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Chapter 1
Introduction to Designing Experiments

A Beginner’s Tutorial

This tutorial chapter introduces you to the design of experiments (DOE) using JMP’s custom designer. 
It gives a general understanding of how to design an experiment using JMP. Refer to subsequent chap-
ters in this book for more examples and procedures on how to design an experiment for your specific 
project.
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About Designing Experiments

About Designing Experiments
Increasing productivity and improving quality are important goals in any business. The methods for 
determining how to increase productivity and improve quality are evolving. They have changed from 
costly and time-consuming trial-and-error searches to the powerful, elegant, and cost-effective statisti-
cal methods that JMP provides.

Designing experiments in JMP is centered around factors, responses, a model, and runs. JMP helps you 
determine if and how a factor affects a response.

My First Experiment
If you have never used JMP to design an experiment, this section shows you how to design the experi-
ment and how to understand JMP’s output.

Tip: The recommended way to create an experiment is to use the custom designer. JMP also provides 
classical designs for use in textbook situations.

The Situation

Your goal is to find the best way to microwave a bag of popcorn. Because you have some experience 
with this, it is easy to decide on reasonable ranges for the important factors:

• how long to cook the popcorn (between 3 and 5 minutes)

• what level of power to use on the microwave oven (between settings 5 and 10)

• which brand of popcorn to use (Top Secret or Wilbur)

When a bag of popcorn is popped, most of the kernels pop, but some remain unpopped. You prefer to 
have all (or nearly all) of the kernels popped and no (or very few) unpopped kernels. Therefore, you 
define “the best popped bag” based on the ratio of popped kernels to the total number of kernels.

A good way to improve any procedure is to conduct an experiment. For each experimental run, JMP’s 
custom designer determines which brand to use, how long to cook each bag in the microwave and what 
power setting to use. Each run involves popping one bag of corn. After popping a bag, enter the total 
number of kernels and the number of popped kernels into the appropriate row of a JMP data table. 
After doing all the experimental runs, use JMP’s model fitting capabilities to do the data analysis. Then, 
you can use JMP’s profiling tools to determine the optimal settings of popping time, power level, and 
brand.

Step 1: Design the Experiment

The first step is to select DOE > Custom Design (Figure 1.1). Then, define the responses and factors.



4 Introduction to Designing Experiments Chapter 1
My First Experiment

Figure 1.1 Select the Custom Designer

Define the Responses: Popped Kernels and Total Kernels

There are two responses in this experiment:

• the number of popped kernels 

• the total number of kernels in the bag. After popping the bag add the number of unpopped kernels 
to the number of popped kernels to get the total number of kernels in the bag.

By default, the custom designer contains one response labeled Y (Figure 1.2). 

Figure 1.2 Open and Close the Responses Panel by Clicking the Disclosure Icon

You want to add a second response to the Responses panel and change the names to be more descrip-
tive:

1 To rename the Y response, double-click the name and type “Number Popped.” Since you want to 
increase the number of popped kernels, leave the goal at Maximize. 

2 To add the second response (total number of kernels), click Add Response and choose None from 
the menu that appears. JMP labels this response Y2 by default.

3 Double-click Y2 and type “Total Kernels” to rename it.

The completed Responses panel looks like Figure 1.3.
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My First Experiment

Figure 1.3 Renamed Responses with Specified Goals

Define the Factors: Time, Power, and Brand

In this experiment, the factors are:

• brand of popcorn (Top Secret or Wilbur)

• cooking time for the popcorn (3 or 5 minutes)

• microwave oven power level (setting 5 or 10)

In the Factors panel, add Brand as a two-level categorical factor:

1 Click Add Factor and select Categorical > 2 Level. 

2 To change the name of the factor (currently named X1), double-click on its name and type Brand.

3 To rename the default levels (L1 and L2), click the level names and type Top Secret and Wilbur.

Add Time as a two-level continuous factor:

4 Click Add Factor and select Continuous. 

5 Change the default name of the factor (X2) by double-clicking it and typing Time.

6 Likewise, to rename the default levels (–1 and 1) as 3 and 5, click the current level name and type in 
the new value.

Add Power as a two-level continuous factor:

7 Click Add Factor and select Continuous. 

8 Change the name of the factor (currently named X3) by double-clicking it and typing Power.

9 Rename the default levels (currently named -1 and 1) as 5 and 10 by clicking the current name and 
typing. The completed Factors panel looks like Figure 1.4.

Figure 1.4 Renamed Factors with Specified Values

10 Click Continue.
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Step 2: Define Factor Constraints

The popping time for this experiment is either 3 or 5 minutes, and the power settings on the micro-
wave are 5 and 10. From experience, you know that

• popping corn for a long time on a high setting tends to scorch kernels.

• not many kernels pop when the popping time is brief and the power setting is low.

You want to constrain the combined popping time and power settings to be less than or equal to 13, 
but greater than or equal to 10. To define these limits:

1 Open the Constraints panel by clicking the disclosure button beside the Define Factor Constraints 
title bar (see Figure 1.5). 

2 Click the Add Constraint button twice, once for each of the known constraints.

3 Complete the information, as shown to the right in Figure 1.5. These constraints tell the Custom 
Designer to avoid combinations of Power and Time that sum to less than 10 and more than 13. Be 
sure to change <= to >= in the second constraint.

The area inside the parallelogram, illustrated on the left in Figure 1.5, is the allowable region for the 
runs. You can see that popping for 5 minutes at a power of 10 is not allowed and neither is popping for 
3 minutes at a power of 5.

Figure 1.5 Defining Factor Constraints

Step 3: Add Interaction Terms

You are interested in the possibility that the effect of any factor on the proportion of popped kernels 
may depend on the value of some other factor. For example, the effect of a change in popping time for 
the Wilbur popcorn brand could be larger than the same change in time for the Top Secret brand. This 
kind of synergistic effect of factors acting in concert is called a two-factor interaction. You can examine 
all possible two-factor interactions in your a priori model of the popcorn popping process.

1 Click Interactions in the Model panel and select 2nd. JMP adds two-factor interactions to the 
model as shown to the left in Figure 1.6.

In addition, you suspect the graph of the relationship between any factor and any response might be 
curved. You can see whether this kind of curvature exists with a quadratic model formed by adding the 
second order powers of effects to the model, as follows.

2 Click Powers and select 2nd to add quadratic effects of the continuous factors, Power and Time.



1
In

tro
d

u
c
tio

n
Chapter 1 Introduction to Designing Experiments 7

My First Experiment

The completed Model should look like the one to the right in Figure 1.6.

Figure 1.6 Add Interaction and Power Terms to the Model

Step 4: Determine the Number of Runs

The Design Generation panel in Figure 1.7 shows the minimum number of runs needed to perform 
the experiment with the effects you’ve added to the model. You can use that minimum or the default 
number of runs, or you can specify your own number of runs as long as that number is more than the 
minimum. JMP has no restrictions on the number of runs you request. For this example, use the 
default number of runs, 16. Click Make Design to continue.

Figure 1.7 Model and Design Generation Panels

Step 5: Check the Design

When you click Make Design, JMP generates and displays a design, as shown on the left in Figure 1.8. 
Note that because JMP uses a random seed to generate custom designs and there is no unique optimal 
design for this problem, your table may be different than the one shown here. You can see in the table 
that the custom design requires 8 runs using each brand of popcorn. 
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Scroll to the bottom of the Custom Design window and look at the Output Options area (shown to the 
right in Figure 1.8. The Run Order option lets you designate the order you want the runs to appear in 
the data table when it is created. Keep the selection at Randomize so the rows (runs) in the output table 
appear in a random order. 

Now click Make Table in the Output Options section.

Figure 1.8 Design and Output Options Section of Custom Designer

The resulting data table (Figure 1.9) shows the order in which you should do the experimental runs and 
provides columns for you to enter the number of popped and total kernels. According to the table, 
cook the first bag of Top Secret for five minutes using a power setting of eight (rounded value). Next, 
cook a bag of Wilbur for five minutes at a power of eight, then cook Top Secret for three minutes using 
a power setting of seven, and so forth.

You do not have fractional control over the power and time settings on a microwave oven, so you 
should round the power and time settings, as shown in the data table. Although this altered design is 
slightly less optimal than the one the custom designer suggested, the difference is negligible. 

Tip: Note that optionally, before clicking Make Table in the Output Options, you could select Sort 
Left to Right in the Run Order menu to have JMP present the results in the data table according to the 
brand. We have conducted this experiment for you and placed the results, called Popcorn DOE 
Results.jmp, in the Sample Data folder installed with JMP. These results have the columns sorted from 
left to right
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Figure 1.9 JMP Data Table of Design Runs Generated by Custom Designer

Step 6: Gather and Enter the Data

Pop the popcorn according to the design JMP provided. Then, count the number of popped and 
unpopped kernels left in each bag. Finally, enter the numbers shown below into the appropriate col-
umns of the data table. 

We have conducted this experiment for you and placed the results in the Sample Data folder installed 
with JMP. To see the results, open Popcorn DOE Results.jmp from the Design Experiment folder in 
the sample data. The data table is shown in Figure 1.10.

Figure 1.10 Results of the Popcorn DOE Experiment

results from 
experiment

scripts to 
analyze data
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Step 7: Analyze the Results

After the experiment is finished and the number of popped kernels and total kernels have been entered 
into the data table, it is time to analyze the data. The design data table has a script, labeled Model, that 
shows in the top left panel of the table. When you created the design, a standard least squares analysis 
was stored in the Model script with the data table. 

1 Click the red triangle for Model and select Run Script. 

The default fitting personality in the model dialog is Standard Least Squares. One assumption of 
standard least squares is that your responses are normally distributed. But because you are modeling the 
proportion of popped kernels it is more appropriate to assume that your responses come from a bino-
mial distribution. You can use this assumption by changing to a generalized linear model.

2 Change the Personality to Generalized Linear Model, Distribution to Binomial, and Link Func-
tion to Logit, as shown in Figure 1.11.

Figure 1.11 Fitting the Model

3 Click Run Model. 

4 Scroll down to view the Effect Tests table (Figure 1.12) and look in the column labeled Prob>Chisq. 
This column lists p-values. A low p-value (a value less than 0.05) indicates that results are statistically 
significant. There are asterisks that identify the low p-values. You can therefore conclude that, in this 
experiment, all the model effects except for Time*Time are highly significant. You have confirmed 
that there is a strong relationship between popping time (Time), microwave setting (Power), pop-
corn brand (Brand), and the proportion of popped kernels.
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Figure 1.12 Investigating p-Values

To further investigate, use the Prediction Profiler to see how changes in the factor settings affect the 
numbers of popped and unpopped kernels:

1 Choose Profilers > Profiler from the red triangle menu on the Generalized Linear Model Fit title 
bar. The Prediction Profiler is shown at the bottom of the report. Figure 1.13 shows the Prediction 
Profiler for the popcorn experiment. Prediction traces are displayed for each factor. 

Figure 1.13 The Prediction Profiler

2 Move the vertical red dotted lines to see the effect that changing a factor value has on the response. 
For example, drag the red line in the Time graph right and left (Figure 1.14). 

p-values indicate significance. 
Values with * beside them are 
p-values that indicate the results 
are statistically significant.

Prediction trace 
for Brand

predicted value 
of the response

95% confidence 
interval on the mean 
response

Factor values (here, time = 4)

Prediction trace 
for Time

Prediction trace 
for PowerDisclosure icon to 

open or close the 
Prediction Profiler
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Figure 1.14 Moving the Time Value from 4 to Near 5

As Time increases and decreases, the curved Time and Power prediction traces shift their slope and 
maximum/minimum values. The substantial slope shift tells you there is an interaction (synergistic 
effect) involving Time and Power.

Furthermore, the steepness of a prediction trace reveals a factor’s importance. Because the prediction 
trace for Time is steeper than that for Brand or Power (see Figure 1.14), you can see that cooking time 
is more important than the brand of popcorn or the microwave power setting.

Now for the final steps.

3 Click the red triangle icon in the Prediction Profiler title bar and select Desirability Functions.

4 Click the red triangle icon in the Prediction Profiler title bar and select Maximize Desirability. JMP 
automatically adjusts the graph to display the optimal settings at which the most kernels will be 
popped (Figure 1.15). 

Our experiment found how to cook the bag of popcorn with the greatest proportion of popped kernels: 
use Top Secret, cook for five minutes, and use a power level of 8. The experiment predicts that cooking 
at these settings will yield greater than 96.5% popped kernels.
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Figure 1.15 The Most Desirable Settings

The best settings are: 

• the Top Secret brand

• cooking time at 5

• power set at 8





Chapter 2
Examples Using the Custom Designer

The use of statistical methods in industry is increasing. Arguably, the most cost-beneficial of these 
methods for quality and productivity improvement is statistical design of experiments. A trial-and 
-error search for the vital few factors that most affect quality is costly and time-consuming. The purpose 
of experimental design is to characterize, predict, and then improve the behavior of any system or pro-
cess. Designed experiments are a cost-effective way to accomplish these goals.

JMP’s custom designer is the recommended way to describe your process and create a design that works 
for your situation. To use the custom designer, you first enter the process variables and constraints, then 
JMP tailors a design to suit your unique case. This approach is more general and requires less experi-
ence and expertise than previous tools supporting the statistical design of experiments. 

Custom designs accommodate any number of factors of any type. You can also control the number of 
experimental runs. This makes custom design more flexible and more cost effective than alternative 
approaches.

This chapter presents several examples showing the use of custom designs. It shows how to drive its 
interface to build a design using this easy step-by-step approach:

Describe Design Collect Fit Predict

Key mathematical steps: appropriate 
computer-based tools are empowering.

Key engineering steps: process knowledge 
and engineering judgement are important.

Identify factors 
and responses.

Compute design 
for maximum 
information from 
runs.

Use design to set 
factors: measure 
response for each 
run.

Compute best fit 
of mathematical 
model to data 
from test runs.

Use model to find 
best factor settings 
for on-target 
responses and 
minimum variability.
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Creating Screening Experiments
You can use the screening designer in JMP to create screening designs, but the custom designer is more 
flexible and general. The straightforward screening examples described below show that ‘custom’ does 
not mean ‘exotic.’ The custom designer is a general purpose design environment that can create screen-
ing designs.

Creating a Main-Effects-Only Screening Design

To create a main-effects-only screening design using the custom designer:

1 Select DOE > Custom Design.

2 Enter six continuous factors into the Factors panel (see “Step 1: Design the Experiment,” p. 3, for 
details). Figure 2.1 shows the six factors.

3 Click Continue. The default model contains only the main effects. 

4 Using the default of eight runs, click Make Design. 

Note to DOE experts: The result is a resolution-three screening design. All the main effects are 
estimable, but they are confounded with two factor interactions. 

Figure 2.1 A Main-Effects-Only Screening Design

5 Click the disclosure button (  on Windows/Linux and  on the Macintosh) to open the 
Alias Matrix. Figure 2.2 shows the Alias Matrix, which is a table of zeros, ones, and negative ones.
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The Alias Matrix shows how the coefficients of the constant and main effect terms in the model are 
biased by any active two-factor interaction effects not already added to the model. The column labels 
identify interactions. For example, the columns labeled 2 6 and 3 4 in the table have a 1 in the row for 
X1. This means that the expected value of the main effect of X1 is actually the sum of the main effect of 
X1 and the two-factor interactions X2*X6 and X3*X4. You are assuming that these interactions are neg-
ligible in size compared to the effect of X1. 

Figure 2.2 The Alias Matrix

Note to DOE experts: The Alias matrix is a generalization of the confounding pattern in frac-
tional factorial designs. 

Creating a Screening Design to Fit All Two-Factor Interactions

There is risk involved in designs for main effects only. The risk is that two-factor interactions, if they 
are strong, can confuse the results of such experiments. To avoid this risk, you can create experiments 
resolving all the two-factor interactions. 

Note to DOE experts: The result in this example is a resolution-five screening design. Two-factor 
interactions are estimable but are confounded with three-factor interactions. 

1 Select DOE > Custom Design.

2 Enter five continuous factors into the Factors panel (see “Step 1: Design the Experiment” in 
Chapter 1, for details).

3 Click Continue.

4 In the Model panel, select Interactions > 2nd.

5 In the Design Generation Panel choose Minimum for Number of Runs and click Make Design.

Figure 2.3 shows the runs of the two-factor design with all interactions. The sample size, 16 (a power of 
two) is large enough to fit all the terms in the model. The values in your table may be different from 
those shown below.



2
E

x
a
m

p
le

s
Chapter 2 Examples Using the Custom Designer 19

Creating Screening Experiments

Figure 2.3 All Two-Factor Interactions 

6 Click the disclosure button to open the Design Evaluation outlines, then open Alias Matrix. 
Figure 2.4 shows the alias matrix table of zeros and ones. The columns labels identify an interaction. 
For example, the column labelled 1 2 refers to the interaction of the first and second effect, the col-
umn labelled 2 3 refers to the interaction between the second and third effect, and so forth. 

Look at the column labelled 1 2. There is only one value of 1 in that column. All others are 0. The 1 
occurs in the row labelled X1*X2. All the other rows and columns are similar. This means that the 
expected value of the two-factor interaction X1*X2 is not biased by any other terms. All the rows 
above the row labelled X1*X2 contain only zeros, which means that the Intercept and main effect 
terms are not biased by any two-factor interactions.

Figure 2.4 Alias Matrix Showing all Two-Factor Interactions Clear of all Main Effects

Open outline 
nodes
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A Compromise Design Between Main Effects Only and All Interactions

In a screening situation, suppose there are six continuous factors and resources for n = 16 runs. The 
first example in this section showed an eight-run design that fit all the main effects. With six factors, 
there are 15 possible two-factor interactions. The minimum number of runs that could fit the constant, 
six main effects and 15 two-factor interactions is 22. This is more than the resource budget of 16 runs. 
It would be good to find a compromise between the main-effects only design and a design capable of 
fitting all the two-factor interactions.

This example shows how to obtain such a design compromise using the custom designer.

1 Select DOE > Custom Design.

2 Define six continuous factors (X1 - X6).

3 Click Continue. The model includes the main effect terms by default. The default estimability of 
these terms is Necessary. 

4 Click the Interactions button and choose 2nd to add all the two-factor interactions.

5 Select all the interaction terms and click the current estimability (Necessary) to reveal a menu. 
Change Necessary to If Possible, as shown in Figure 2.5. 

Figure 2.5 Model for Six-Variable Design with Two-Factor Interactions Designated If Possible

6 Type 16 in the User Specified edit box in the Number of Runs section, as shown. Although the 
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desired number of runs (16) is less than the total number of model terms, the custom designer 
builds a design to estimate as many two-factor interactions as possible.

7 Click Make Design.

After the custom designer creates the design, click the disclosure button beside Design Evaluation to 
open the Alias Matrix (Figure 2.6). The values in your table may be different from those shown below, 
but with a similar pattern.

Figure 2.6 Alias Matrix

All the rows above the row labelled X1*X2 contain only zeros, which means that the Intercept and main 
effect terms are not biased by any two-factor interactions. The row labelled X1*X2 has the value 0.333 
in the 1 2 column and the same value in the 4 6 column. That means the expected value of the estimate 
for X1*X2 is actually the sum of X1*X2 and any real effect due to X4*X6. 

Note to DOE experts: The result in this particular example is a resolution-four screening design. 
Two-factor interactions are estimable but are aliased with other two-factor interactions. 

Creating ‘Super’ Screening Designs

This section shows how to use the technique shown in the previous example to create ‘super’ (supersat-
urated) screening designs. Supersaturated designs have fewer runs than factors, which makes them 
attractive for factor screening when there are many factors and experimental runs are expensive.

In a saturated design, the number of runs equals the number of model terms. In a supersaturated 
design, as the name suggests, the number of model terms exceeds the number of runs (Lin, 1993). A 
supersaturated design can examine dozens of factors using fewer than half as many runs as factors.
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The Need for Supersaturated Designs

The 27–4 and the 215–11 fractional factorial designs available using the screening designer are both satu-
rated with respect to a main effects model. In the analysis of a saturated design, you can (barely) fit the 
model, but there are no degrees of freedom for error or for lack of fit. Until recently, saturated designs 
represented the limit of efficiency in designs for screening.

Factor screening relies on the sparsity principle. The experimenter expects that only a few of the factors 
in a screening experiment are active. The problem is not knowing which are the vital few factors and 
which are the trivial many. It is common for brainstorming sessions to turn up dozens of factors. Yet, in 
practice, screening experiments rarely involve more than ten factors. What happens to winnow the list 
from dozens to ten or so?

If the experimenter is limited to designs that have more runs than factors, then dozens of factors trans-
late into dozens of runs. Often, this is not economically feasible. The result is that the factor list is 
reduced without the benefit of data. In a supersaturated design, the number of model terms exceeds the 
number of runs, and you can examine dozens of factors using less than half as many runs.

There are drawbacks: 

• If the number of active factors approaches the number of runs in the experiment, then it is likely 
that these factors will be impossible to identify. A rule of thumb is that the number of runs should 
be at least four times larger than the number of active factors. If you expect that there might be as 
many as five active factors, you should have at least 20 runs.

• Analysis of supersaturated designs cannot yet be reduced to an automatic procedure. However, using 
forward stepwise regression is reasonable and the new Screening platform (Analyze > Modeling > 
Screening) offers a more streamlined analysis.

Example: Twelve Factors in Eight Runs

As an example, consider a supersaturated design with twelve factors. Using model terms designated If 
Possible provides the software machinery for creating a supersaturated design.

In the last example, two-factor interaction terms were specified If Possible. In a supersaturated design, 
all terms—including main effects—are If Possible. Note in Figure 2.7, the only primary term is the 
intercept. 

To see an example of a supersaturated design with twelve factors in eight runs:

1 Select DOE > Custom Design.

2 Add 12 continuous factors and click Continue.

3 Highlight all terms except the Intercept and click the current estimability (Necessary) to reveal the 
menu. Change Necessary to If Possible, as shown in Figure 2.7.
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Figure 2.7 Changing the Estimability

4 The desired number of runs is eight so type 8 in the User Specified edit box in the Number of 
Runs section.

5 Click the red triangle on the Custom Design title bar and select Simulate Responses, as shown in 
Figure 2.8.

Figure 2.8 Simulating Responses

6 Click Make Design, then click Make Table. A window named Simulate Responses and a design 
table appear, similar to the one in Figure 2.9. The Y column values are controlled by the coefficients 
of the model in the Simulate Responses window. The values in your table may be different from 
those shown below.
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Figure 2.9 Simulated Responses and Design Table

7 Change the default settings of the coefficients in the Simulate Responses dialog to match those in 
Figure 2.10 and click Apply. The numbers in the Y column change. Because you have set X2 and 
X10 as active factors in the simulation, the analysis should be able to identify the same two factors.

Note that random noise is added to the Y column formula, so the numbers you see might not necessar-
ily match those in the figure. The values in your table may be different from those shown below.

Figure 2.10 Give Values to Two Main Effects and Specify the Standard Error as 0.5

To identify active factors using stepwise regression:

1 To run the Model script in the design table, click the red triangle beside Model and select Run 
Script. 

2 Change the Personality in the Model Specification window from Standard Least Squares to 
Stepwise.

3 Click Run Model on the Fit Model dialog. 

4 In the resulting display click the Step button two times. JMP enters the factors with the largest 
effects. From the report that appears, you should identify two active factors, X2 and X10, as shown 
in Figure 2.11. The step history appears in the bottom part of the report. Because random noise is 
added, your estimates will be slightly different from those shown below.
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Figure 2.11 Stepwise Regression Identifies Active Factors

Note: This example defines two large main effects and sets the rest to zero. In real-world situations, it 
may be less likely to have such clearly differentiated effects.

Screening Designs with Flexible Block Sizes

When you create a design using the Screening designer (DOE > Screening), the available block sizes for 
the listed designs are a power of two. However, custom designs in JMP can have blocks of any size. The 
blocking example shown in this section is flexible because it is using three runs per block, instead of a 
power of two.

After you select DOE > Custom Design and enter factors, the blocking factor shows only one level in 
the Values section of the Factors panel because the sample size is unknown at this point. After you com-
plete the design, JMP shows the appropriate number of blocks, which is calculated as the sample size 
divided by the number of runs per block.

For example, Figure 2.12 shows that when you enter three continuous factors and one blocking factor 
with three runs per block, only one block appears in the Factors panel.
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Figure 2.12 One Block Appears in the Factors Panel

The default sample size of nine requires three blocks. After you click Continue, there are three blocks in 
the Factors panel (Figure 2.13). This is because the default sample size is nine, which requires three 
blocks with three runs each.

Figure 2.13 Three Blocks in the Factors Panel

If you enter 24 runs in the User Specified box of the Number of Runs section, the Factors panel 
changes and now contains 8 blocks (Figure 2.14).
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Figure 2.14 Number of Runs is 24 Gives Eight Blocks

If you add all the two-factor interactions and change the number of runs to 15, three runs per block 
produces five blocks (as shown in Figure 2.15), so the Factors panel displays five blocks in the Values 
section. 

Figure 2.15 Changing the Runs to 15
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Click Make Design, then click the disclosure button (  on Windows/Linux and  on the 
Macintosh) to open the Relative Variance of Coefficients report. Figure 2.16 shows the variance of each 
coefficient in the model relative to the unknown error variance.

The values in your table may be slightly different from those shown below. Notice that the variance of 
each coefficient is about one-tenth the error variance and that all the variances are roughly the same 
size. The error variance is assumed to be 1.

Figure 2.16 Table of Relative Variance of the Model Coefficients

The main question here is whether the relative size of the coefficient variance is acceptably small. If not, 
adding more runs (18 or more) will lower the variance of each coefficient.

For more details, see “The Relative Variance of Coefficients and Power Table,” p. 68. 

Note to DOE experts: There are four rows associated with X4 (the block factor). That is because 
X4 has 5 blocks and, therefore, 4 degrees of freedom. Each degree of freedom is associated with one 
unknown coefficient in the model.

Checking for Curvature Using One Extra Run

In screening designs, experimenters often add center points and other check points to a design to help 
determine whether the assumed model is adequate. Although this is good practice, it is also ad hoc. The 
custom designer provides a way to improve on this ad hoc practice while supplying a theoretical founda-
tion and an easy-to-use interface for choosing a design robust to the modeling assumptions.

The purpose of check points in a design is to provide a detection mechanism for higher-order effects 
that are contained in the assumed model. These higher-order terms are called potential terms. (Let q 
denote the potential terms, designated If Possible in JMP.) The assumed model consists of the primary 
terms. (Let p denote the primary terms designated Necessary in JMP.)

To take advantage of the benefits of the approach using If Possible model terms, the sample size should 
be larger than the number of Necessary (primary) terms but smaller than the sum of the Necessary 
and If Possible (potential) terms. That is, p < n < p+q. The formal name of the approach using If 
Possible model terms is Bayesian D-Optimal design. This type of design allows the precise estimation of 
all of the Necessary terms while providing omnibus detectability (and some estimability) for the If 
Possible terms.
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For a two-factor design having a model with an intercept, two main effects, and an interaction, there 
are p = 4 primary terms. When you enter this model in the custom designer, the default minimum runs 
is a four-run design with the factor settings shown in Figure 2.17.

Figure 2.17 Two Continuous Factors with Interaction

Now suppose you can afford an extra run (n = 5). You would like to use this point as a check point for 
curvature. If you leave the model the same and increase the sample size, the custom designer replicates 
one of the four vertices. Replicating any run is the optimal choice for improving the estimates of the 
terms in the model, but it provides no way to check for lack of fit.

Adding the two quadratic terms to the model makes a total of six terms. This is a way to model curva-
ture directly. However, to do this the custom designer requires two additional runs (at a minimum), 
which exceeds your budget of five runs.

The Bayesian D-Optimal design provides a way to check for curvature while adding only one extra run. 
To create this design:

1 Select DOE > Custom Design.

2 Define two continuous factors (X1 and X2).

3 Click Continue. 

4 Choose 2nd from the Interactions menu in the Model panel. The results appear as shown in 
Figure 2.18.

Figure 2.18 Second-Level Interactions

5 Choose 2nd from the Powers button in the Model panel. This adds two quadratic terms.

6 Select the two quadratic terms (X1*X1 and X2*X2) and click the current estimability (Necessary) to 
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see the menu and change Necessary to If Possible, as shown in Figure 2.19. 

Figure 2.19 Changing the Estimability

Now, the p = 4 primary terms (the intercept, two main effects, and the interaction) are designated as 
Necessary while the q = 2 potential terms (the two quadratic terms) are designated as If Possible. The 
desired number of runs, five, is between p = 4 and p + q = 6. 

7 Enter 5 into the User Specified edit box in the Number of Runs section of the Design Generation 
panel.

8 Click Make Design. The resulting factor settings appear in Figure 2.20. The values in your design 
may be different from those shown below.

Figure 2.20 Five-Run Bayesian D-Optimal Design

9 Click Make Table to create a JMP data table of the runs.

10 Create the overlay plot in Figure 2.21 with Graph > Overlay Plot, and assign X1 as Y and X2 as X. 
The overlay plot illustrates how the design incorporates the single extra run. In this example the 
design places the factor settings at the center of the design instead of at one of the corners.
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Figure 2.21 Overlay Plot of Five-run Bayesian D-Optimal Design

Creating Response Surface Experiments
Response surface experiments traditionally involve a small number (generally 2 to 8) of continuous fac-
tors. The a priori model for a response surface experiment is usually quadratic. 

In contrast to screening experiments, researchers use response surface experiments when they already 
know which factors are important. The main goal of response surface experiments is to create a predic-
tive model of the relationship between the factors and the response. Using this predictive model allows 
the experimenter to find better operating settings for the process.

In screening experiments one measure of the quality of the design is the size of the relative variance of 
the coefficients. In response surface experiments, the prediction variance over the range of the factors is 
more important than the variance of the coefficients. One way to visualize the prediction variance is 
JMP’s prediction variance profile plot. This plot is a powerful diagnostic tool for evaluating and com-
paring response surface designs.

Exploring the Prediction Variance Surface

The purpose of the example below is to generate and interpret a simple Prediction Variance Profile Plot. 
Follow the steps below to create a design for a quadratic model with a single continuous factor.

1 Select DOE > Custom Design.

2 Add one continuous factor by selecting Add Factor > Continuous (Figure 2.22), and click 
Continue.

3 In the Model panel, select Powers > 2nd to create a quadratic term (Figure 2.22).
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Figure 2.22 Adding a Factor and a Quadratic Term

4 In the Design Generation panel, use the default number of runs (six) and click Make Design 
(Figure 2.23). The number of runs is inversely proportional to the size of variance of the predicted 
response. As the number of runs increases, the prediction variances decrease. 

Figure 2.23 Using the Default Number of Runs

5 Click the disclosure button (  on Windows/Linux and  on the Macintosh) to open the 
Design Evaluation outline node, and then the Prediction Variance Profile, as shown in 
Figure 2.24. 

For continuous factors, the initial setting is at the mid-range of the factor values. For categorical factors, 
the initial setting is the first level. If the design model is quadratic, then the prediction variance func-
tion is quartic. The y-axis is the relative variance of prediction of the expected value of the response. 

In this design, the three design points are –1, 0, and 1. The prediction variance profile shows that the 
variance is a maximum at each of these points on the interval –1 to 1. 

Figure 2.24 Prediction Profile for Single Factor Quadratic Model

The prediction variance is relative to the error variance. When the relative prediction variance is one, 
the absolute variance is equal to the error variance of the regression model. More detail on the Predic-
tion Variance Profiler is in “Understanding Design Evaluation,” p. 64.

6 To compare profile plots, click the Back button and choose Minimum in the Design Generation 
panel, which gives a sample size of three. 

7 Click Make Design and then open the Prediction Variance Profile again.
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Now you see a curve that has the same shape as the previous plot, but the maxima are at one instead of 
0.5. Figure 2.25 compares plots for a sample size of six and sample size of three for this quadratic 
model. You can see the prediction variance increase as the sample size decreases. Since the prediction 
variance is inversely proportional to the sample size, doubling the number of runs halves the prediction 
variance. These profiles show settings for the maximum variance and minimum variance, for sample 
sizes six (top charts) and sample size three (bottom charts). The axes on the bottom plots are adjusted to 
match the axes on the top plot.

Figure 2.25 Comparison of Prediction Variance Profiles

Tip: Control-click (Command-click on the Mac) on the factor to set a factor level precisely.

8 To create an unbalanced design, click the Back button and enter a sample size of 7 in the User Spec-
ified text edit box in the Design Generation panel, then click Make Design. The results are shown 
in Figure 2.26. 

You can see that the variance of prediction at –1 is lower than the other sample points (its value is 0.33 
instead of 0.5). The symmetry of the plot is related to the balance of the factor settings. When the 
design is balanced, the plot is symmetric, as shown in Figure 2.25. When the design is unbalanced, the 
prediction plot might not be symmetric, as shown in Figure 2.26.
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Figure 2.26 Sample Size of Seven for the One-Factor Quadratic Model

Introducing I-Optimal Designs for Response Surface Modeling

The custom designer generates designs using a mathematical optimality criterion. All the designs in this 
chapter so far have been D-Optimal designs. D-Optimal designs are most appropriate for screening 
experiments because the optimality criterion focuses on precise estimates of the coefficients. If an exper-
imenter has precise estimates of the factor effects, then it is easy to tell which factors’ effects are impor-
tant and which are negligible. However, D-Optimal designs are not as appropriate for designing 
experiments where the primary goal is prediction.

I-Optimal designs minimize the average prediction variance inside the region of the factors. This makes 
I-Optimal designs more appropriate for prediction. As a result I-Optimality is the recommended crite-
rion for JMP response surface designs. 

An I-Optimal design tends to place fewer runs at the extremes of the design space than does a D-Opti-
mal design. As an example, consider a one-factor design for a quadratic model using n = 12 experimen-
tal runs. The D-Optimal design for this model puts four runs at each end of the range of interest and 
four runs in the middle. The I-Optimal design puts three runs at each end point and six runs in the 
middle. In this case, the D-Optimal design places two-thirds of its runs at the extremes versus one-half 
for the I-Optimal design.

Figure 2.27 compares prediction variance profiles of the one-factor I- and D-Optimal designs for a qua-
dratic model with (n = 12) runs. The variance function for the I-Optimal design is less than the corre-
sponding function for the D-Optimal design in the center of the design space; the converse is true at 
the edges.

Figure 2.27 Prediction Variance Profiles for 12-Run I-Optimal (left) and D-Optimal (right) Designs

Prediction variance at X1= 0 Prediction variance at X1= –1
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At the center of the design space, the average variance (relative to the error variance) for the I-Optimal 
design is 0.1667 compared to the D-Optimal design, which is 0.25. This means that confidence inter-
vals for prediction will be nearly 10% shorter on average for the I-Optimal design.

To compare the two design criteria, create a one-factor design with a quadratic model that uses the 
I-Optimality criterion, and another one that uses D-Optimality:

1 Select DOE > Custom Design.

2 Add one continuous factor: X1.

3 Click Continue.

4 Click the RSM button in the Model panel to make the design I-Optimal.

5 Change the number of runs to 12.

6 Click Make Design.

7 Click the disclosure button (  on Windows/Linux and  on the Macintosh) to open the 
Prediction Variance Profile, as shown on the left in Figure 2.27.

8 Repeat the same steps to create a D-Optimal design, but select Optimality Criterion > Make 
D-Optimal Design from the red triangle menu on the custom design title bar. The results in the Pre-
diction Variance Profile should look the same as those on the right in Figure 2.27.

A Three-Factor Response Surface Design

In higher dimensions, the I-Optimal design continues to place more emphasis on the center of the 
region of the factors. The D-Optimal and I-Optimal designs for fitting a full quadratic model in three 
factors using 16 runs are shown in Figure 2.28. 

To compare the two design criteria, create a three-factor design that uses the I-Optimality criterion, and 
another one that uses D-Optimality:

1 Select DOE > Custom Design.

2 Add three continuous factors: X1, X2, and X3.

3 Click Continue.

4 Click the RSM button in the Model panel to add interaction and quadratic terms to the model and 
to change the default optimality criterion to I-Optimal.

5 Use the default of 16 runs.

6 Click Make Design.

7 The design is shown in the Design panel (the left in Figure 2.28).

8 If you want to create a D-Optimal design for comparison, repeat the same steps but select 
Optimality Criterion > Make D-Optimal Design from the red triangle menu on the custom design 
title bar. The design should look similar to those on the right in Figure 2.28. The values in your 
design may be different from those shown below.
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Figure 2.28 16-run I-Optimal and D-Optimal designs for RSM Model

Profile plots of the variance function are displayed in Figure 2.29. These plots show slices of the vari-
ance function as a function of each factor, with all other factors fixed at zero. The I-Optimal design has 
the lowest prediction variance at the center. Note that there are two center points in this design.

The D-Optimal design has no center points and its prediction variance at the center of the factor space 
is almost three times the variance of the I-Optimal design. The variance at the vertices of the D-Opti-
mal design is not shown. However, note that the D-Optimal design predicts better than the I-Optimal 
design near the vertices.

Figure 2.29 Variance Profile Plots for 16 run I-Optimal and D-Optimal RSM Designs

Response Surface with a Blocking Factor

It is not unusual for a process to depend on both qualitative and quantitative factors. For example, in 
the chemical industry, the yield of a process might depend not only on the quantitative factors temper-
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ature and pressure, but also on such qualitative factors as the batch of raw material and the type of reac-
tor. Likewise, an antibiotic might be given orally or by injection, a qualitative factor with two levels. 
The composition and dosage of the antibiotic could be quantitative factors (Atkinson and Donev, 
1992).

The response surface designer (described in “Response Surface Designs,” p. 115) only deals with quan-
titative factors. You could use the response surface designer to produce a Response Surface Model 
(RSM) design with a qualitative factor by replicating the design over each level of the factor. But, this is 
unnecessarily time-consuming and expensive. Using custom designer is simpler and more cost-effective 
because fewer runs are required. The following steps show how to accommodate a blocking factor in a 
response surface design using the custom designer:

1 First, define two continuous factors (X1 and X2).

2 Now, click Add Factor and select Blocking > 4 runs per block to create a blocking factor(X3). The 
blocking factor appears with one level, as shown in Figure 2.30, but the number of levels adjusts 
later to accommodate the number of runs specified for the design.

Figure 2.30 Add Two Continuous Factors and a Blocking Factor

3 Click Continue, and then click RSM in the Model panel to add the quadratic terms to the model 
(Figure 2.31). This automatically changes the recommended optimality criterion from D-Optimal 
to I-Optimal. Note that when you click RSM, a message reminds you that nominal factors (such as 
the blocking factor) cannot have quadratic effects.

Figure 2.31 Add Response Surface Terms

4 Enter 12 in the User Specified text edit box in the Design Generation panel, and note that the Fac-
tors panel now shows the Blocking factor, X3, with three levels (Figure 2.32). Twelve runs defines 
three blocks with four runs per block.
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Figure 2.32 Blocking Factor Now Shows Three Levels

5 Click Make Design.

6 In the Output Options, select Sort Right to Left from the Run Order list. 

7 Click Make Table to see an I-Optimal table similar to the one on the left in Figure 2.33.

Figure 2.33 compares the results of a 12-run I-Optimal design and a 12-run D-Optimal Design. 

To see the D-Optimal design:

1 Click the Back button. 

2 Click the red triangle icon on the Custom Design title bar and select Optimality Criterion > Make 
D-Optimal Design. 

3 Click Make Design, then click Make Table.

Figure 2.33 JMP Design Tables for 12-Run I-Optimal and D-Optimal Designs

Figure 2.34 gives a graphical view of the designs generated by this example. These plots were generated 
for the runs in each JMP table by choosing Graph > Overlay Plot from the main menu and using the 
blocking factor (X3) as the Grouping variable. 

Note that there is a center point in each block of the I-Optimal design. The D-Optimal design has only 
one center point. The values in your graph may be different from those shown below.
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Figure 2.34 Plots of I-Optimal (left) and D-Optimal (right) Design Points by Block.

Either of the above designs supports fitting the specified model. The D-Optimal design does a slightly 
better job of estimating the model coefficients. The diagnostics (Figure 2.35) for the designs show 
beneath the design tables. In this example, the D-efficiency of the I-Optimal design is about 51%, and 
is 55% for the D-Optimal design.

The I-Optimal design is preferable for predicting the response inside the design region. Using the for-
mulas given in “Technical Discussion,” p. 53, you can compute the relative average variance for these 
designs. The average variance (relative to the error variance) for the I-Optimal design is 0.5 compared 
to 0.59 for the D-Optimal design (See Figure 2.35). This means confidence intervals for prediction will 
be almost 20% longer on average for D-Optimal designs.

Figure 2.35 Design Diagnostics for I-Optimal and D-Optimal Designs
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Creating Mixture Experiments
If you have factors that are ingredients in a mixture, you can use either the custom designer or the spe-
cialized mixture designer. However, the mixture designer is limited because it requires all factors to be 
mixture components and you might want to vary the process settings along with the percentages of the 
mixture ingredients. The optimal formulation could change depending on the operating environment. 
The custom designer can handle mixture ingredients and process variables in the same study. You are 
not forced to modify your problem to conform to the restrictions of a special-purpose design approach. 

Mixtures Having Nonmixture Factors

The following example from Atkinson and Donev (1992) shows how to create designs for experiments 
with mixtures where one or more factors are not ingredients in the mixture. In this example:

• The response is the electromagnetic damping of an acrylonitrile powder.

• The three mixture ingredients are copper sulphate, sodium thiosulphate, and glyoxal. 

• The nonmixture environmental factor of interest is the wavelength of light. 

Though wavelength is a continuous variable, the researchers were only interested in predictions at 
three discrete wavelengths. As a result, they treated it as a categorical factor with three levels. To create 
this custom design:

1 Select DOE > Custom Design.

2 Create Damping as the response. The authors do not mention how much damping is desirable, so 
right-click the goal and create Damping’s response goal to be None.

3 In the Factors panel, add the three mixture ingredients and the categorical factor, Wavelength. The 
mixture ingredients have range constraints that arise from the mechanism of the chemical reaction. 
Rather than entering them by hand, load them from the Sample Data folder that was installed with 
JMP: click the red triangle icon on the Custom Design title bar and select Load Factors. Open 
Donev Mixture Factors.jmp, from the Design Experiment folder in the sample data. The custom 
design panels should now look like those shown in Figure 2.36.

Figure 2.36 Mixture Experiment Response Panel and Factors Panel

The model, shown in Figure 2.37 is a response surface model in the mixture ingredients along with the 
additive effect of the wavelength. To create this model:

1 Click Interactions, and choose 2nd. A warning dialog appears telling you that JMP removes the 



2
E

x
a
m

p
le

s
Chapter 2 Examples Using the Custom Designer 41

Creating Mixture Experiments

main effect terms for non-mixture factors that interact with all the mixture factors. Click OK.

2 In the Design Generation panel, type 18 in the User Specified text edit box (Figure 2.37), which 
results in six runs each for the three levels of the wavelength factor. 

Figure 2.37 Mixture Experiment Design Generation Panel

3 Click Make Design, and then click Make Table. 

The resulting data table is shown in Figure 2.38. The values in your table may be different from those 
shown below.
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Figure 2.38 Mixture Experiment Design Table

Atkinson and Donev also discuss the design where the number of runs is limited to 10. In that case, it 
is not possible to run a complete mixture response surface design for every wavelength. 

To view this:

1 Click the Back button.

2 Remove all the effects by highlighting them and clicking Remove Term.

3 Add the main effects by clicking the Main Effects button.

4 In the Design Generation panel, change the number of runs to 10 (Figure 2.39) and click Make 
Design. The Design table to the right in Figure 2.39 shows the factor settings for 10 runs.

Figure 2.39 Ten-Run Mixture Response Surface Design

Note that there are necessarily unequal numbers of runs for each wavelength. Because of this lack of 
balance it is a good idea to look at the prediction variance plot (top plot in Figure 2.40).

5 Open the Design Evaluation outline, then open the Prediction Variance Profile.

The prediction variance is almost constant across the three wavelengths, which is a good indication that 
the lack of balance is not a problem.

The values of the first three ingredients sum to one because they are mixture ingredients. If you vary 
one of the values, the others adjust to keep the sum constant. 

6 Select Maximize Desirability from red triangle menu on the Prediction Variance Profile title bar, as 
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shown in the bottom profiler in Figure 2.40. 

The most desirable wavelength is L2, with the CuSO4 percentage decreasing from about 0.4 to 0.2, 
Glyoxal percentage is zero, and Na2S2O3 is 0.8, which maintains the mixture. 

Figure 2.40 Prediction Variance Plots for Ten-Run Design

Experiments that are Mixtures of Mixtures

As a way to illustrate the idea of a ‘mixture of mixtures’ situation, imagine the ingredients that go into 
baking a cake and assume the following:

• dry ingredients composed of flour, sugar, and cocoa 

• wet (or non-dry) ingredients consisting of milk, melted butter, and eggs.

These two components (wet and dry) of the cake are two mixtures that are first mixed separately and 
then blended together.

The dessert chef knows that the dry component (the mixture of flour, sugar, and cocoa) contributes 
45% of the combined mixture and the wet component (butter, milk, and eggs) contributes 55%.

The objective of such an experiment might be to identify proportions within the two components that 
maximize some measure of taste or consistency. 

This is a main effects model except that you must leave out one of the factors in order to avoid singular-
ity. The choice of which factor to leave out of the model is arbitrary.

For now, consider these upper and lower levels of the various factors:

Within the dry mixture:

• cocoa must be greater than 10% but less than 20% 

• sugar must be greater than 0% but less than 15% 

• flour must be greater than 20% but less than 30%
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Within the wet mixture:

• melted butter must be greater than 10% but less than 20%

• milk must be greater than 25% and less than 35% 

• eggs constitute more than 5% but less than 20%

You want to bake cakes and measure taste on a scale from 1 to 10

Use the Custom Designer to set up this example, as follows:

1 In the Response Panel, enter one response and call it Taste. 

2 Give Taste a Lower Limit of 1 and an Upper Limit of 10. (You are assuming a taste test where the 
respondents reply on a scale of 1 to 10.)

3 In the Factors Panel, enter the six cake factors described above.

4 Enter the given percentage values of the factors as proportions in the Values section of the Factors 
panel.

The completed Response and Factors panels should look like those shown in Figure 2.41.

Figure 2.41 Completed Responses and Factors Panel for the Cake Example

5 Next, click Continue. 

6 Open the Constraints pane and click Add Constraint twice.

7 Enter the constraints as shown at the top in Figure 2.42.

By confining the dry factors to exactly 45% in this way, the mixture role of all the factors ensures that 
the wet factors constitute the remaining 55%.

8 Open the Model dialog and note that it lists all 6 effects. Because these are mixture factors, includ-
ing all effects would render the model singular. Highlight any one of the terms in the model and 
click Remove Term, as shown.
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Figure 2.42 Constraints to Define the Double Mixture Experiment

9 To see a completed example, choose Simulate Responses from the menu on the Custom Design 
title bar.

10 In the Design Generation panel, enter 10 as the number of runs for the example. That is, you would 
bake cakes with 10 different sets of ingredient proportions. 

11 Click Make Design in the Design Generation panel, and then click Make Table.

The table inFigure 2.43 shows that the two sets of cake ingredients (dry and wet) adhere to the propor-
tions 45% and 55% as defined by the entered constraints. In addition, the amount of each ingredient 
in each cake recipe (run) conforms to the upper and lower limits given in the factors dialog.

Figure 2.43 Cake Experiment Conforming to a Mixture of Mixture Design

Note: As a word of caution, keep in mind that it is easy to define constraints in such a way that it is 
impossible to construct a design that fits the model. In such a case, you will get a message saying 
“Could not find a valid starting design. Please check your constraints for consistency.”

Each run sums to 0.55 (55%)Each run sums to 0.45 (45%)
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Special-Purpose Uses of the Custom Designer
While some of the designs discussed in previous sections can be created using other designers in JMP or 
by looking them up in a textbook containing tables of designs, the designs presented in this section can-
not be created without using the custom designer.

Designing Experiments with Fixed Covariate Factors

Pre-tabulated designs rely on the assumption that the experimenter controls all the factors. Sometimes 
you have quantitative measurements (a covariate) on the experimental units before the experiment 
begins. If this variable affects the experimental response, the covariate should be a design factor. The 
pre-defined design that allows only a few discrete values is too restrictive. The custom designer supplies 
a reasonable design option. 

For this example, suppose there are a group of students participating in a study. A physical education 
researcher has proposed an experiment where you vary the number of hours of sleep and the calories for 
breakfast and ask each student to run 1/4 mile. The weight of the student is known and it seems impor-
tant to include this information in the experimental design. 

To follow along with this example that shows column properties, open Big Class.jmp from the Sample 
Data folder that was installed when you installed JMP.

Build the custom design as follows:

1 Select DOE > Custom Design.

2 Add two continuous variables to the models by clicking Add Factors and selecting Continuous, 
naming them calories and sleep.

3 Click Add Factor and select Covariate, as shown in Figure 2.44. The Covariate selection displays a 
list of the variables in the current data table.

Figure 2.44 Add a Covariate Factor

4 Select weight from the variable list (Figure 2.45) and click OK.
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Figure 2.45 Design with Fixed Covariate

5 Click Continue.

6 Add the interaction to the model by selecting calories in the Factors panel, selecting sleep in the 
Model panel, and then clicking the Cross button (Figure 2.46).

Figure 2.46 Design With Fixed Covariate Factor

7 Click Make Design, then click Make Table. The data table in Figure 2.47 shows the design table. 
Your runs might not look the same because the order of the runs has been randomized.
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Figure 2.47 Design Table for Covariate Example

Note: Covariate factors cannot have missing values.

Remember that weight is the covariate factor, measured for each student, but it is not controlled. The 
custom designer has calculated settings for calories and sleep for each student. It would be desirable if 
the correlations between calories, sleep and weight were as small as possible. You can see how well the 
custom designer did by fitting a model of weight as a function of calories and sleep. If that fit has a 
small model sum of squares, that means the custom designer has successfully separated the effect of 
weight from the effects of calories and sleep.

8 Click the red triangle icon beside Model in the data table and select Run Script, as shown on the 
left in Figure 2.48.

Figure 2.48 Model Script

9 Rearrange the dialog so weight is Y and calories, sleep, and calories*sleep are the model effects, as 
shown to the right in Figure 2.48. Click Run Model. 

The leverage plots are nearly horizontal, and the analysis of variance table shows that the model sum of 
squares is near zero compared to the residuals (Figure 2.49). Therefore, weight is independent of 
calories and sleep. The values in your analysis may be a little different from those shown below.
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Figure 2.49 Analysis to Check That Weight is Independent of Calories and Sleep

Creating a Design with Two Hard-to-Change Factors: Split Plot

While there is substantial research literature covering the analysis of split plot designs, it has only been 
possible in the last few years to create optimal split plot designs (Goos 2002). The split plot design 
capability accessible in the JMP custom designer is the first commercially available tool for generating 
optimal split plot designs.

The split plot design originated in agriculture, but is commonplace in manufacturing and engineering 
studies. In split plot experiments, hard-to-change factors only change between one whole plot and the 
next. The whole plot is divided into subplots, and the levels of the easy-to-change factors are randomly 
assigned to each subplot. 

The example in this section is adapted from Kowalski, Cornell, and Vining (2002). The experiment 
studies the effect of five factors on the thickness of vinyl used to make automobile seat covers. The 
response and factors in the experiment are described below:

• Three of the factors are ingredients in a mixture. They are plasticizers whose proportions, m1, m2, 
and m3, sum to one. Additionally, the mixture components are the subplot factors of the experi-
ment.

• Two of the factors are process variables. They are the rate of extrusion (extrusion rate) and the tem-
perature (temperature) of drying. These process variables are the whole plot factors of the experi-
ment. They are hard to change. 

• The response in the experiment is the thickness of the vinyl used for automobile seat covers. The 
response of interest (thickness) depends both on the proportions of the mixtures and on the effects 
of the process variables. 

To create this design in JMP:

1 Select DOE > Custom Design.

2 By default, there is one response, Y, showing. Double-click the name and change it to thickness. 
Use the default goal, Maximize (Figure 2.50).

3 Enter the lower limit of 10. 
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4 To add three mixture factors, type 3 in the box beside Add N Factors, and click Add Factor > 
Mixture. 

5 Name the three mixture factors m1, m2, and m3. Use the default levels 0 and 1 for those three fac-
tors.

6 Add two continuous factors by typing 2 in the box beside Add N Factors, and click Add Factor > 
Continuous. Name these factors extrusion rate and temperature. 

7 Ensure that you are using the default levels, –1 and 1, in the Values area corresponding to these two 
factors.

8 To make extrusion rate a whole plot factor, click Easy and select Hard.

9 To make temperature a whole plot factor, click Easy and select Hard. Your dialog should look like 
the one in Figure 2.50. 

Figure 2.50 Entering Responses and Factors

10 Click Continue.

11 Next, add interaction terms to the model by selecting Interactions > 2nd (Figure 2.51). This causes 
a warning that JMP removes the main effect terms for non-mixture factors that interact with all the 
mixture factors. Click OK.

Figure 2.51 Adding Interaction Terms

12 In the Design Generation panel, type 7 in the Number of Whole Plots text edit box.

13 For Number of Runs, type 28 in the User Specified text edit box (Figure 2.52).
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Figure 2.52 Assigning the Number of Whole Plots and Number of Runs

Note: If you enter a missing value in the Number of Whole Plots edit box, then JMP considers many 
different numbers of whole plots and chooses the number that maximizes the information about the 
coefficients in the model. It maximizes the determinant of where V 

-1 is the inverse of the 
variance matrix of the responses. The matrix, V, is a function of how many whole plots there are, so 
changing the number of whole plots changes V, which can make a difference in the amount of informa-
tion a design contains.

14 Click Make Design. The result is shown in Figure 2.53.

Figure 2.53 Partial Listing of the Final Design Structure

15 Click Make Table. 

16 From the Sample Data folder that was installed with JMP, open Vinyl Data.jmp from the Design 
Experiment folder, which contains 28 runs as well as response values. The values in the table you 
generated with the custom designer may be different from those from the Sample Data folder, 
shown in Figure 2.54.

X′ V 1– X
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Figure 2.54 The Vinyl Data Design Table

17 Click the red triangle icon next to the Model script and select Run Script. The dialog in Figure 2.55 
appears. 

The models for split plots have a random effect associated with the whole plots’ effect. 

As shown in the dialog in Figure 2.55, JMP designates the error term by appending &Random to the 
name of the effect. REML will be used for the analysis, as indicated in the menu beside Method in 
Figure 2.55. For more information about REML models, see the JMP Statistics and Graphics Guide.

Figure 2.55 Define the Model in the Fit Model Dialog

18 Click Run Model to run the analysis. The results are shown in Figure 2.56.
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Figure 2.56 Split Plot Analysis Results

Technical Discussion
This section provides more technical information about I-, D-, and Bayesian D-Optimal designs in 
JMP. 

D-Optimality: 

• is the default design type produced by the custom designer except when the RSM button has been 
clicked to create a full quadratic model.

• minimizes the variance of the model coefficient estimates. This is appropriate for first-order models 
and in screening situations, because the experimental goal in such situations is often to identify the 
active factors; parameter estimation is key. 

• is dependent on a pre-stated model. This is a limitation because in most real situations, the form of 
the pre-stated model is not known in advance. 

• has runs whose purpose is to lower the variability of the coefficients of this pre-stated model. By 
focusing on minimizing the standard errors of coefficients, a D-Optimal design may not allow for 
checking that the model is correct. It will not include center points when investigating a first-order 
model. In the extreme, a D-Optimal design may have just p distinct runs with no degrees of freedom 
for lack of fit.

• maximizes D when 

D det X′ X[ ]=
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D-optimal split plot designs maximize D when 

where V -1is the block diagonal variance matrix of the responses (Goos 2002).

Bayesian D-Optimality:

• is a modification of the D-Optimality criterion that effectively estimates the coefficients in a model, 
and at the same time has the ability to detect and estimate some higher-order terms. If there are 
interactions or curvature, the Bayesian D-Optimality criterion is advantageous.

• works best when the sample size is larger than the number of Necessary terms but smaller than the 
sum of the Necessary and If Possible terms. That is, p + q > n > p. The Bayesian D-Optimal design 
is an approach that allows the precise estimation of all of the Necessary terms while providing 
omnibus detectability (and some estimability) for the If Possible terms.

• uses the If Possible terms to force in runs that allow for detecting any inadequacy in the model con-
taining only the Necessary terms. Let K be the (p + q) by (p + q) diagonal matrix whose first p diag-
onal elements are equal to 0 and whose last q diagonal elements are the constant, k. If there are 
2-factor interactions then k = 4. Otherwise k = 1. The Bayesian D-Optimal design maximizes the 
determinant of (X'X + K). The difference between the criterion for D-Optimality and Bayesian 
D-Optimality is this constant added to the diagonal elements corresponding to the If Possible terms 
in the X'X matrix.

I-Optimality:

• minimizes the average variance of prediction over the region of the data.

• is more appropriate than D-Optimality if your goal is to predict the response rather than the coeffi-
cients, such as in response surface design problems. Using the I-Optimality criterion is more appro-
priate because you can predict the response anywhere inside the region of data and therefore find the 
factor settings that produce the most desirable response value. It is more appropriate when your 
objective is to determine optimum operating conditions, and also is appropriate to determine 
regions in the design space where the response falls within an acceptable range. Precise estimation of 
the response therefore takes precedence over precise estimation of the parameters.

• maximizes this criterion: If f '(x) denotes a row of the X matrix corresponding to factor combina-
tions x, then

where

is a moment matrix that is independent of the design and can be computed in advance.

Bayesian I-Optimality:

Bayesian I-Optimality has a different objective function to optimize than the Bayesian D-optimal 
design, so the designs that result are different. The variance matrix of the coefficients for Bayesian 

D det X′ V 1– X[ ]=

I f
R
∫ ′ x( ) X′X( )= 1– f x( )dx

Trace X ′X( ) 1– M[ ]=

M f
R
∫ x( ) f x( )′dx=
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I-optimality is X'X + K where K is a matrix having zeros for the Necessary model terms and some con-
stant value for the If Possible model terms.

The variance of the predicted value at a point x0 is:

The Bayesian I-Optimal design minimizes the average prediction variance over the design region:

where M is defined as before.

var Y
ˆ

x0⎝ ⎠
⎛ ⎞ x0′ X′X K+⎝ ⎠

⎛ ⎞ 1–
⎝ ⎠
⎛ ⎞ x0=

Trace X ′X K+( ) 1– M[ ]=





Chapter 3
Building Custom Designs

The Basic Steps

JMP can build a custom design that both matches the description of your engineering problem and 
remains within your budget for time and material. Custom designs are general, flexible, and good for 
routine factor screening or response optimization. To create these tailor-made designs, use the Custom 
Design command found on the DOE menu or the Custom Design button found on the DOE panel of 
the JMP Starter.

This chapter introduces you to the steps you need to complete to build a custom design.
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Creating a Custom Design
To begin, select DOE > Custom Design, or click the Custom Design button on the JMP Starter DOE 
page. Then, follow the steps below.

• Enter responses and factors into the custom designer.

• Describe the model.

• Select the number of runs.

• Check the design diagnostics, if desired.

• Specify output options.

• Make the JMP design table.

The following sections describe each of these steps.

Enter Responses and Factors into the Custom Designer

How to Enter Responses

To enter responses, follow the steps in Figure 3.1.

Figure 3.1 Entering Responses

Tip: To quickly enter multiple responses, click Number of Responses and enter the number of 
responses you want.

Specifying Response Goal Types and Lower and Upper Limits

When entering responses, you can tell JMP that your goal is to obtain the maximum or minimum 
value possible, to match a specific value, or that there is no response goal. 

The following description explains the relationship between the goal type (step 3 in Figure 3.1) and the 
lower and upper limits (step 4 in Figure 3.1):

Click to change the response goal, 
if desired.

To enter one 
response at a 
time, click then 
select a goal type: 
Maximize, Match 
Target, Minimize, 
or None.

Double-click to edit 
the response name, if 
desired.

Click to enter lower and upper 
limits and importance weights.

2 3

4

1
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• For responses such as strength or yield, the best value is usually the largest possible. A goal of 
Maximize supports this objective. 

• The Minimize goal supports an objective of having the smallest value, such as when the response is 
impurity or defects. 

• The Match Target goal supports the objective when the best value for a response is a specific target 
value, such as a dimension for a manufactured part. The default target value is assumed to be mid-
way between the given lower and upper limits.

Note: If your target response is not equidistant from the lower and upper acceptable bounds, you can 
alter the default target after you make a table from the design. In the data table, open the Column Info 
dialog for the response column (Cols > Column Info) and enter the desired target value.

Understanding Response Importance Weights 

To compute and maximize overall desirability, JMP uses the value you enter as the importance weight 
(step 4 in Figure 3.1) of each response. If there is only one response, then importance weight is unnec-
essary. With two responses you can give greater weight to one response by assigning it a higher impor-
tance value.

Adding Simulated Responses, If Desired

If you do not have values for specific responses, you might want to add simulated responses to see a 
prospective analysis in advance of real data collection:

1 Create the design.

2 Before you click Make Table, click the red triangle icon in the title bar and select Simulate 
Responses. 

3 Then, click Make Table to create the design table—the Y column contains values for simulated 
responses.

4 For custom and augment designs, a window (Figure 3.2) appears along with the design data table. In 
this window, enter values you want to apply to the Y column in the data table and click Apply. The 
numbers you enter represent the coefficients in an equation. An example of such an equation, as 
shown in Figure 3.2, would be, y = 28 + 4X1 + 5X2 + random noise, where the random noise is dis-
tributed with mean zero and standard deviation one. 
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Figure 3.2 In Custom and Augment Designs, Specify Values for Simulated Responses

How to Enter Factors

To enter factors, follow the steps in Figure 3.3.

Figure 3.3 Entering Factors in a Custom Design

Types of Factors

When adding factors, click the Add Factor button and choose the type of factor. 

To add one factor, click Add Factor and select a fac-
tor type: Continuous, Categorical, Blocking, 
Covariate, Mixture, Constant, or Uncontrolled 
(see description below).

To add multiple factors, type the 
number of factors in the Add N 
Factors box, click the Add 
Factor button, and select the 
factor type. 

Click and select 
Add Level to 
increase the 
number of levels.

Double-click to edit 
the factor name.

Click to enter or change fac-
tor values. To remove a 
level, click it, press the 
delete key on the keyboard, 
then press the Return or 
Enter key on the keyboard.

1

2

3 4 5
Click to indicate that 
changing a factor’s setting 
from run to run is Easy 
or Hard. Changing to 
Hard will cause the 
resulting design to be a 
split plot design.
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Continuous Continuous factors are numeric data types only. In theory, you can set a continuous 
factor to any value between the lower and upper limits you supply.

Categorical Either numeric or character data types. Categorical data types have no implied order. 
If the values are numbers, the order is the numeric magnitude. If the values are character, the 
order is the sorting sequence. The settings of a categorical factor are discrete and have no intrinsic 
order. Examples of categorical factors are machine, operator, and gender.

Blocking Either numeric or character data types. Blocking factors are a special kind of categorical 
factor. Blocking factors differ from other categorical factors in that there is a limit to the number 
of runs that you can perform within one level of a blocking factor.

Covariate Either numeric or character data types. Covariate factors are not controllable, but their 
values are known in advance of an experiment.

Mixture Mixture factors are continuous factors that are ingredients in a mixture. Factor settings 
for a run are the proportion of that factor in a mixture and vary between zero and one.

Constant Either numeric or character data types. Constant factors are factors whose values are 
fixed during an experiment.

Uncontrolled Either numeric or character data types. Uncontrolled factors have values that can-
not be controlled during an experiment, but they are factors you want to include in the model.

Factors that are Easy, Hard, or Very Hard, to Change - Creating Optimal Split-Plot 
and Split-Split-Plot Designs

Split plot experiments are performed in groups of runs where one or more factors are held constant 
within a group but vary between groups. In industrial experimentation this structure is desirable 
because certain factors may be difficult and expensive to change from one run to the next. It is conve-
nient to make several runs while keeping such factors constant. Until now, commercial software has not 
supplied a general capability for the design and analysis of these experiments. 

To indicate the difficulty level of changing a factor’s setting, click in Changes column of the Factors 
panel for a given factor and select Easy, Hard, or Very Hard from the menu that appears. Changing to 
Hard results in a split-plot design and Very Hard results in a split-split-plot design.

See “Creating Random Block Designs,” p. 71, for more details.

Defining Factor Constraints, If Necessary

Sometimes it is impossible to vary factors simultaneously over their entire experimental range. For 
example, if you are studying the affect of cooking time and microwave power level on the number of 
kernels popped in a microwave popcorn bag, the study cannot simultaneously set high power and long 
time without burning all the kernels. Therefore, you have factors whose levels are constrained.
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To define the constraints:

1 After you add factors and click Continue, click the blue disclosure button (  on Windows/Linux 
and  on the Macintosh) to open the Define Factor Constraints panel.

2 Click the Add Constraint button. Note that this feature is dis-
abled if you have already controlled the design region by entering 
disallowed combinations or chosen a sphere radius.

3 Specify the coefficients and their limiting value in the boxes pro-
vided, as shown to the right. When you need to change the direc-
tion of the constraint, click on the default less than or equal 
button and select the greater than or equal to direction.

4 To add another constraint, click the Add Constraint button again and repeat the above steps.

Describe the Model

Initially, the Model panel lists only the main effects corresponding to the factors you entered, as shown 
in Figure 3.4. However, you can add factor interactions or powers of continuous factors to the model. 
For example, to add all the two-factor interactions and quadratic effects at once, click the RSM button.

Figure 3.4 Add Terms

Table 3.1 summarizes the ways to add specific factor types to the model.

Table 3.1 How to Add Terms to a Model
Action Instructions

Add interaction terms involving selected 
factors. If none are selected, JMP adds all 
of the interactions to the specified order.

Click the Interactions button and select 2nd, 3rd, 4th, 
or 5th. For example, if the factors are X1 and X2 and you 
click Interactions > 2nd, X1*X2 is added to the list of 
model terms.

Add all second-order effects, including 
two-factor interactions and quadratic 
effects

Click the RSM button. The design now uses I-Optimal-
ity criterion rather than D-Optimality criterion.

Add selected cross product terms 1 Highlight the factor names.

2 Highlight term(s) in the model list.

3 Click the Cross button.

Add powers of continuous factors to the 
model effects

Click the Powers button and select 2nd, 3rd, 4th, or 
5th.
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Select the Number of Runs

The Design Generation panel (Figure 3.5) shows the minimum number of runs needed to perform the 
experiment based on the effects you’ve added to the model (two main effects in the example above). It 
also shows alternate (default) numbers of runs, or lets you choose your own number of runs. Balancing 
the cost of each run with the information gained by extra runs you add is a judgment call that you con-
trol.

Figure 3.5 Options for Selecting the Number of Runs

The Design Generation panel has these options for selecting the number of runs you want:

Minimum is the smallest number of terms that can create a design. When you use Minimum, the 
resulting design is saturated (no degrees of freedom for error). This is an extreme and risky 
choice, and is appropriate only when the cost of extra runs is prohibitive.

Default is a custom design suggestion for the number of runs. This value is based on heuristics for 
creating balanced designs with a few additional runs above the minimum.

User Specified is a value that specifies the number of runs you want. Enter that value into the 
Number of Runs text box. 

Note: In general, the custom design suggests a number of runs that is the smallest number that can be 
evenly divided by the number of levels of each of the factors and is larger than the minimum possible 
sample size. For designs with factors at two levels only, the default sample size is the smallest power of 
two larger than the minimum sample size.

When the Design Generation panel shows the number of runs you want, click Make Design.

Understanding Design Evaluation

After making the design, you can preview the design and investigate details by looking at various plots 
and tables that serve as design diagnostic tools.

Although different tools are available depending on the model you specify, most designs display

• the Prediction Variance Profile Plot

• the Fraction of Design Space Plot 

• the Prediction Variance Surface Plot 
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• the Relative Variance of Coefficients and Power Table 

• the Alias Matrix

• Design Diagnostic Table. 

These diagnostic tools are outline nodes beneath the Design Evaluation panel, as shown in Figure 3.6. 
JMP always provides the Prediction Variance Profile, but the Prediction Surface Plot only appears if 
there are two or more variables.

Figure 3.6 Custom Design Diagnostic Tools

The Prediction Variance Profile

The example in Figure 3.7 shows the prediction variance profile for a response surface model (RSM) 
with 2 variables and 8 runs. To see a response surface design similar to this:

1 Chose DOE > Custom Design.

2 In the Factors panel, add 2 continuous factors.

3 Click Continue.

4 In the Model panel, click RSM.

5 Click Make Design.

6 Open the Prediction Variance Profile.



66 Building Custom Designs Chapter 3
Creating a Custom Design

Figure 3.7 A Factor Design Layout For a Response Surface Design with 2 Variables

The prediction variance for any factor setting is the product of the error variance and a quantity that 
depends on the design and the factor setting. Before you collect the data the error variance is unknown, 
so the prediction variance is also unknown. However, the ratio of the prediction variance to the error 
variance is not a function of the error variance. This ratio, called the relative variance of prediction, 
depends only on the design and the factor setting and can be calculated before acquiring the data. The 
prediction variance profile plots the relative variance of prediction as a function of each factor at fixed 
values of the other factors. 

After you run the experiment, collect the data, and fit the model, you can estimate the actual variance 
of prediction at any setting by multiplying the relative variance of prediction by the mean squared error 
(MSE) of the least squares fit.

It is ideal for the prediction variance to be small throughout the allowable regions of the factors. Gener-
ally, the error variance drops as the sample size increases. Comparing the prediction variance profilers 
for two designs side-by-side, is one way to compare two designs. A design that has lower prediction 
variance on the average is preferred.

In the profiler, drag the vertical lines in the plot to change the factor settings to different points. Drag-
ging the lines reveals any points that have prediction variances that are larger than you would like.

Another way to evaluate a design, or to compare designs, is to try and minimize the maximum variance. 
You can use the Maximize Desirability command on the Prediction Variance Profile title bar to iden-
tify the maximum prediction variance for a model. Consider the Prediction Variance profile for the 
two-factor RSM model shown in Figure 3.8. The plots on the left are the default plots. The plots on 
the right identify the factor values where the maximum variance (or worst-case scenario) occur, which 
helps you evaluate the acceptability of the model.

Figure 3.8 Find Maximum Prediction Variance
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The Fraction of Design Space Plot

The Fraction of Design Space plot is a way to see how much of the model prediction variance lies above 
(or below) a given value. As a simple example, consider the Prediction Variance plot for a single factor 
quadratic model, shown on the left in Figure 3.9. The Prediction Variance plot shows that 100% of the 
values are smaller than 0.5. You can move the vertical trace and also see that all the values are above 
0.332. The Fraction of Design Space plot displays the same information. The X axis is the proportion 
or percentage of prediction variance values, ranging from 0 to 100%, and the Y axis is the range of pre-
diction variance values. In this simple example, the Fraction of Design plot verifies that 100% of the 
values are below 0.5 and 0% of the values are below approximately 0.3. You can use the crosshair tool 
and find the percentage of values for any value of the prediction variance. The example to the right in 
Figure 3.9 shows that 75% of the prediction variance values are below approximately 0.46.

The Fraction of Design space is most useful when there are multiple factors. It summarizes the predic-
tion variance, showing the fractional design space for all the factors taken together.

Figure 3.9 Variance Profile and Fraction of Design Space

The Prediction Variance Surface

When there are two or more factors, the Prediction Variance Surface plots the surface of the prediction 
variance for any two variables. This feature uses the Graph > Surface Plot platform in JMP, and has all 
its functionality. Drag on the plot to rotate and change the perspective. Figure 3.10 shows the Predic-
tion Variance Surface plot for a two-factor RSM model. The factors are on the x and y axes, and the 
prediction variance is on the z axis. You can clearly see the high and low variance areas for both factors. 
Compare this plot to the Prediction Variance Profile shown in Figure 3.8.
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Figure 3.10 Prediction Variance Surface Plot for Two-Factor RSM Model

You can find complete documentation for the Surface Plot platform in JMP Statistics and Graphics 
Guide.

The Relative Variance of Coefficients and Power Table

Before clicking Make Table in the custom designer, click the disclosure button (  on Windows/
Linux and  on the Macintosh) to open the Relative Variance of Coefficients table.

The Relative Variance of Coefficients table (Figure 3.11) shows the relative variance of all the coeffi-
cients for the example RSM custom design (see Figure 3.7). The variances are relative to the error vari-
ance, which is unknown before the experiment, and is assumed to be one. Once you complete the 
experiment and have an estimate for the error variance, you can multiply it by the relative variance to 
get the estimated variance of the coefficient. The square root of this value should match the standard 
error of prediction for the coefficient when you fit a model using Analyze > Fit Model.

The Power column shows the power of the design as specified to detect effects of a certain size. In the 
text edit boxes, you can change the alpha level of the test and the magnitude of the effects compared to 
the error standard deviation. The alpha level edit box is called Significance Level. The magnitude of 
the effects edit box is called Signal to Noise Ratio. This is the ratio of the absolute value of the regres-
sion parameter to sigma (the square root of the error variance).

If you enter a smaller alpha (requiring a more significant test), then the power falls. If you increase the 
magnitude of the effect you want to detect, the power rises.

The power reported is the probability of finding a significant model parameter if the true effect is Sig-
nal to Noise Ratio times sigma. The Relative Variance of Coefficients table on the left in Figure 3.11 
shows the results for the two-factor RSM model. 

As another example, suppose you have a 3-factor 8-run experiment with a linear model and you want 
to detect any regression coefficient that is twice as large as the error standard deviation, with an alpha 
level of 0.05. The Relative Variance of Coefficients table on the right in Figure 3.11 shows that the 
resulting power is 0.984 for all the parameters.



3
C

u
s
to

m
 D

e
s
ig

n
s

Chapter 3 Building Custom Designs 69
Creating a Custom Design

Figure 3.11 Table of Relative Variance of Coefficients

The Alias Matrix (Confounding Pattern)

Click the Alias Matrix disclosure button (  on Windows/Linux and  on the Macintosh) to 
open the alias matrix (Figure 3.12).

The alias matrix only appears for custom designs if all factors are two-level factors. The table shows the 
aliasing (if any) between the model terms and all the two-factor interactions. It allows you to see the 
confounding pattern in D-Optimal and I-Optimal designs.

Figure 3.12 Alias Matrix

The Design Diagnostics Table

Open the Design Diagnostics outline node to display a table with relative D-, G-, and A-efficiencies, 
average variance of prediction, and length of time to create the design. The design efficiencies are com-
puted as follows:

where 

D-efficiency = 100 1
ND
------- X′X 1 p/
⎝ ⎠
⎛ ⎞

A-efficiency = 100
p

trace ND X′X( ) 1–( )
-----------------------------------------------
⎝ ⎠
⎜ ⎟
⎛ ⎞

G-efficiency = 100

p
ND

------

σM
-----------
⎝ ⎠
⎜ ⎟
⎜ ⎟
⎜ ⎟
⎛ ⎞
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• ND is the number of points in the design

• p is the number of effects in the model including the intercept

• σM is the maximum standard error for prediction over the design points.

These efficiency measures are single numbers attempting to quantify one mathematical design charac-
teristic. While the maximum efficiency is 100 for any criterion, an efficiency of 100% is impossible for 
many design problems. It is best to use these design measures to compare two competitive designs with 
the same model and number of runs rather than as some absolute measure of design quality.

Figure 3.13 Custom Design Showing Diagnostics

Specify Output Options

Use the Output Options panel to specify how you want the output data table to appear:

Run Order lets you designate the order you want the runs to appear in the data table when it is created. 
Choices are:

Keep the Same the rows (runs) in the output table will appear as they do in the Design panel. 

Sort Left to Right the rows (runs) in the output table will appear sorted from left to right. 

Randomize the rows (runs) in the output table will appear in a random order.

Sort Right to Left the rows (runs) in the output table will appear sorted from right to left. 

Randomize within Blocks the rows (runs) in the output table will appear in random order within 
the blocks you set up. 
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Add additional points using options from Make JMP Table from design plus

Number of Center Points: Specifies additional runs placed at the center of each continuous fac-
tor’s range.

Number of Replicates: Specify the number of times to replicate the entire design, including cen-
terpoints. Type the number of times you want to replicate the design in the associated text box. 
One replicate doubles the number of runs.

Make the JMP Design Table

When the Design panel shows the layout you want, click Make Table. Parts of the table contain infor-
mation you might need to continue working with the table in JMP. The upper-left of the design table 
can have one or more of the following scripts:

• a Screening script runs the Analyze > Modeling > Screening platform when appropriate for the 
generated design. 

• a Model script runs the Analyze > Fit Model platform with the model appropriate for the design.

• a constraint script that shows any model constraints you entered in the Define Factor Constraints 
panel of the Custom Design dialog.

• a DOE Dialog script that recreates the dialog used to generate the design table, and regenerates the 
design table.

Figure 3.14 Example Design Table

Creating Random Block Designs
It is often necessary to group the runs of an experiment into blocks. Runs within a block of runs are 
more homogeneous than runs in different blocks. For example, the experiment described in Goos 
(2002), describes a pastry dough mixing experiment that took several days to run. It is likely that ran-
dom day-to-day differences in environmental variables have some effect on all the runs performed on a 
given day. Random block designs are useful in situations like this, where there is a non-reproducible 
shock to the system between each block of runs. In Goos (2002), the purpose of the experiment was to 
understand how certain properties of the dough depend on three factors: feed flow rate, initial moisture 
content, and rotational screw speed. It was only possible to conduct four runs a day. Because day-to-day 

This area identifies the design type that generated the 
table. Click Custom Design to edit.

Model is a script. Click the red triangle icon and select 
Run Script to open the Fit Model dialog, which is used 
to generate the analysis appropriate to the design.

DOE Dialog is a script. Click the red trangle icon and 
select Run Script to recreate the DOE Custom Dialog 
and generate a new design table.
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variation was likely, it was important to group the runs so that this variation would not compromise the 
information about the three factors. Thus, blocking the runs into groups of four was necessary. Each 
day's experimentation was one block. The factor, Day, is an example of a random block factor.

To create a random block, use the custom design and enter 
responses and factors, and define your model as usual. In the 
Design Generation panel, check the Group runs into random 
blocks of size check box and enter the number of runs you 
want in each block. When you select or enter the sample size, 
the number of runs specified are assigned to the blocks.

In this example, the Design Generation Panel shown here des-
ignates four runs per block, and the user-specified number of runs (28) indicates there will be seven 
days (blocks) of 4 runs. If the number of runs is not an even multiple of the random block size, some 
blocks will have a fewer runs than others. 

Creating Split Plot Designs
Split plot experiments happen when it is convenient to run an experiment in groups of runs (called 
whole plots) where one or more factors stay constant within each group. Usually this is because these 
factors are difficult or expensive to change from run to run. JMP calls these factors Hard to change 
because this is usually how split plotting arises in industrial practice. 

In a completely randomized design, any factor can change its setting from one run to the next. When 
certain factors are hard to change, the completely randomized design may require more changes in the 
settings of hard-to-change factors than desired.

If you know that a factor or two are difficult to change, then you can set the Changes setting of a factor 
from the default of Easy to Hard. Before making the design, you can set the number of whole plots you 
are willing to run.

For an example of creating a split plot design, see “Creating a Design with Two Hard-to-Change Fac-
tors: Split Plot,” p. 49. 

To create a split plot design using the custom designer:

1 In the factors table there is a column called Changes. By default, changes are Easy for all factors. If, 
however, you click in the changes area for a factor, you can choose to make the factor Hard to 
change.

2 Once you finish defining the factors and click continue, you see an edit box for supplying the num-
ber of whole plots. You can supply any value as long as it is above the minimum necessary to fit all 
the model parameters. You can also leave this field empty. In this case, JMP chooses a number of 
whole plots to minimize the omnibus uncertainty of the fixed parameters.

Note: If you enter a missing value in the Number of Whole Plots edit box, then JMP considers many 
different numbers of whole plots and chooses the number that maximizes the information about the 
coefficients in the model. It maximizes the determinant of where V 

-1 is the inverse of the vari-
ance matrix of the responses. The matrix, V, is a function of how many whole plots there are, so chang-

X ′V 1–
X
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ing the number of whole plots changes V, which can make a difference in the amount of information a 
design contains.

To create a split plot design every time you use a certain factor, save steps by setting up that factor to be 
“hard” in all experiments. See “Identify Factor Changes Column Property,” p. 87, for details.

Creating Split-Split Plot Designs
Split-split plot designs are a three stratum extension of split plot designs. Now there are factors that are 
Very-Hard-to-change, Hard-to-change, and Easy-to-change. Here, in the top stratum, the 
Very-Hard-to- change factors stay fixed within each whole plot. In the middle stratum the 
Hard-to-change factors stay fixed within each subplot. Finally, the Easy-to-change factors may vary 
(and should be reset) between runs within a subplot. This structure is natural when an experiment cov-
ers three processing steps. The factors in the first step are Very-Hard-to-change in the sense that once 
the material passes through the first processing stage, these factor settings are fixed. Now the material 
passes to the second stage where the factors are all Hard-to-change. In the third stage, the factors are 
Easy-to-change.

Schoen (1999) provides an example of three-stage processing involving the production of cheese that 
leads to a split-split plot design. The first processing step is milk storage. Typically milk from one stor-
age facility provides the raw material for several curds processing units—the second processing stage. 
Then the curds are further processed to yield individual cheeses.

In a split-split plot design the material from one processing stage passes to the next stage in such a way 
that nests the subplots within a whole plot. In the example above, milk from a storage facility becomes 
divided into two curds processing units. Each milk storage tank provided milk to a different set of curds 
processors. So, the curds processors were nested within the milk storage unit.

Figure 3.15 shows an example of how factors might be defined for the cheese processing example.

Figure 3.15 Example of Split-Split Response and Factors in Custom Designer Dialog



74 Building Custom Designs Chapter 3
Creating Strip Plot Designs

Creating Strip Plot Designs
In a strip plot design it is possible to reorder material between processing stages. Suppose units are 
labelled and go through the first stage in a particular order. If it is possible to collect all the units at the 
end of the first stage and reorder them for the second stage process, then the second stage variables are 
not nested within the blocks of the first stage variables. For example, in semiconductor manufacturing 
a boat of wafers may go through the first processing step together. However, after this step, the wafers in 
a given boat may be divided among many boats for the second stage.

To set up a strip plot design, enter responses and factors as usual, designating factors as Very Hard, 
Hard, or Easy to change. Then, in the Design Generation panel, check the box that says Hard to 
change factors can vary independently of Very Hard to change factors, as shown in Figure 3.16. 
Note that the Design Generation panel specified 6 whole plots, 12 subplots, and 24 runs.

When you click Make Design, the design table on the right in Figure 3.16 lists the run with subplots 
that are not nested in the whole plots. 

Figure 3.16 Example of Strip Split Factors and Design Generation panel in Custom Designer Dialog

Special Custom Design Commands
After you select DOE > Custom Design, click the red triangle icon on the title bar to see the list of 
commands available to the Custom designer (Figure 3.17). The commands found on this menu vary, 
depending on which DOE command you select. However, the commands to save and load responses 
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and factors, the command to set the random seed, and the command to simulate responses are available 
to all designers. You should examine the red triangle menu for each designer you use to determine 
which commands are available. If a designer has additional commands, they are described in the appro-
priate chapter.

Figure 3.17 Click the Red Triangle Icon to Reveal Commands

The following sections describe these menu commands and how to use them.

Save Responses and Save Factors

If you plan to do further experiments with factors and/or responses to which you have given meaning-
ful names and values, you can save them for later use. 

To save factors or responses:

1 Select a design type from the DOE menu.

2 Enter the factors and responses into the appropriate panels (see “Enter Responses and Factors into 
the Custom Designer,” p. 59, for details).

3 Click the red triangle icon on the title bar and select Save Responses or Save Factors.

Save Responses creates a data table containing a row for each response with a column called 
Response Name that identifies the responses. Four additional columns identify more informa-
tion about the responses: Lower Limit, Upper Limit, Response Goal, and Importance.

Save Factors creates a data table containing a column for each factor and a row for each factor 
level. The columns have a column property (noted with an asterisk icon in the column panel) 
called Design Role that identifies them as DOE factors and lists their type (continuous, categori-
cal, blocking, and so on).

4 Save the data table.

Load Responses and Load Factors

If you have saved responses and factors, you can quickly apply them to your design and avoid retyping 
this information each time you run an experiment. 
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To design an experiment using responses or factors you have previously saved:

1 Open the data table that contains the factor names and levels. 

2 Select a design type from the DOE menu.

3 Click the red triangle icon on the title bar (Figure 3.18) and select Load Responses or Load 
Factors.

Figure 3.18  Loading Factor Names and Values from a JMP Table

Tip: It is possible to create a factors table by keying data into an empty table, but remember to assign 
each column a factor type. Do this by right-clicking the column name, selecting Column Info, and 
then selecting Column Properties > Design Role. Lastly, click the button in the Design Role area and 
select the appropriate role.

Save Constraints and Load Constraints

In custom, augment, and mixture designs, if you set up factor constraints and plan to do further exper-
iments with them, you can save them for later use. You can quickly apply these constraints to your 
design and avoid retyping this information each time you run an experiment. 

To save factor constraints:

1 Select a design type from the DOE menu.

2 Enter the factor constraints into the appropriate panels (see “Enter Responses and Factors into the 
Custom Designer,” p. 59, for details).

3 Click the red triangle icon on the title bar (Figure 3.18) and select Save Constraints. Save 
Constraints creates a data table that contains the information you enter into a constraints panel. 
There is a column for each constraint. Each has a column property called Constraint State that iden-
tifies it as a ‘less than’ or a ‘greater than’ constraint. There is a row for each variable and an additional 
row that has the inequality condition for each variable.

4 Save the data table. 

To design an experiment using factor constraints you have previously saved:

1 Open the data table that contains the constraints. 

2 Select a design type from the DOE menu.

3 Click the red triangle icon on the title bar (Figure 3.18) and select Load Constraints.
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Set Random Seed: Setting the Number Generator

The design process begins with a random starting design. To set the random seed that the custom 
designer uses to create this starting design, click the red triangle icon in the design title bar 
(Figure 3.18) and select Set Random Seed. 

The window that appears shows the generating seed for that design (Figure 3.19). From this window, 
you can set a new random number and then run the design again. 

If you use the same seed as a previous design, you will get the same design again.

Figure 3.19 Setting the Random Seed

Note: The random seed is also used when you simulate responses to be used with a design, as 
described next.

Simulate Responses

Often, when you define a custom design (or any standard design), it may be 
useful to look at properties of the design with response data before you have 
collected data. The Simulate Responses command adds random response val-
ues to the JMP table that the custom designer creates. To use the command, 
select it before you click Make Table. When you click Make Table to create the 
design table, the Y column contains values for simulated responses.

For custom and augment designs, an additional window appears with the 
design data table that lists coefficients for the design you described in the 
designer panels. You can enter any coefficient values you want and click Apply to see new Y values in 
the data table. An example of an equation for a model with two factors and interaction (Figure 3.20) 
would be, 

y = 19 + 2X1 + (–5)X2 + 6X1X2 + random noise, 

where the random noise is distributed with mean zero and standard deviation one.

Figure 3.20 Example of a Custom Design with Simulated Responses
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Save X Matrix: Viewing the Design (X) Matrix in the Log

To create a script and save the design matrix as a table property in a data table, click the red triangle 
icon in the Custom Design title bar (Figure 3.17) and select Save X Matrix. A script is saved as a table 
property called Design Matrix. When you run this script, JMP creates a global matrix called X and dis-
plays its number of rows in the log. If you do not have the log visible, select View > Log (Window > 
Log on the Macintosh).

Optimality Criterion: Changing the Design Criterion (D- or I- Optimality)

To change the design criterion, click the red triangle icon in the Custom Design title bar (Figure 3.21) 
and select Optimality Criterion, then choose Make D-Optimal Design or Make I-Optimal Design. 

Figure 3.21 Changing the Design Criterion

The default criterion for Recommended is D-optimal for all design types unless you have used the 
RSM button in the Model panel to add effects that make the model quadratic. For specific information 
about optimality criterion, see “Technical Discussion,” p. 53.

Number of Starts: Changing the Number of Random Starts

To override the default number of 
random starts, click the red triangle 
icon in the Custom Design title bar 
(Figure 3.17) and select Number of 
Starts. When you select this com-
mand, the window shown here appears with an edit box for you to enter the number of random starts 
for the design you want to build. The number you enter overrides the default number of starts, which 
varies depending on the design. 

Note: If the design iterations are taking too long, click the Cancel button. The Custom Designer 
stops and gives the best design found at that point.
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Why Change the Number of Starts?

One difficulty with the creation of optimal designs is that the methods used do not always find the glo-
bally optimal design in cases where the optimal design is known from theory. For example, orthogonal 
designs are D-optimal with respect to a linear additive model and a cubic design space.

As the number of factors and sample size increase, the optimization problem becomes harder. It is easy 
for an optimizer to converge to a local optimum instead of a global optimum.

It is useful to know that:

• If random starts are used for the optimization, the design produced at the end is not always the 
same. Increasing the number of random starts tends to improve the optimality of the resulting 
design.

• For designs with all two-level factors, there is a formula for the optimal determinant:
If D is the determinant, n is the sample size, and c is the number of columns in the design matrix, 
the LogD = cLogn.

If the determinants that result from the random starts match the formula above, the algorithm stops. 
The design is D-optimal and orthogonal.

Default Choice of Number of Random Starts: Technical Information

JMP does not start over with random designs until a jackpot is hit. The time it takes for one iteration of 
the algorithm (coordinate exchange) increases roughly as the product of the sample size and the num-
ber of terms in the model. By doing a large number of random starts for small sample sizes and reduc-
ing this number proportional to the square of the sample size as the designs get larger, the total time it 
takes to generate a design is kept roughly constant over the range of usual sample sizes. 

The Custom Designer always attempts to find globally optimal designs when such designs are known 
from theory. For example, 

• 2-level fractional factorial designs are globally D-optimal for all main effect and two-factor interac-
tion models

• Latin-Square designs are D-optimal for main effect models assuming the right sample size and num-
bers of levels of the factors.

• Plackett-Burman designs are D-optimal for main effect models.

If the custom designer can identify one of these special cases, it does many more random starts. In gen-
eral, however, the default number of random starts is controlled by the sample size, n, as follows: 

Table 3.2 Sample Size and Random Starts
Sample Size Number of Starts

9 or fewer 80

from 9 to 16 40

from 17 to 24 10

from 25 to 32 5

more than 32 2
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Note the following exceptions:

• If each factor has only two levers, the number of terms in the model is one greater than the number 
of factors, and the sample size is a multiple of 4, then multiply the default number of starts shown in 
the table above by 40.

• If the design is I-optimal divide all the sample sizes in the table above by 2 and add 1.

• If the design could be a Latin Square, the Custom Designer does 1000 random starts.

• If the number of terms in the model is greater than 100, though, the number of random starts is 1.

After each random start, the design is checked to see if it is globally optimal, and if so, the iterations 
stop. Therefore, even if the default number of starts is large, it may only take a small fraction of the 
default number to find the globally optimal design. Again, if the process seems to be taking too long, 
use the Cancel button to see the best design found at that point.

Sphere Radius: Constraining a Design to a Hypersphere

You can constrain custom and augmented designs to a hypersphere by editing the sphere radius. Before 
making the design, click the red triangle icon in the Custom Design title bar (Figure 3.17) and select 
Sphere Radius. Enter the appropriate value and click OK. 

Note that hypersphere constraints do not work with other constraints. Also, split plot designs cannot be 
generated with hypersphere constraints.

If you have designed any factor’s changes as Hard (see “Factors that are Easy, Hard, or Very Hard, to 
Change - Creating Optimal Split-Plot and Split-Split-Plot Designs,” p. 62, and “Creating Random 
Block Designs,” p. 71), the sphere radius item becomes unavailable. Conversely, once you set the sphere 
radius, you cannot make a factor Hard to change.

Disallowed Combinations: Accounting for Factor Level Restrictions

JMP gives you the flexibility to disallow particular combinations of levels of factors. You can do this for 
custom and augmented designs except for experiments with mixture or blocking factors. This feature 
can also be used with continuous factors or mixed continuous and categorical factors. 

For example, in a market research choice experiment, you might want to exclude a choice that allows all 
the best features of a product at the lowest price. In this case, the factor Feature has levels of worst (1), 
medium (2), and best (3), and the factor Price has levels of high (1), medium (2), and low (3). You 
want to exclude the third Feature level (best) and the third Price level (low).

To disallow a combination of factor levels:

1 Begin by adding the factors. 

2 Click the red triangle icon in the title bar (Figure 3.17) of the designer window and select 
Disallowed Combinations. Note that this menu item is not available if you have already defined 
linear inequality constraints. 

3 Enter a Boolean expression that identifies what you do not want allowed (Figure 3.22). JMP evalu-
ates your expression, and when it sees it as true, it disallows the specified combination. 
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Note: When forming the expression, use the ordinal value of the level instead of the name of the level. 
If the level names of the factor called Price are high, medium, and low, their associated ordinal values 
are 1, 2, and 3. 

For example, in Figure 3.22, Feature==3 & Price==3 will not allow a run containing the best 
features at the lowest price. If there were two disallowed combinations in this example, you would 
use Feature==3 & Price==3 | Quality==3 & Price==3, which tells JMP to disallow a run 
with the best features at the lowest price or a run with the best quality and lowest price.

Figure 3.22 Enter a Boolean Expression

4 Make the design table. It excludes the combination of factors you specified, as shown in Figure 3.23.

Figure 3.23 No Row Contains L3 for Both Price and Feature

Advanced Options for the Custom Designer

The following options are for advanced design of experiment users. 

Changing the Search Points Per Factor

For a main effects model, the coordinate exchange algorithm in the custom designer only considers the 
high and low values. However, you can change this so the algorithm considers more search points. For 
example, if you enter 5, then JMP considers five equally spaced settings for each factor. The 5 levels are 
considered, but all 5 levels may not appear in the output table. The Custom Designer finds a D- or 
I-Optimal design, which might not need to include all 5 levels.

To change the search points:

1 Select DOE > Custom Design.

2 Click the red triangle icon in the title bar (Figure 3.17) of the designer window and select 
Advanced Options > Search Points Per Factor.

3 Enter a positive integer and click OK. 
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4 Make the design.

Altering the Mixture Sum

If you want to keep a component of a mixture constant throughout an experiment, then the sum of the 
other mixture components must be between 0.001 and 1. You may have one or more fixed ingredients 
so that the sum of the remaining add to less than one but more than zero. To alter the mixture sum:

1 Select DOE > Custom Design.

2 Click the red triangle icon in the title bar (Figure 3.17) of the designer window and select 
Advanced Options > Mixture Sum.

3 Enter a positive number and click OK.

4 Make the design.

Split Plot Variance Ratio

The optimal split plot design depends on the ratio of the variance of the random whole plot variance to 
the error variance. By default, this variance is one. If you have some prior knowledge of this variance 
ratio, you can supply it by following these steps:

1 Select DOE > Custom Design.

2 Click the red triangle icon in the title bar (Figure 3.17) of the designer window and select 
Advanced Options > Split Plot Variance Ratio.

3 Enter a positive number and click OK.

4 Make the design.

Prior Parameter Variance

If you have specified If Possible as the Estimability for any factors in your model, then you can use this 
option to also specify the weight used for these terms. Default values are one. Larger values represent 
more prior information and a smaller variance. Variances are the reciprocals of the entered values.

1 Select DOE > Custom Design.

2 Click the red triangle icon in the title bar (Figure 3.17) of the designer window and select 
Advanced Options > Prior Parameter Variance.

3 Enter a positive number for each of the terms for which you want to specify a weight and click OK.

4 Make the design.

Save Script to Script Window

This command creates the script for the design you described in the Custom Designer and saves it in an 
open script window.
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Assigning Column Properties
Columns in a data table can contain special column properties. Figure 3.24 shows that a column called 
Stretch has two special properties: Role and Response Limits, that were assigned by the Custom 
Designer when the table was created. To see the example in Figure 3.24, open Bounce Data.jmp from 
the Design Experiment folder found in the sample data installed with JMP. Then, right-click the col-
umn name in the data table and select Column Info. When the Column Info dialog appears, click on 
the property you want to see.

Figure 3.24 Column Properties Menu in the Column Info Dialog

All special column properties are covered in the JMP User Guide. The following discussion gives details 
about properties specific to DOE and that are useful for analyzing DOE data.

Define Low and High Values (DOE Coding) for Columns

For continuous variables, the Coding column property transforms data in the range you specify from –1 
to +1. When you analyze the coded variable, JMP uses those transformed data values to compute mean-
ingful parameter estimates. You can specify the range in which the low and high values of the column 
are transformed.

By default, when JMP generates a design table from values entered in the Factors panel, it uses those 
values as the low and high values of the coding property. If a column has one or more limits missing, 
JMP substitutes the data’s minimum and maximum for the high and low values.

You can use the Column Info dialog to manually add or delete a coding property, or change the range 
in which the low and high values are transformed. Figure 3.25 shows the coding values for the 
Temperature variable in the Reactor 8 Runs data table from the Design Experiment Sample Data.
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Figure 3.25 Coding Column Property in Column Info Dialog

Set Columns as Factors for Mixture Experiments

You might have a column in a data table that is one of several factors that form 100% of a mixture. You 
can set up the column so JMP uses it to automatically generate a no-intercept model when you analyze 
the data with the Fit Model platform. The following example uses the Donev Mixture Data from the 
Design Experiment sample data

To set up the CuS04 column as a mixture factor, first select Cols > Column Info to see the Column 
Info dialog for CuS04. Then continue as follows:

1 Select Mixture from the Column Properties drop-down menu. Upper and Lower limits, and the 
sum of the limits appear in a panel on the dialog, as shown in Figure 3.26. You can use these limits, 
or enter your own values.

2 Optionally, check the boxes beside L PseudoComponent Coding, U PseudoComponent Coding, 
or both L and U PseudoComponent Coding. Using the example in Figure 3.26, where the mix-
ture sum value is 1, the terms are coded as:

 for the L pseudocomponent 

 for the U pseudocomponent 

where Li and Ui are the lower and upper bounds, L is the sum of Li and U is the sum of Ui. 

Note: If you check either L PseudoComponent Coding or U PseudoComponent Coding for the 
mixture coding of one mixture factor and you check the other alternative for one or more other mixture 
factors in the model, of if you check both boxes for one or more of the mixture factors, the Fit Model 
platform uses the L coding if (1 – L) < (U – 1), and the U coding otherwise. If only one coding box is 
checked consistently for all mixture factors in the model, then only that one pseudocomponent coding 
is used.

In the Fit Model report, the main effects are labeled with the coding transformation. Crossed effects 
are not labeled, but coding values are used. All the features of fitting, such as the profilers and saved 

XiL Xi Li–( ) 1 L–( )⁄=

XiU Ui Xi–( ) U 1–( )⁄=
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formulas, respect the pseudocomponent coding but present the un-coded values in the tables and 
plots.

3 Select the Design Role Column Property, and choose Mixture from its drop down menu.

4 Click OK. The properties icon ( ) now appears next to the column name in the columns panel, 
indicating the column contains one or more column properties. 

Figure 3.26 Column Info to Create Mixture Column For Analysis

5 Repeat the above steps for any other mixture factors that will be included in the model.

Define Response Column Values

You can save response limits in a column, which means you can run analyses without having to re-spec-
ify response limits each time. Saving these limits in a column facilitates consistency. For example, if you 
run an analysis that employs these limits, then come back later and change the data, you can run a new 
analysis using the same limits without having to reenter them. To see the example in Figure 3.27, open 
Bounce Data.jmp from the Design Experiment folder in the sample data installed with JMP. 

Figure 3.27 shows the panel with values that specify lower, middle, and upper limits, and a desirability 
value. You can also select a possible goal for a DOE response variable: Maximize, Match Target, 
Minimize, or None. If you have more than one response, you can enter an importance value, which lets 
JMP know how to weigh the importance of one response against another.

To enter response limits:

1 Double-click the column name in the data grid. The Column Info dialog appears.

2 Select Response Limits from the Column Properties drop-down menu.
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3 Complete the settings in the window, as described in Figure 3.27.

4 Click OK. The properties icon ( ) now appears next to the column name in the column panel of 
the data table to indicate that the column contains a property.

Figure 3.27 Define Response Column Values

Assign Columns a Design Role

The Custom designer in JMP assigns design roles to factors when you create the design. However, you 
can assign a property to a column that identifies a factor column as a continuous, categorical, blocking, 
covariate, mixture, constant, signal, or noise factor. The example in Figure 3.28 shows the Whole Plots 
factor in the Vinyl Data.jmp table from the Design Experiment sample data assigned the Random 
Block design role.

To give a column a design role:

1 Double-click the column name in the data grid. The Column Info window appears.

2 Select Design Role from the Column Properties drop-down menu, as shown in Figure 3.28. 
Design role information appears on the right.

3 Click the Design Role drop-down menu and select how you want JMP to use the factor column: 
Continuous, Categorical, Blocking, Covariate, Mixture, Constant, Signal, Noise, Uncontrolled, 
or Random Block.

4 Click OK to see the property icon ( ) next to the column name in the data table’s column panel.

Click to select a goal for the response 
variable. For example, if you are in 
the prediction profiler and want the 
desired value to be close to zero, 
select Match Target

When you have two responses, enter 
a number to indicate the amount of 
weight you want this response to 
have when JMP computes the over-
all desirability

Enter the lower, middle and 
upper limits as well as the 
desirability values
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Figure 3.28 Assign a Design Role to a Factor Column

Identify Factor Changes Column Property

To create split plot or split-split plot designs, you must identify a factor as having values that are hard to 
change, or very hard to change. This is done in the DOE design panel (see “Creating Split Plot 
Designs,” p. 72, for details) each time you design an experiment. However, if you know that every time 
you use that factor, you want it to be considered hard or very hard to change, you can save yourself 
steps by setting up a column property to be used in all experiments using that factor. To do this:

1 Double-click the column name in the data grid to see the Column Info dialog for that column.

2 Select Factor Changes from the Column Properties drop-down menu, as shown in Figure 3.29.

3 Click the Factor Changes button and select Easy, Hard, or Very Hard from the Factor Changes 
drop-down menu.

4 Click OK. The properties icon ( ) now appears next to the column name in the column panel of 
the data table.

Note: Although you can save design roles for factors, which are then automatically used each time 
those factors are loaded, you must always verify that the model for the design you create is correctly 
entered into the DOE custom designer.
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Figure 3.29 Factor Changes Column Property

How Custom Designs Work: Behind the Scenes
The custom designer starts with a random set of points inside the range of each factor. The computa-
tional method is an iterative algorithm called coordinate exchange (Meyer and Nachtsheim, 1995). Each 
iteration of the algorithm involves testing every value of every factor in the design to determine if 
replacing that value increases the optimality criterion. If so, the new value replaces the old. This process 
continues until no replacement occurs for an entire iteration. 

To avoid converging to a local optimum, the whole process is repeated several times using a different 
random start. The custom designer displays the best of these designs. For more details, see the section 
“Optimality Criterion: Changing the Design Criterion (D- or I- Optimality),” p. 78.

Sometimes a design problem can have several equivalent solutions. Equivalent solutions are designs 
with equal precision for estimating the model coefficients as a group. When this is true, the design algo-
rithm may generate different (but equivalent) designs when you click the Back and Make Design but-
tons repeatedly. 



Chapter 4
Screening Designs

Screening designs are some of the most popular designs for industrial experimentation. They examine 
many factors to see which have the greatest effect on the results of a process. 

Screening designs generally require fewer experimental runs, which is why they cost less. Thus, they are 
attractive because they are a relatively inexpensive and efficient way to begin improving a process.

Often screening designs are a prelude to further experiments. It is wise to spend only about a quarter of 
your resource budget on an initial screening experiment. You can then use the results to guide further 
study.

The efficiency of screening designs depends on the critical assumption of effect sparsity. Effect sparsity 
results because real-world processes usually have only a few driving factors; other factors are relatively 
unimportant. To understand the importance of effect sparsity, you can contrast screening designs to full 
factorial designs:

• Full factorial designs consist of all combinations of the levels of the factors. The number of runs is 
the product of the factor levels. For example, a factorial experiment with a two-level factor, a 
three-level factor, and a four-level factor has 2 x 3 x 4 = 24 runs. 

• By contrast, screening designs reduce the number of runs by restricting the factors to two (or three) 
levels and by performing only a fraction of the full factorial design.

Each factor in a screening design is usually set at two levels to economize on the number of runs 
needed, and response measurements are taken for only a fraction of the possible combinations of levels. 
In the case described above, you can restrict the factors to two levels, which yield 2 x 2 x 2 = 8 runs. 
Further, by doing half of these eight combinations you can still assess the separate effects of the three 
factors. So the screening approach can reduce the original 24-run experiment to four runs.

Of course, there is a price for this reduction. This chapter discusses the screening approach in detail, 
showing both pros and cons. It also describes how to use JMP’s screening designer, which supplies a list 
of popular screening designs for two or more factors. These factors can be continuous or categorical, 
with two or three levels. The list of screening designs you can use includes designs that group the exper-
imental runs into blocks of equal sizes where the size is a power of two.
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Screening Design Examples
This chapter is divided into two sections. The first section consists of two examples using screening 
designs. The second section outlines the procedures to follow to create a screening design to match your 
needs. 

Using Two Continuous Factors and One Categorical Factor

Suppose an engineer wants to investigate a process that uses an electron beam welding machine to join 
two parts. The engineer fits the two parts into a welding fixture that holds them snugly together. A 
voltage applied to a beam generator creates a stream of electrons that heats the two parts, causing them 
to fuse. The ideal depth of the fused region is 0.17 inches. The engineer wants to study the welding 
process to determine the best settings for the beam generator to produce the desired depth in the fused 
region.

For this study, the engineer wants to explore the following three inputs, which are the factors for the 
study:

• Operator, who is the technician operating the welding machine

• Rotation Speed, which is the speed at which the part rotates under the beam

• Beam Current, which is a current that affects the intensity of the beam

After each processing run, the engineer cuts the part in half. This reveals an area where the two parts 
have fused. The Length of this fused area is the depth of penetration of the weld. This depth of pene-
tration is the response for the study.

The goals of the study are to:

• find which factors affect the depth of the weld

• quantify those effects

• find specific factor settings that predict a weld depth of 0.17 inches

To begin this example, select DOE > Screening Design from the main menu. Note that in the 
Responses panel, there is a single default response called Y. Change the default response as follows:

1 Double-click the response name and change it to Depth (In.). 

2 The default goal for the single default response is Maximize, but the goal of this process is to get a 
target value of 0.17 inches with a lower bound of 0.12 and an upper bound of 0.22. Click the Goal 
box and choose Match Target from the drop-down menu, as shown in Figure 4.1. 
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Figure 4.1 Screening Design Response With Match Target Goal

3 Click the Lower Limit text edit area and enter 0.12 as the lower limit (minimum acceptable value). 
Then click the Upper Limit text edit area and enter 0.22 as the upper limit (maximum acceptable 
value).

This example has one categorical factor (Operator) and two continuous factors (Speed and Current). 

4 Add the categorical factor by clicking the Add button beside 2-Level Categorical. 

5 Add two continuous factors by typing 2 in the Continuous box and clicking the associated Add 
button. 

6 Double-click the factor names and rename them Operator, Speed, and Current. 

7 Set high and low values for Speed to 3 and 5 rpm. Set high and low values for Current to 150 and 
165 amps, and assign Mary and John as values for the categorical factor called Operator, as shown in 
Figure 4.2.

Figure 4.2 Screening Design with Two Continuous and One Categorical Factor

8 Click Continue.

9 Select Full Factorial in the list of designs, as shown in Figure 4.3, and then click Continue.

Click the Goal box 
and choose Match 
Target 
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Figure 4.3 List of Screening Designs for Two Continuous and One Categorical Factors

In the Output Options section of the Display and Modify Design panel that appears, click on the Run 
Order menu and select Sort Left to Right, which arranges the runs in the JMP design data table (see 
Figure 4.7). Then click Make Table to create the JMP table that contains the specified design.

The table in Figure 4.4 appears. The table uses the names for responses, factors, and levels you speci-
fied. The Pattern variable shows the coded design runs. You can also see the table produced in this 
example by selecting Help > Sample Data > Design of Experiments > DOE Example 1.jmp.

Figure 4.4 The Design Data Table

Using Five Continuous Factors

As illustrated in the previous section, experiments for screening the effects of many factors usually con-
sider only two levels of each factor. This allows the examination of many factors with a minimum num-
ber of runs. 

The following example, adapted from Meyer, et al. (1996), demonstrates how to use JMP’s screening 
designer when you have many factors. In this study, a chemical engineer investigates the effects of five 
factors on the percent reaction of a chemical process. The factors are: 

• feed rate, the amount of raw material added to the reaction chamber in liters per minute 

• percentage of catalyst 

• stir rate, the RPMs of a propeller in the chamber

• reaction temperature in degrees Celsius

• concentration of reactant
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To start the example:

1 Select DOE > Screening Design.

2 You see one default response called Y. Change the default response name (Y) to Percent Reacted.

3 The Goal is to maximize the response, but change the minimum acceptable reaction percentage to 
90 (Lower Limit), and upper limit to 99 (Upper Limit), as shown in Figure 4.5.

4 Add five continuous factors.

5 Change the default factor names (X1-X5) to Feed Rate, Catalyst, Stir Rate, Temperature, and 
Concentration.

6 Enter the high and low values, as shown in Figure 4.5. 

Figure 4.5 Screening for Many Factors

7 Click Continue. Now, JMP lists the designs for the number of factors you specified, as shown to the 
left in Figure 4.6. 

8 Select the first item in the list, which is an 8-run fractional factorial design with no blocks. 

9 Click Continue to see the Display and Modify Design panel on the right in Figure 4.6.
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Figure 4.6 Two-level Screening Design (left) and design output options (right)

The design dialog has options shown in Figure 4.7 that can modify the final design table.

Figure 4.7 Output Options for Design Table

10 Click Make Table to create the data table shown in Figure 4.8 that lists the runs for the design you 
selected. Note that it also has a column called Percent Reacted for recording experimental results, 
showing as the rightmost column of the data table.
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Figure 4.8 JMP Table of Runs for Screening Example

Of the five factors in the reaction percentage experiment, you expect a few to stand out in comparison 
to the others. Let’s take an approach to the analysis that looks for active effects.

11 To run the model generated by the data shown in Figure 4.8, open Reactor 8 Runs.jmp from the 
Design Experiment folder found in the sample data that was installed with JMP. This table has the 
design runs and the results of the experiment. 

12 In the design data table, click the Screening script that shows on the upper left of the data table, and 
select Run Script. Or, you can choose Analyze > Modeling > Screening to analyze the data. Select 
Percent Reacted as Y and all other continuous variables as X. Click OK.The report is shown in 
Figure 4.9.

Figure 4.9 Report for Screening Example

Note: Analysis of the screening data is covered in the section “Create a Plackett-Burman design,” 
p. 106 at the end of this chapter.
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Create a Fractional Factorial Design
To begin, select DOE > Screening Design, or click the Screening Design button on the JMP Starter 
DOE page. Then, see the following sections for each step to create a screening design: 

1 “Enter Responses,” p. 97

2 “Enter Factors,” p. 98

3 “Choose a Design,” p. 99

4 “Display and Modify a Design,” p. 102

5 “Specify Output Options,” p. 105

6 “View the Design Table,” p. 106

Enter Responses

To enter responses, follow the steps in Figure 4.10.

Figure 4.10 Entering Responses

Tip: To quickly enter multiple responses, click the Number of Responses button and enter the num-
ber of responses you want.

Specifying Goal Types and Lower and Upper Limits

When entering responses, you can tell JMP that your goal is to obtain the maximum or minimum 
value possible, to match a specific value, or that there is no goal. 

The following description explains the relationship between the goal type (step 3 in Figure 4.10) and 
the lower and upper limits (step 4 in Figure 4.10):

• For responses such as strength or yield, the best value is usually the largest possible. A goal of 
Maximize supports this objective. 

Click to change the response goal, 
if desired.

To enter one 
response at a 
time, click then 
select a goal type: 
Maximize, Match 
Target, Minimize, 
or None.

Double-click to edit 
the response name, if 
desired.

Click to enter lower and upper 
limits and importance weights.

2 3

4

1
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• The Minimize goal supports an objective of having the smallest value be the most desirable, such as 
when the response is impurity or defects. 

• The Match Target goal supports the objective when the best value for a response is a specific target 
value, such as dimensions of a manufactured part. The default target value is assumed to be midway 
between the lower and upper limits.

Note: If your target range is not symmetric around the target value, you can alter the default target 
after you make a table from the design. In the data table, open the response’s Column Info dialog by 
double-clicking the column name, and enter an asymmetric target value.

Understanding Importance Weights 

When computing overall desirability, JMP uses the value you enter as the importance weight (step 4 in 
Figure 4.10) as the weight of each response. If there is only one response, then specifying importance is 
unnecessary. With two responses you can give greater weight to one response by assigning it a higher 
importance value.

Enter Factors

Next, you enter factors. The Factors panel’s appearance depends on the design you select. Entering fac-
tors is the same in Screening Design, Space Filling Design, Mixture Design, and Response 
Surface Design. This process is described below, in Figure 4.11.

Figure 4.11 Entering Factors

Types of Factors

In general, when designing experiments, you can enter different types of factors in the model. Below is 
a description of factor types from which you can choose when creating screening designs:

Continuous Continuous factors have numeric data types only. In theory, you can set a continuous 
factor to any value between the lower and upper limits you supply.

Categorical Categorical factors (either numeric or categorical data types) have no implied order. 
If the values are numbers, the order is the numeric magnitude. If the values are character, the 

To enter factors, type the 
number of factors and click 
Add.

Double-click to 
edit the factor 
name.

Click to enter factor values. To remove a level, click 
it, press the delete key on your keyboard, then press 
the Return or Enter key on your keyboard.

Highlight the factor and 
click the Remove Selected 
button to remove a factor in 
the list.
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order is the sorting sequence. The settings of a categorical factor are discrete and have no intrinsic 
order. Examples of categorical factors are machine, operator, and gender.

After you enter responses and factors, click Continue.

Choose a Design

The list of screening designs you can use includes designs that group the experimental runs into blocks 
of equal sizes where the size is a power of two. Highlight the type of screening design you want to use 
and click Continue.

Figure 4.12 Choosing a Type of Screening Design

The screening designer provides the following types of designs:

Two-Level Full Factorial

A full factorial design has runs for all combinations of the levels of the factors. The samples size is the 
product of the levels of the factors. For two-level designs, this is 2k where k is the number of factors. 
This can be expensive if the number of factors is greater than 3 or 4.

These designs are orthogonal. This means that the estimates of the effects are uncorrelated. If you 
remove an effect in the analysis, the values of the other estimates remain the same. Their p-values 
change slightly, because the estimate of the error variance and the degrees of freedom are different.

Full factorial designs allow the estimation of interactions of all orders up to the number of factors. Most 
empirical modeling involves first- or second-order approximations to the true functional relationship 
between the factors and the responses. The figure to the left in Figure 4.13 is a geometric representation 
of a two-level factorial.

Two-Level Fractional Factorial

A fractional factorial design also has a sample size that is a power of two. If k is the number of factors, 
the number of runs is 2k – p where p < k. The fraction of the full factorial is 2-p. Like the full factorial, 
fractional factorial designs are orthogonal.

The trade-off in screening designs is between the number of runs and the resolution of the design. If 
price is no object, you can run several replicates of all possible combinations of m factor levels. This 
provides a good estimate of everything, including interaction effects to the mth degree. But because 
running experiments costs time and money, you typically only run a fraction of all possible levels. This 
causes some of the higher-order effects in a model to become nonestimable. An effect is nonestimable 
when it is confounded with another effect. In fact, fractional factorials are designed by deciding in 
advance which interaction effects are confounded with the other interaction effects.
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Resolution Number: The Degree of Confounding

In practice, few experimenters worry about interactions higher than two-way interactions. These 
higher-order interactions are assumed to be zero. 

Experiments can therefore be classified by resolution number into three groups:

• Resolution = 3 means that main effects are confounded with one or more two-way interactions, 
which must be assumed to be zero for the main effects to be meaningful.

• Resolution = 4 means that main effects are not confounded with other main effects or two-factor 
interactions. However, two-factor interactions are confounded with other two-factor interactions.

• Resolution ≥ 5 means there is no confounding between main effects, between two-factor interac-
tions, or between main effects and two-factor interactions.

All the fractional factorial designs are minimum aberration designs. A minimum aberration design is 
one in which there are a minimum number of confoundings for a given resolution. For DOE experts, 
the minimum aberration design of a given resolution minimizes the number of words in the defining 
relation that are of minimum length.

The figure on the right in Figure 4.13 is geometric representation of a two-level fractional factorial 
design.

Figure 4.13 Representation of Full Factorial (Left) and Two-Level Fractional Factorial (Right) Designs

Plackett-Burman Designs

Plackett-Burman designs are an alternative to fractional factorials for screening. One useful characteris-
tic is that the sample size is a multiple of four rather than a power of two. There are no two-level frac-
tional factorial designs with sample sizes between 16 and 32 runs. However, there are 20-run, 24-run, 
and 28-run Plackett-Burman designs.

The main effects are orthogonal and two-factor interactions are only partially confounded with main 
effects. This is different from resolution-three fractional factorial where two-factor interactions are 
indistinguishable from main effects. 

In cases of effect sparsity, a stepwise regression approach can allow for removing some insignificant 
main effects while adding highly significant and only somewhat correlated two-factor interactions. The 
new Screening platform in JMP, Analyze > Modeling > Screening, is a streamlined approach for look-
ing at sparse data. This platform can accept multiple responses and multiple factors, then automatically 
fits a two-level design and shows significant effects with plots and statistics. See “Screening Designs,” 
p. 89 of JMP Statistics and Graphics Guide for documentation of the Screening platform.

-1, -1, -1
-1, 1, -1

1, 1, 1

-1, -1, 1

1, -1, -1

1, 1, -1
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Mixed-Level Designs

If you have qualitative factors with three values, then none of the classical designs discussed previously 
are appropriate. For pure three-level factorials, JMP offers fractional factorials. For mixed two-level and 
three-level designs, JMP offers complete factorials and specialized orthogonal-array designs, listed in 
Table 4.1

If you have fewer than or equal to the number of factors for a design listed in the table, you can use that 
design by selecting an appropriate subset of columns from the original design. Some of these designs are 
not balanced, even though they are all orthogonal.
.

Cotter Designs

Cotter designs are used when you have very few resources and many factors, and you believe there may 
be interactions. Suppose you believe in effect sparsity— that very few effects are truly nonzero. You 
believe in this so strongly that you are willing to bet that if you add up a number of effects, the sum will 
show an effect if it contains an active effect. The danger is that several active effects with mixed signs 
will cancel and still sum to near zero and give a false negative.

Cotter designs are easy to set up. For k factors, there are 2k + 2 runs. The design is similar to the “vary 
one factor at a time” approach many books call inefficient and naive.

A Cotter design begins with a run having all factors at their high level. Then follow k runs each with 
one factor in turn at its low level, and the others high. The next run sets all factors at their low level and 
sequences through k more runs with one factor high and the rest low. This completes the Cotter design, 
subject to randomizing the runs.

When you use JMP to generate a Cotter design, the design also includes a set of extra columns to use as 
regressors. These are of the form factorOdd and factorEven where factor is a factor name. They are con-
structed by adding up all the odd and even interaction terms for each factor. For example, if you have 
three factors, A, B, and C:

Because these columns in a Cotter design make an orthogonal transformation, testing the parameters 
on these combinations is equivalent to testing the combinations on the original effects. In the example 
of factors listed above, AOdd estimates the sum of odd terms involving A. AEven estimates the sum of 
the even terms involving A, and so forth.

Because Cotter designs have a false-negative risk, many statisticians discourage their use. 

Table 4.1 Table of Mixed-Level Designs
Design Two–Level Factors Three–Level Factors

L18 John 1 7

L18 Chakravarty 3 6

L18 Hunter 8 4

L36 11 12

Table 4.2
AOdd = A + ABC AEven = AB + AC

BOdd = B + ABC BEven = AB + BC

COdd = C + ABC CEven = BC + AC
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How to Run a Cotter Design

By default, JMP does not include a Cotter design in the list of available screening designs (Figure 4.12). 
However, if you want to make a Cotter design:

1 Immediately after entering responses and factors (and before clicking Continue), click the red trian-
gle icon in the Screening Design title bar.

2 Select Supress Cotter Designs (to uncheck it), as shown to the right.

Changing the setting via the red triangle menu applies only to the current design. To alter the setting for 
all screening designs:

1 Select File > Preferences.

2 Click the Platforms icon.

3 Click DOE to highlight it.

4 Uncheck the box beside Suppress Cotter Designs.

Display and Modify a Design

After you select a design type, click the disclosure buttons (  on Windows/Linux and  on the 
Macintosh) to display the design and show modification options using the Display and Modify Design 
panel to tailor the design (Figure 4.14). 

Figure 4.14 Display and Modification Options

Change Generating Rules Controls the choice of different fractional factorial designs for a given 
number of factors.

Aliasing of Effects Shows the confounding pattern for fractional factorial designs.

Coded Design Shows the pattern of high and low values for the factors in each run. 

Aliasing of Effects

To see which effects are confounded with which other effects, click the disclosure button (  on 
Windows/Linux and  on the Macintosh) to reveal the Aliasing of Effects panel. It shows effects 
and confounding up to two-factor interactions (Figure 4.15).
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Figure 4.15 Generating Rules and Aliasing of Effects Panel

For example, a full factorial with five factors requires 25 = 32 runs. Eight runs can only accommodate a 
full factorial with three two-level factors. It is necessary to construct the two additional factors in terms 
of the first three factors. 

The price of reducing the number of runs from 32 to eight is effect aliasing (confounding). Confound-
ing is the direct result of the assignment of new factor values to products of the coded design columns. 

In the example above, the values for Temperature are the product of the values for Feed Rate and 
Concentration. This means that you can’t tell the difference of the effect of Temperature and the syner-
gistic (interactive) effect of Feed Rate and Concentration.

In the example shown in Figure 4.15, all the main effects are confounded with two-factor interactions. 
This is characteristic of resolution-three designs. 

Look at the Confounding Pattern

JMP can create a data table that shows the aliasing pattern for a specified level. To create this table:

1 Click the red triangle at the bottom of the Aliasing of Effects area.

2 Select Show Confounding Pattern (Figure 4.16). 

Figure 4.16 Show Confounding Patterns

3 Enter the order of confounding you want to see (Figure 4.17). 
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Figure 4.17 Enter Order of Confounding in Text Edit Box

4 Click OK.

Figure 4.18 shows the third order aliasing for the five-factor reactor example. The effect names begin 
with C (Constant) and are shown by their order number in the design. Thus, Temperature appears as 
“4”, with second order aliasing as “1 5” (Feed Rate and Concentration), and third order confounding 
as “1 2 3” (Feed Rate, Catalyst, and Stir Rate).

Figure 4.18 The Third Level Alias for the Five-Factor Reactor Example

Understanding Design Codes

In the Coded Design panel, each row represents a run. Plus signs designate high levels and minus signs 
represent low levels. As shown in Figure 4.19, rows for the first three columns of the coded design, 
which represent Feed Rate, Catalyst, and Stir Rate are all combinations of high and low values (a full 
factorial design). The fourth column (Temperature) of the coded design is the element-by-element 
product of the first three columns. Similarly, the last column (Concentration) is the product of the sec-
ond and third columns.

Figure 4.19 Default Coded Designs

Feed Rate

Catalyst Temperature Concentration
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Changing the Coded Design

In the Change Generating Rules panel, changing the check marks and clicking Apply changes the 
coded design; it changes the choice of different fractional factorial designs for a given number of fac-
tors. The Coded Design table in Figure 4.19 shows how the last two columns are constructed in terms 
of the first three columns. The check marks in the Change Generating Rules table shown in 
Figure 4.20 for Temperature now show it is a function of Feed Rate, and Catalyst. The check marks 
for Concentration show it is a function of Feed Rate and Stir Rate. 

If you check the options as shown in Figure 4.20 and click Apply, the Coded Design panel changes. 
The first three columns of the coded design remain a full factorial for the first three factors (Feed Rate, 
Catalyst, and Stir Rate). Temperature is now the product of Feed Rate and Catalyst, so the fourth 
column of the coded design is the element by element product of the first two columns. Concentration 
is a function of Feed Rate and Stir Rate.

Figure 4.20 Modified Coded Designs and Generating Rules

Specify Output Options

Use the Output Options panel (Figure 4.21) to specify how you want the output data table to appear. 
When the options are the way you want them, click Make Table.

Figure 4.21 Select the Output Options
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Run Order Lets you designate the order you want the runs to appear in the data table when it is 
created. Choices are:

Keep the Same—the rows (runs) in the output table appear as they do in the Design panel. 

Sort Left to Right—the rows (runs) in the output table appear sorted from left to right. 

Randomize—the rows (runs) in the output table appear in a random order.

Sort Right to Left—the rows (runs) in the output table appear sorted from right to left. 

Randomize within Blocks—the rows (runs) in the output table will appear in random order 
within the blocks you set up. 

Number of Center Points Specifies additional runs placed at the center points.

Number of Replicates Specify the number of times to replicate the entire design, including cen-
terpoints. Type the number of times you want to replicate the design in the associated text box. 
One replicate doubles the number of runs.

View the Design Table

Click Make Table to create a data table that contains the runs for your experiment. In the table, the 
high and low values you specified are displayed for each run. 

Figure 4.22 The Design Data Table

Create a Plackett-Burman design
The previous example shows an 8-run fractional factorial design for five continuous factors. But sup-
pose you can afford 4 additional runs. First, repeat the steps shown in the previous sections. This time, 
use the Load Responses and Load Factors commands to define the design, as follows:

1 Select DOE > Screening Design.

2 Select Load Responses from the red triangle menu on the Screening Design title bar. Navigate to 

The name of the table is 
the design type that 
generated it.

The column called Pattern shows the pattern of low values 
denoted “–” and high values denoted “+”. Pattern is especially 
useful as a label variable in plots.

This script 
allows you to 
screen for active 
effects.
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the Design Experiment folder in the Sample Data installed with JMP and open the file called 
Reactor Response.jmp. 

3 Next, select Load Factors from red triangle menu on the Screening Design title bar. Navigate to the 
Design Experiment folder in the Sample Data installed with JMP and open the file called 
Reactor Factors.jmp. 

These two commands complete the DOE screening dialog for you, with the correct response and factor 
names, goal and limits for the response, and the values for the factors. 

4 Click Continue on the completed Screening design dialog to see the list of designs in Figure 4.23, 
and chose the Plackett-Burman, as shown. 

Figure 4.23 Design List for 5-factor Plackett-Burman Screening Design

5 Click Continue.

After you select the model from the Design list, the outlines for modifying and evaluating the model 
appear. In the Custom designer, you have the ability to form any model effects you want. The Screen-
ing designer creates the design effects based on the design you choose. In particular, the full factorial 
with all two-factor interactions has no aliasing of the included interactions, as shown in Figure 4.24.
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Figure 4.24 No aliasing of the included interactions

A complete discussion of the Design Evaluation options is found in Chapter 3, “Building Custom 
Designs.”

To continue with this example, do the following:

6 Choose Sort Left to Right in the Output Options panel.

7 Click Make Table to see the design runs shown in Figure 4.25.

Examine the data table and note the Pattern variable to see the arrangement of plus and minus signs 
that define the runs. This table is used in the analysis sections that follow. 

Figure 4.25 Listing of a 5-factor Placket-Burman Design Table with Results

Analysis of Screening Data
After creating and viewing the data table, you can now run analyses on the data. As an example, open 
the data table called Plackett-Burman.jmp, found in Design Experiment folder in the Sample Data 
installed with JMP. This table contains the design runs and the Percent Reacted experimental results 
for the 12-run Plackett-burman design created in the previous section. 
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Using the Screening Analysis Platform

The data table has two scripts called Screening and Model, showing in the upper-left corner of the 
table, that were created by the DOE Screening designer. You can use these scripts to analyze the data, 
however it is simple to run the analyses yourself. 

1 Select Analyze > Modeling > Screening to see the completed launch dialog shown in Figure 4.26. 
When you create a DOE design table, the variable roles are saved with the data table and used by the 
launch platform to complete the dialog. 

Figure 4.26 Launch Dialog for the Screening Platform

2 Click OK to see the Screening platform result shown in Figure 4.27.

The Contrasts section of the Screening platform results lists all possible model effects, a contrast value 
for each effect, Lenth t-ratios (calculated as the contrast value divided by the Lenth PSE (pseudo-stan-
dard error), individual and simultaneous p-values, and aliases if there are any. Significant and margin-
ally significant effects are highlighted. See the chapter on analyzing Screening designs in the Statistics 
and Graphics Guide for complete documentation of the Screening analysis platform.
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Figure 4.27 Results of the Screening Analysis

3 Examine the Half Normal plot in Figure 4.27.

Using the Fit Model Platform

The Make Model button beneath the Half Normal Plot creates a Fit Model dialog that includes all the 
highlighted effects. However, note that the Catalyst*Stir Rate interaction is highlighted, but the Stir 
Rate main effect is not. Therefore, that interaction shouldn’t be in the model.

4 Click the Make Model Button beneath the Half Normal Plot to see the completed Fit Model dialog 
in Figure 4.28.

5 Highlight the Catalyst*Stir Rate interaction and click Remove on the Fit Model dialog.

6 Then click Run Model to see the analysis results.
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Figure 4.28 Create Fit Model Dialog and Remove Unwanted Effect

The Actual-by-Predicted Plot

The Whole Model actual-by-predicted plot, shown on the left in Figure 4.29, appears at the top of the 
Fit Model report. You see at a glance that this model fits well. The mean line falls outside the bounds of 
the 95% confidence curves (red-dotted lines), which tells you the model is significant. The model 
p-value (p = 0.0178), R2, and RMSE appear below the plot. The RMSE is an estimate of the standard 
deviation of the process noise, assuming that the unestimated effects are negligible.

In this example, the Pattern variable is designated as a label column. To show labels in the plot (on the 
right in Figure 4.29), shift click to select points of interest, right-click the graph, and select Row Label. 
The pattern variable displayed in the data table serves as the label for each point. Also, you can hover 
over a point to see the label.

Figure 4.29 An Actual-by-Predicted Plot
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The Scaled Estimates Report

To see a scaled estimates report, use Effect Screening > Scaled Estimates found in the red triangle 
menu on the Response Percent Reacted title bar. When there are quadratic or polynomial effects, the 
coefficients and the tests for them are more meaningful if effects are scaled and coded. The Scaled Esti-
mates report includes a bar chart of the individual effects embedded in a table of parameter estimates. 
The last column of the table has the p-values for each effect.

Figure 4.30 Example of a Scaled Estimates Report

A Power Analysis

The Fit Model report has outline nodes for the Catalyst and Temperature effects. To run a power anal-
ysis for an effect, click the red triangle icon on its title bar and select Power Analysis.

This example shows a power analysis for the Catalyst variable, using default value for α (0.05), the root 
mean square error and parameter estimate for Catalyst, for a sample size of 12. The resulting power is 
0.802, which means that in similar experiments, you can expect an 80% chance of detecting a signifi-
cant effect for Catalyst.
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Figure 4.31 Example of a Power Analysis

Refer to the JMP Statistics and Graphics Guide for details.





Chapter 5
Response Surface Designs

Response surface designs are useful for modeling a curved quadratic surface to continuous factors. A 
response surface model can pinpoint a minimum or maximum response, if one exists inside the factor 
region. Three distinct values for each factor are necessary to fit a quadratic function, so the standard 
two-level designs cannot fit curved surfaces. 

The most popular response surface design is the central composite design, illustrated in the figure to the 
left below. It combines a two-level fractional factorial and two other kinds of points:

• Center points, for which all the factor values are at the zero (or midrange) value.

• Axial (or star) points, for which all but one factor are set at zero (midrange) and that one factor is set 
at outer (axial) values.

The Box-Behnken design, illustrated in the figure on the right below, is an alternative to central com-
posite designs. One distinguishing feature of the Box-Behnken design is that there are only three levels 
per factor. 

Another important difference between the two design types is that the Box-Behnken design has no 
points at the vertices of the cube defined by the ranges of the factors. This is sometimes useful when it 
is desirable to avoid these points due to engineering considerations. The price of this characteristic is 
the higher uncertainty of prediction near the vertices compared to the central composite design.

center points

axial points

fractional factorial points

Central Composite Design Box-Behnken Design
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A Box-Behnken Design: The Tennis Ball Example 
The Bounce Data.jmp sample data file has response surface data inspired by the tire tread data 
described in Derringer and Suich (1980). The objective of this experiment is to match a standardized 
target value (450) of tennis ball bounciness. The bounciness varies with amounts of Silica, Silane, and 
Sulfur used to manufacture the tennis balls. The experimenter wants to collect data over a wide range of 
values for these variables to see if a response surface can find a combination of factors that matches a 
specified bounce target. To follow this example:

1 Select DOE > Response Surface Design. 

2 Load factors by clicking the red triangle icon on the Response Surface Design title bar and selecting 
Load Factors. Navigate to the Sample Data folder installed with JMP, and open Bounce 
Factors.jmp from the Design Experiment folder.

3 Load the responses by clicking the red triangle icon on the Response Surface Design title bar and 
selecting Load Responses. Navigate to the Sample Data folder, and open Bounce Response.jmp 
from the Design Experiment folder. Figure 5.1 shows the completed Response panel and Factors 
panel.

Figure 5.1 Response and Factors For Bounce Data

After the response data and factors data are loaded, the Response Surface Design Choice dialog lists the 
designs in Figure 5.2.

Figure 5.2 Response Surface Design Selection

The Box-Behnken design selected for three effects generates the design table of 15 runs shown in 
Figure 5.3. 

In real life, you would conduct the experiment and then enter the responses into the data table. Sup-
pose you completed the experiment and the final data table is Bounce Data.jmp.

1 Open Bounce Data.jmp from the Design Experiment folder found in the sample data installed with 
JMP (Figure 5.3).
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Figure 5.3 JMP Table for a Three-Factor Box-Behnken Design

After opening the Bounce Data.jmp data table, run a fit model analysis on the data. The data table 
contains a script labeled Model, showing in the upper left panel of the table.

2 Click the red triangle next to Model and select Run Script to start a fit model analysis.

3 When the Fit Model dialog appears, click Run Model.

The standard Fit Model analysis results appear in tables shown in Figure 5.4, with parameter estimates 
for all response surface and crossed effects in the model. 

The prediction model is highly significant with no evidence of lack of fit. All main effect terms are sig-
nificant as well as the two interaction effects involving Sulfur.

Figure 5.4 JMP Statistical Reports for a Response Surface Analysis of Bounce Data

See the chapter “Standard Least Squares: Introduction” of JMP Statistics and Graphics Guide for more 
information about interpretation of the tables in Figure 5.4.

The Response Surface report also has the tables shown in Figure 5.5.



5
R

e
s
p

o
n

s
e
 S

u
rfa

c
e
 D

e
s
ig

n
s

Chapter 5 Response Surface Designs 119
A Box-Behnken Design: The Tennis Ball Example

Figure 5.5 Statistical Reports for a Response Surface Analysis

See the chapter “Standard Least Squares: Exploring the Prediction Equation” of JMP Statistics and 
Graphics Guide for details about the response surface analysis tables in Figure 5.5.

The Prediction Profiler

Next, use the response Prediction Profiler to get a closer look at the response surface and help find the 
settings that produce the best response target. The Prediction Profiler is a way to interactively change 
variables and look at the effects on the predicted response.

1 If the Prediction Profiler is not already open, click the red triangle on the Response title bar and 
select Factor Profiling > Profiler, as shown in Figure 5.6. 

Figure 5.6 The Profiler

Summary of the parameter 
estimates

Lists the critical values of the 
surface factors and tells the kind 
of solution (maximum, mini-
mum, or saddle point). The 
solution for this example is a 
saddle point. The table also 
warns that the critical values 
given by the solution are outside 
the range of data values.

Shows eigenvalues and eigenvectors of the effects. The eigenvector 
values show that the dominant negative curvature (yielding a maxi-
mum) is mostly in the Sulfur direction. The dominant positive cur-
vature (yielding a minimum) is mostly in the Silica direction. This is 
confirmed by the prediction profiler in Figure 5.8. 
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The first three plots in the top row of plots in the Prediction Profiler (Figure 5.7) display prediction 
traces for each x variable. A prediction trace is the predicted response as one variable is changed while 
the others are held constant at the current values (Jones 1991).

The current predicted value of Stretch, 396, is based on the default factor setting. It is represented by 
the horizontal dotted line that shows slightly below the desirability function target value (Figure 5.7). 
The profiler shows desirability settings for the factors Silica, Silane, and Sulfur that give a value for 
Stretch of 396, which is well away from the specified target of 450. 

The bottom row has a plot for each factor, showing its desirability trace. The profiler also contains a 
Desirability column, which graphs desirability on a scale from 0 to 1 and has an adjustable desirability 
function for each y variable. The overall desirability measure is on the left of the desirability traces. 

Figure 5.7 The Prediction Profiler

2 To adjust the prediction traces of the factors and find a Stretch value that is closer to the target, click 
the red triangle on the Prediction Profiler title bar and select Maximize Desirability. This command 
adjusts the profile traces to produce the response value closest to the specified target (the target given 
by the desirability function). The range of acceptable values is determined by the positions of the 
upper and lower handles. 

Figure 5.8 shows the result of the most desirable settings. Changing the settings of Silica from 1.2 to 
0.94, Silane from 50 to 46, and Sulfur from 2.3 to 2.1 raised the predicted response from 396 to the 
target value of 450. Finding maximum desirability is an iterative process so your results may differ 
slightly from those shown below.
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Figure 5.8 Prediction Profiler with Maximum Desirability Set for a Response Surface Analysis

See the JMP Statistics and Graphics Guide for further discussion of the Prediction Profiler.

A Response Surface Plot (Contour Profiler)

Another way to look at the response surface is to use the Contour Profiler. Click the red triangle on the 
Response title bar and select Factor Profiling > Contour Profiler to display the interactive contour pro-
filer, as shown in Figure 5.9. 

The contour profiler is useful for viewing response surfaces graphically, especially when there are multi-
ple responses. This example shows the profile to Silica and Sulfur for a fixed value of Silane.

Options on the Contour Profiler title bar can be used to set the grid density, request a surface plot 
(mesh plot), and add contours at specified intervals, like those shown in the contour plot in Figure 5.9. 
The sliders for each factor set values for Current X and Current Y.

Figure 5.9 Contour Profiler for a Response Surface Analysis
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Figure 5.10 shows the Contour profile when the Current x values have Lo and Hi limits in effect, 
which cause shaded regions to show on the contour.

Figure 5.10 Contour Profiler with High and Low Limits

The Prediction Profiler and the Contour Profiler are discussed in more detail in the JMP Statistics and 
Graphics Guide. 

Geometry of a Box-Behnken Design

The geometric structure of a design with three effects is seen by using the Scatterplot 3D platform. The 
plot shown in Figure 5.11 illustrates the three Box-Behnken design columns. You can clearly see the 
center points and the 12 points midway between the vertices. For details on how to use the Scatterplot 
3D platform, see the JMP Statistics and Graphics Guide.

Enter Lo limit and Hi limit 
to see shaded unacceptable 
regions in contour plot.
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Figure 5.11 Scatterplot 3D Rendition of a Box-Behnken Design for Three Effects

Creating a Response Surface Design
Response Surface Methodology (RSM) is an experimental technique invented to find the optimal 
response within specified ranges of the factors. These designs are capable of fitting a second-order pre-
diction equation for the response. The quadratic terms in these equations model the curvature in the 
true response function. If a maximum or minimum exists inside the factor region, RSM can estimate it. 
In industrial applications, RSM designs usually involve a small number of factors. This is because the 
required number of runs increases dramatically with the number of factors. Using the response surface 
designer, you choose to use well-known RSM designs for two to eight continuous factors. Some of 
these designs also allow blocking. 

Response surface designs are useful for modeling and analyzing curved surfaces.

To start a response surface design, select DOE > Response Surface Design, or click the Response 
Surface Design button on the JMP Starter DOE page. Then, follow the steps described in the follow-
ing sections.

• “Enter Responses and Factors,” p. 124

• “Choose a Design,” p. 124

• “Specify Axial Value (Central Composite Designs Only),” p. 125

• “Specify Output Options,” p. 126

• “View the Design Table,” p. 126



124 Response Surface Designs Chapter 5
Creating a Response Surface Design

Enter Responses and Factors

The steps for entering responses are the same in Screening Design, Space Filling Design, Mixture 
Design, Response Surface Design, Custom Design, and Full Factorial Design. These steps are out-
lined in “Enter Responses and Factors into the Custom Designer,” p. 59

Factors in a response surface design can only be continuous. The Factors panel for a response surface 
design appears with two default continuous factors. To enter more factors, type the number you want 
in the Factors panel edit box and click Add, as shown in Figure 5.12.

Figure 5.12 Enter Factors into a Response Surface Design

Click Continue to proceed to the next step.

Choose a Design

Highlight the type of response surface design you want and click Continue. The next sections describe 
the types of response surface designs shown in Figure 5.13.

Figure 5.13 Choose a Design Type
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Box-Behnken Designs 

The Box-Behnken design has only three levels per factor and has no points at the vertices of the cube 
defined by the ranges of the factors. This is sometimes useful when it is desirable to avoid extreme 
points due to engineering considerations. The price of this characteristic is the higher uncertainty of 
prediction near the vertices compared to the central composite design.

Central Composite Designs

The response surface design list contains two types of central composite designs: uniform precision and 
orthogonal. These properties of central composite designs relate to the number of center points in the 
design and to the axial values:

• Uniform precision means that the number of center points is chosen so that the prediction variance 
near the center of the design space is very flat. 

• For orthogonal designs, the number of center points is chosen so that the second order parameter 
estimates are minimally correlated with the other parameter estimates.

Specify Axial Value (Central Composite Designs Only)

When you select a central composite (CCD-Uniform Precision) design and then click Continue, you 
see the panel in Figure 5.14. It supplies default axial scaling information. Entering 1.0 in the text box 
instructs JMP to place the axial value on the face of the cube defined by the factors, which controls how 
far out the axial points are. You have the flexibility to enter the values you want to use.

Figure 5.14 Display and Modify the Central Composite Design

Rotatable makes the variance of prediction depend only on the scaled distance from the center of 
the design. This causes the axial points to be more extreme than the range of the factor. If this 
factor range cannot be practically achieved, it is recommended that you choose On Face or spec-
ify your own value.

Orthogonal makes the effects orthogonal in the analysis. This causes the axial points to be more 
extreme than the –1 or 1 representing the range of the factor. If this factor range cannot be prac-
tically achieved, it is recommended that you choose On Face or specify your own value.

On Face leaves the axial points at the end of the -1 and 1 ranges.

User Specified uses the value you enter in the Axial Value text box. 

If you want to inscribe the design, click the box beside Inscribe. When checked, JMP rescales the 
whole design so that the axial points are at the low and high ends of the range (the axials are –1 and 1 
and the factorials are shrunken based on that scaling).
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Specify Output Options

Use the Output Options panel to specify how you want the output data table to appear. When the 
options are specified the way you want them, click Make Table. Note that the example shown in 
Figure 5.15 is for a Box-Behnken design. The Box-Behnken design from the design list and the Output 
Options request 3 center points for a single replicate.

Figure 5.15 Select the Output Options

Run Order provides a menu with options for designating the order you want the runs to appear in the 
data table when it is created. Menu choices are:

Keep the Same the rows (runs) in the output table will appear as they do in the Design panel. 

Sort Left to Right the rows (runs) in the output table will appear sorted from left to right. 

Randomize the rows (runs) in the output table will appear in a random order.

Sort Right to Left the rows (runs) in the output table will appear sorted from right to left. 

Randomize within Blocks the rows (runs) in the output table will appear in random order within 
the blocks you set up.

Add additional points with options given by Make JMP Table from design plus:

Number of Center Points Specifies additional runs placed at the center points.

Number of Replicates Specify the number of times to replicate the entire design, including cen-
terpoints. Type the number of times you want to replicate the design in the associated text box. 
One replicate doubles the number of runs.

View the Design Table

Now you have a data table that outlines your experiment, as described in Figure 5.16.
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Figure 5.16 The Design Data Table

The name of the table 
is the design type that 
generated it.

There are 
three center 
points.

Runs are in a random order.

The column called Pattern identifies the coding of the factors. It shows 
all the codings with “+” for high, “–” for low factor, “a” and “A” for low 
and high axial values, and “0” for midrange. Pattern is suitable to use as 
a label variable in plots because when you hover over a point in a plot of 
the factors, the pattern value shows the factor coding of the point.

The Y column 
is for recording 
experimental 
results.

This script fits a 
model using the 
values in the 
design table.





Chapter 6
Full Factorial Designs

A full factorial design contains all possible combinations of a set of factors. This is the most fool proof 
design approach, but it is also the most costly in experimental resources. The full factorial designer sup-
ports both continuous factors and categorical factors with up to nine levels.

In full factorial designs, you perform an experimental run at every combination of the factor levels. The 
sample size is the product of the numbers of levels of the factors. For example, a factorial experiment 
with a two-level factor, a three-level factor, and a four-level factor has 2 x 3 x 4 = 24 runs. 

Factorial designs with only two-level factors have a sample size that is a power of two (specifically 2f 
where f is the number of factors). When there are three factors, the factorial design points are at the ver-
tices of a cube as shown in the diagram below. For more factors, the design points are the vertices of a 
hypercube.

Full factorial designs are the most conservative of all design types. There is little scope for ambiguity 
when you are willing to try all combinations of the factor settings. 

Unfortunately, the sample size grows exponentially in the number of factors, so full factorial designs are 
too expensive to run for most practical purposes. 
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The Five-Factor Reactor Example
The following example, adapted from Meyer et al. (1996) and Box, Hunter, and Hunter (1978), shows 
a five-factor reactor example. 

Previously, the screening designer was used to investigate the effects of five factors on the percent reac-
tion of a chemical process (see “Screening Designs,” p. 89). The factors (Feed Rate, Catalyst, Stir 
Rate, Temperature, and Concentration) are all two-level continuous factors. The next example studies 
the same system using a full factorial design.

1 Select DOE > Full Factorial Design.

2 Click the red triangle icon on the Full Factorial Design title bar and select Load Responses.

3 In the sample data (installed with JMP), open Reactor Response.jmp found in the Design 
Experiment Sample Data folder.

4 Click the red triangle icon on the Full Factorial Design title bar and select Load Factors.

5 In the sample data (installed with JMP), open Reactor Factors.jmp found in the Design 
Experiment folder.

The completed dialog should look like the one shown in Figure 6.1. 

Figure 6.1 Full Factorial Example Response and Factors Panels

6 Click Continue to see the Output Options panel. In the Output Options panel, select Sort Left to 
Right from the Run Order menu, as shown to the right. This command defines the order of runs as 
they will be in the final JMP design table.
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7 Click Make Table. 

The design data table (Figure 6.2) contains a run for every combination of high and low values for the 
five variables, which covers all combinations of five factors with two levels each. Since there are five 
variables, there are 25=32 runs. Initially, the table has an empty Y column named Percent Reacted for 
entering response values when the experiment is complete. 

To see the completed experiment and continue this example, open Reactor 32 Runs.jmp found in the 
Design Experiment Sample Data folder.

Figure 6.2 Partial Listing of Reactor 32 Runs.jmp from the Sample Data Folder

Analyze the Reactor Data

Begin the analysis with a quick look at the response data before fitting the factorial model. 

1 Select Analyze > Distribution.

2 Highlight Percent Reacted and click Y, Columns. Then click OK.

3 Click the red triangle icon on the Percent Reacted title bar and select Normal Quantile Plot. The 
results are shown in Figure 6.3.

Figure 6.3 Distribution of Response Variable for Reactor Data

Note that this initial analysis 
shows some experimental runs 
with a very high percent reacted 
response.
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Start the formal analysis with a stepwise regression. The data table has a script stored with it that auto-
matically defines an analysis of the model with main effects and all two-factor interactions.

4 Click the red triangle icon next to the Fit Model script and select Run Script. The stepwise analysis 
begins with the Stepwise Regression Control panel shown in Figure 6.4.

5 The probability to enter a factor (Prob to Enter) in the model should be 0.05. 

6 The probability to remove a factor (Prob to Leave) should be 0.1.

Figure 6.4 Stepwise Control Panel

7 A useful way to use the Stepwise platform is to check all the main effects in the Current Estimates 
table. However, make sure that the menu beside Direction in the Stepwise Regression Control panel 
specifies Mixed (see Figure 6.4).

8 Check the boxes for the main effects of the factors as shown in Figure 6.5. 

9 Click Go.

Figure 6.5 Starting Model For Stepwise Process

The mixed stepwise procedure removes insignificant main effects and adds important interactions. The 
end result is shown in Figure 6.6. Note that the Feed Rate and Stir Rate factors are no longer in the 
model.
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Figure 6.6 Model After Mixed Stepwise Regression

10 Click the Make Model button in the Stepwise Regression Control panel. The Model Specification 
window that appears is automatically set up with the appropriate effects (Figure 6.7).

Figure 6.7 Fitting a Prediction Model

11 Click Run Model to see the analysis for a candidate prediction model (Figure 6.8). 

The figure on the left in Figure 6.8 shows the actual by predicted plot for the model. The predicted 
model covers a range of predictions from 40% to 95% reacted. The size of the random noise as mea-
sured by the RMSE is only 3.3311%, which is more than an order of magnitude smaller than the range 
of predictions. This is strong evidence that the model has good predictive capability.

The figure on the right in Figure 6.8 shows a table of model coefficients and their standard errors 
(labeled Parameter Estimates). All effects selected by the stepwise process are highly significant.
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Figure 6.8 Actual by Predicted Plot and Prediction Parameter Estimates Table

The factor Prediction Profiler also gives you a way to compare the factors and find optimal settings. 

1 To open the Prediction Profiler, click the red triangle on the Response Percent Reacted title bar and 
select Factor Profiling > Profiler, as shown in Figure 6.9. 

Figure 6.9 Selecting the Profiler

Figure 6.10 shows the profiler’s initial display. The Prediction Profiler is discussed in more detail in the 
chapter “Response Surface Designs,” p. 115, and in the chapter “Standard Least Squares: Exploring the 
Prediction Equation” of JMP Statistics and Graphics Guide. 

Figure 6.10 Viewing the Profiler

2 Click the red triangle on the Prediction Profiler title bar and select Maximize Desirability to see the 
profiler in Figure 6.11. 
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Figure 6.11 Viewing the Prediction Profiles at the Optimum Settings

The goal is to maximize Percent Reacted. The reaction is unfeasible economically unless the Percent 
Reacted is above 90%. Percent Reacted increases from 65.5 at the center of the factor ranges to 
95.875 ± 2.96 at the most desirable settings. The best settings of all three factors are at the ends of their 
ranges. Future experiments could investigate what happens as you continue moving further in this 
direction.

Creating a Factorial Design
To start a full factorial design, select DOE > Full Factorial Design, or click the Full Factorial Design 
button on the JMP Starter DOE page. Then, follow the steps below:

• “Enter Responses and Factors,” p. 136

• “Select Output Options,” p. 137

• “Make the Table,” p. 138

Enter Responses and Factors

The steps for entering responses are outlined in “Enter Responses and Factors into the Custom 
Designer,” p. 59

The steps for entering factors in a full factorial design are unique to this design. To add factors, see 
Figure 6.12.
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Figure 6.12 Entering Factors in a Full Factorial Design

When you finish adding factors, click Continue.

Select Output Options

Use the Output Options panel to specify how you want the output data table to appear, as illustrated in 
Figure 6.13:

Figure 6.13 Output Options Panel

Run Order gives options to designate the order you want the runs to appear in the data table when it is 
created. Choices are:

Keep the Same the rows (runs) in the output table will appear as they do in the Design panel. 

Sort Left to Right the rows (runs) in the output table will appear sorted from left to right. 

Randomize the rows (runs) in the output table will appear in a random order.

Sort Right to Left the rows (runs) in the output table will appear sorted from right to left.

Add additional points to the data table with these options:

Number of Center Points Specifies additional runs placed at the center of each continuous factor’s 
range.

Number of Replicates Specify the number of times to replicate the entire design, including cen-
terpoints. Type the number of times you want to replicate the design in the associated text box. 
One replicate doubles the number of runs.

To enter factors, click either the Continuous 
button or the Categorical button and select a 
factor type, level 2 - 9.

Double-click to edit 
the factor name.

Click to enter values or change the level names. To remove 
a level, click it, press the delete key on the keyboard, then 
press the Return or Enter key on the keyboard.
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Make the Table

When you click Make Table, the table shown in Figure 6.14 appears. 

Figure 6.14 Factorial Design Table

for continuous factors, a minus 
sign represents low levels

level numbers represent values 
of categorical factors

values in the Pattern column 
describe the run each row rep-
resents

The name of the table is the design type that generated it.

This script 
automates fit-
ting a model 
using values 
in the design 
table.

for continuous factors, a plus 
sign represents high levels



Chapter 7
Mixture Designs

The mixture designer supports experiments with factors that are ingredients in a mixture. You can 
choose among several classical mixture design approaches, such as simplex, extreme vertices, and lattice. 
For the extreme vertices approach you can supply a set of linear inequality constraints limiting the 
geometry of the mixture factor space.

The properties of a mixture are almost always a function of the relative proportions of the ingredients 
rather than their absolute amounts. In experiments with mixtures, a factor's value is its proportion in 
the mixture, which falls between zero and one. The sum of the proportions in any mixture recipe is one 
(100%).

Designs for mixture experiments are fundamentally different from those for screening. Screening exper-
iments are orthogonal. That is, over the course of an experiment, the setting of one factor varies inde-
pendently of any other factor. Thus, the interpretation of screening experiments is relatively simple, 
because the effects of the factors on the response are separable.

With mixtures, it is impossible to vary one factor independently of all the others. When you change the 
proportion of one ingredient, the proportion of one or more other ingredients must also change to 
compensate. This simple fact has a profound effect on every aspect of experimentation with mixtures: 
the factor space, the design properties, and the interpretation of the results.

Because the proportions sum to one, mixture designs have an interesting geometry. The feasible region 
for the response in a mixture design takes the form of a simplex. For example, consider three factors in 
a 3-D graph. The plane where the sum of the three factors sum to one is a triangle-shaped slice. You can 
rotate the plane to see the triangle face-on and see the points in the form of a ternary plot.

triangular feasible region

x1

x2

x3
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Mixture Design Types
To create a mixture design, choose DOE > Mixture Design, enter the responses and factors into the ini-
tial mixture designer panel, and click Continue. You then see the Choose Mixture Design Type panel 
shown in Figure 7.1. Select one of the designs from the panel:

Optimal invokes the custom designer with all the mixture variables already defined. 

Simplex Centroid lets you specify the degree to which the factor combinations are made.

Simplex Lattice lets you specify how many levels you want on each edge of the grid.

Extreme Vertices lets you specify linear constraints or restrict the upper and lower bounds to be 
within the 0 to 1 range.

ABCD Design generates a screening design for mixtures devised by Snee (1975).

Figure 7.1 Mixture Design Selection Dialog

After you select the design type, choose the number of runs in the Design Generation panel and click 
Make Design.

The following sections describe each mixture design type and show examples.

The Optimal Mixture Design
The Optimal mixture design choice invokes the custom designer with the mixture variables entered 
into the response and factors panels. To create an optimal mixture design:

1 Select DOE > Mixture Design.

2 Enter factors and responses. The steps for entering responses are outlined in “Enter Responses and 
Factors into the Custom Designer,” p. 59. 

3 After you enter responses and factors, click Continue.

4 Click Optimal on the Choose Mixture Design Type panel. 

5 Add effects to the model using the instructions below.
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Adding Effects to the Model

Initially, the Model panel lists only the main effects corresponding to the factors you entered, as shown 
in Figure 7.2. 

Figure 7.2 The Model Panel

However, you can add factor interactions, specific crossed factor terms, powers, or Scheffe Cubic terms 
to the model.

• To add interaction terms to a model, click the Interactions button and select 2nd, 3rd, 4th, or 5th. 
For example, if you have factors X1 and X2, click Interactions > 2nd and X1*X2 is added to the list 
of model effects.

• To add crossed effects to a model, highlight the factors and effects you want to cross and click the 
Cross button.

• To add powers of continuous factors to the model, click the Powers button and select 2nd, 3rd, 
4th, or 5th.

• When you want a mixture model with third-degree polynomial terms, the Scheffe Cubic button 
provides a polynomial specification of the surface by adding terms of the form X1*X2*(X1-X2).

The Simplex Centroid Design
A simplex centroid design of degree k with n factors is composed of mixture runs with 

• all one factor 

• all combinations of two factors at equal levels

• all combinations of three factors at equal levels 

• and so on up to k factors at a time combined at k equal levels. 

A center point run with equal amounts of all the ingredients is always included.

Creating the Design

To create a simplex centroid design:

1 Select DOE > Mixture Design.

2 Enter factors and responses. The steps for entering responses are outlined in “Enter Responses and 
Factors into the Custom Designer,” p. 59.

3 After you enter responses and factors, click Continue.

4 Enter the number of ingredients in the box labeled K. JMP will create runs for each ingredient with-
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out mixing, then create runs that mix equal proportions of K ingredients at a time to the specified 
limit.

5 Click the Simplex Centroid button.

6 View factor settings and Output Options, as illustrated in Figure 7.3.

Figure 7.3 Example of Factor Settings and Output Options

7 Specify Run Order, which is the order you want the runs to appear in the data table when it is cre-
ated. Run order choices are:

Keep the Same the rows (runs) in the output table will appear as they do in the Design panel. 

Sort Left to Right the rows (runs) in the output table will appear sorted from left to right. 

Randomize the rows (runs) in the output table will appear in a random order.

Sort Right to Left the rows (runs) in the output table will appear sorted from right to left. 

Randomize within Blocks the rows (runs) in the output table will appear in random order 
within the blocks you set up. 

8 Specify Number of Replicates. The number of replicates is the number of times to replicate the 
entire design, including centerpoints. Type the number of times you want to replicate the design in 
the associated text box. One replicate doubles the number of runs.

9 Click Make Table.

Simplex Centroid Design Examples

The table of runs for a design of degree 1 with three factors (left in Figure 7.4) shows runs for each sin-
gle ingredient followed by the center point. The table of runs to the right is for three factors of degree 2. 
The first three runs are for each single ingredient, the second set shows each combination of two ingre-
dients in equal parts, and the last run is the center point.
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Figure 7.4 Three-Factor Simplex Centroid Designs of Degrees 1 and 2 

To generate the two sets of runs in Figure 7.4:

1 Choose DOE > Mixture Design.

2 Enter three mixture factors. 

3 Click Continue. 

4 Enter 1 in the K box, and click Simplex Centroid to see the design on the left in Figure 7.5. 

5 Click the Back button, then click Continue, and enter 2 in the K box. Then click Simplex 
Centroid to see the design on the right in Figure 7.5. 

Figure 7.5 Create Simplex Centroid Designs of Degrees 1 and 2 

As another example:

1 Choose DOE > Mixture Design.

2 Enter five factors and click Continue. 

3 Use the default value, 4, in the K box. 

4 Click Simplex Centroid. 

5 Click Make Table to see the 31-run JMP data table shown in Figure 7.6.
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Figure 7.6 Partial Listing of Factor Settings for Five-Factor Simplex Centroid Design

The Simplex Lattice Design
The simplex lattice design is a space filling design that creates a triangular grid of runs. The design is 
the set of all combinations where the factors’ values are i / m, where i is an integer from 0 to m such that 
the sum of the factors is 1.

To create simplex lattice designs:

1 Select DOE > Mixture Design.

2 Enter factors and responses. The steps for entering responses are outlined in “Enter Responses and 
Factors into the Custom Designer,” p. 59.

3 Click Continue.

4 Specify the number of levels you want in the Mixture Design Type dialog (Figure 7.1) and click 
Simplex Lattice. 

Figure 7.7 shows the runs for three-factor simplex lattice designs of degrees 3, 4, and 5, with their cor-
responding geometric representations. In contrast to the simplex centroid design, the simplex lattice 
design does not necessarily include the centroid.
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Figure 7.7 Three-Factor Simplex Lattice Designs for Factor Levels 3, 4, and 5

Figure 7.8 lists the runs for a simplex lattice of degree 3 for five effects. In the five-level example, the 
runs creep across the hyper-triangular region and fill the space in a grid-like manner.

Figure 7.8 JMP Design Table for Simplex Lattice with Five Variables, Order (Degree) 3
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The Extreme Vertices Design
The extreme vertices design accounts for factor limits and selects vertices and their averages (formed by 
factor limits) as design points. Additional limits are usually in the form of range constraints, upper 
bounds, and lower bounds on the factor values.

The extreme vertices design finds the corners (vertices) of a factor space constrained by limits specified 
for one or more of the factors. The property that the factors must be non-negative and must add up to 
one is the basic mixture constraint that makes a triangular-shaped region. 

Sometimes other ingredients need range constraints that confine their values to be greater than a lower 
bound or less than an upper bound. Range constraints chop off parts of the triangular-shaped (simplex) 
region to make additional vertices. It is also possible to have a linear constraint, which defines a linear 
combination of factors to be greater or smaller than some constant. 

The geometric shape of a region bound by linear constraints is called a simplex, and because the vertices 
represent extreme conditions of the operating environment, they are often the best places to use as 
design points in an experiment.

You usually want to add points between the vertices. The average of points that share a constraint 
boundary is called a centroid point, and centroid points of various degrees can be added. The centroid 
point for two neighboring vertices joined by a line is a second degree centroid because a line is two 
dimensional. The centroid point for vertices sharing a plane is a third degree centroid because a plane is 
three dimensional, and so on.

If you specify an extreme vertices design but give no constraints, a simplex centroid design results.

Creating the Design

Follow these steps to create an extreme vertices design. The next sections show examples with specific 
constraints.

1 Select DOE > Mixture Design.

2 Enter factors and responses. These steps are outlined in “Enter Responses and Factors into the Cus-
tom Designer,” p. 59. Remember to enter the upper and lower limits in the factors panel (see 
Figure 7.9).

3 Click Continue.

4 In the Degree text box, enter the degree of the centroid point you want to add. The centroid point 
is the average of points that share a constraint boundary.

5 If you have linear constraints, click the Linear Constraints button for each constraint you want to 
add. Use the text boxes that appear to define a linear combination of factors to be greater or smaller 
than some constant. 

6 Click Extreme Vertices to see the factor settings.
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7 (Optional) Change the order of the runs in the data table when it is created. Run order choices are:

Keep the Same—the rows (runs) in the output table will appear as they do in the Design panel. 

Sort Left to Right—the rows (runs) in the output table will appear sorted from left to right. 

Randomize—the rows (runs) in the output table will appear in a random order.

Sort Right to Left—the rows (runs) in the output table will appear sorted from right to left. 

Randomize within Blocks—the rows (runs) in the output table will appear in random order 
within the blocks you set up. 

8 (Optional) Type the sample size you want in the Choose desired sample size text box. 

9 (Optional) Click Find Subset to generate the optimal subset having the number of runs specified in 
sample size box described in Step 8. The Find Subset option uses the row exchange method (not 
coordinate exchange) to find the optimal subset of rows.

10 Click Make Table.

An Extreme Vertices Example with Range Constraints

The following example design table is for five factors with the range constraints shown in Figure 7.9, 
where the ranges are smaller than the default 0 to 1 range. 

1 Select DOE > Mixture Design.

2 Add two additional factors (for a total of 5 factors) and give them the values shown in Figure 7.9.

3 Click Continue.

4 Enter ‘4’ in the Degree text box (Figure 7.9).

Figure 7.9 Example of Five-factor Extreme Vertices

5 Click Exreme Vertices. 

6 Select Sort Left to Right from the Run Order menu.
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7 Click Make Table. Figure 7.10 shows a partial listing of the resulting table. Note that the Rows 
panel in the data table shows that the table has the default 116 runs.

Figure 7.10 JMP Design Table for Extreme Vertices with Range Constraints

Suppose you want fewer runs. You can go back and enter a different sample size (number of runs).

8 Click Back, then click Continue. 

9 Enter ‘4’ in the Degree text box and click Exreme Vertices. 

10 In the sample size text box, enter ‘10’ as the sample size. 

11 Click Find Subset to generate the optimal subset having the number of runs specified. The result-
ing design (Figure 7.11) is the optimal 10-run subset of the 116 current runs. This is useful when 
the extreme vertices design generates a large number of vertices. 

Figure 7.11 JMP Design Table for 10-Run Subset of the 116 Current Runs

Note: The Find Subset option uses the row exchange method (not coordinate exchange) to find the 
optimal subset of rows.
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An Extreme Vertices Example with Linear Constraints

Consider the classic example presented by Snee (1979) and Peipel (1988). This example has three fac-
tors, X1, X2, and X3, with five individual factor bound constraints and three additional linear con-
straints: 

To enter these constraints:

1 Enter the upper and lower limits in the factors panel. 

2 Click Continue.

3 Click the Linear Constraint button three times. Enter the constraints as shown in Figure 7.12.

4 Click the Extreme Vertices button.

5 Change the run order to Sort Right to Left, and keep the sample size at 13 to see the 13-run factor 
settings like those shown on the right in Figure 7.12.

6 Click Make Table.

Figure 7.12 Constraints

This example is best understood by viewing the design as a ternary plot, as shown at the end of this 
chapter, in Figure 7.14. The ternary plot shows how close to one a given component is by how close it 
is to the vertex of that variable in the triangle. See “Creating Ternary Plots,” p. 152, for details.

Table 7.1 Linear Constraints for the Snee and Peipel Example
X1 ≥ 0.1
X1 ≤ 0.5
X2 ≥ 0.1
X2 ≤ 0.7
X3 ≤ 0.7

90 ≤ 85*X1 + 90*X2 + 100*X3
     85*X1 + 90*X2 + 100*X3 ≤ 95
.4 ≤ 0.7*X1 + X3
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Extreme Vertices Method: How It Works

If there are linear constraints, JMP uses the CONSIM algorithm developed by R.E. Wheeler, described 
in Snee (1979) and presented by Peipel (1988) as CONVRT. The method is also described in Cornell 
(1990, Appendix 10a). The method combines constraints and checks to see if vertices violate them. If 
so, it drops the vertices and calculates new ones. The method named CONAEV for doing centroid 
points is by Peipel (1988).

If there are no linear constraints (only range constraints), the extreme vertices design is constructed 
using the XVERT method developed by Snee and Marquardt (1974) and Snee (1975). After the verti-
ces are found, a simplex centroid method generates combinations of vertices up to a specified order.

The XVERT method first creates a full 2nf – 1 design using the given low and high values of the   nf – 1 
factors with smallest range. Then, it computes the value of the one factor left out based on the restric-
tion that the factors’ values must sum to one. It keeps the point if it is in that factor’s range. If not, it 
increments or decrements it to bring it within range, and decrements or increments each of the other 
factors in turn by the same amount, keeping the points that still satisfy the initial restrictions.

The above algorithm creates the vertices of the feasible region in the simplex defined by the factor con-
straints. However, Snee (1975) has shown that it can also be useful to have the centroids of the edges 
and faces of the feasible region. A generalized n-dimensional face of the feasible region is defined by 
nf – n of the boundaries and the centroid of a face defined to be the average of the vertices lying on it. 
The algorithm generates all possible combinations of the boundary conditions and then averages over 
the vertices generated on the first step.

The ABCD Design
This approach by Snee (1975) generates a screening design for mixtures. To create an ABCD design:

1 Select DOE > Mixture Design.

2 Enter factors and responses. The steps for entering responses are outlined in “Enter Responses and 
Factors into the Custom Designer,” p. 59.

3 After you enter responses and factors, click Continue.

4 Click the ABCD button. 

5 View factor settings and Output Options.

6 Specify Run Order, which is the order you want the runs to appear in the data table when it is cre-
ated. Run order choices are:

Keep the Same—the rows (runs) in the output table will appear as they do in the Design panel. 

Sort Left to Right—the rows (runs) in the output table will appear sorted from left to right. 

Randomize—the rows (runs) in the output table will appear in a random order.

Sort Right to Left—the rows (runs) in the output table will appear sorted from right to left. 

Randomize within Blocks—the rows (runs) in the output table will appear in random order 
within the blocks you set up. 

7 Specify Number of Replicates. The number of replicates is the number of times to replicate the 
entire design, including centerpoints. Type the number of times you want to replicate the design in 
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the associated text box. One replicate doubles the number of runs.

8 Click Make Table.

Creating Ternary Plots
A mixture problem in three components can be represented in two dimensions because the third com-
ponent is a linear function of the others. The ternary plot in Figure 7.14 shows how close to one (1) a 
given component is by how close it is to the vertex of that variable in the triangle. The plot to the left in 
Figure 7.13 illustrates a ternary plot. 

Figure 7.13 Ternary Plot (left) and Tetrary Plot (right) for Mixture Design

The Peipel (1979) example referenced in “An Extreme Vertices Example with Linear Constraints,” 
p. 150 is best understood by the ternary plot shown in Figure 7.14. 

To view a mixture design as a ternary plot:

1 Create the Peipel mixture data as shown previously, or open the table called Peipel.jmp, found in the 
Design Experiments folder of the Sample Data Library.

2 Choose Graph > Ternary Plot.

3 In the ternary plot launch dialog, specify the three mixture components and click OK.

The JMP Ternary plot platform recognizes the three factors as mixture factors, and also considers the 
upper and lower constraints entered into the Factors panel when the design was created. The Ternary 
plot uses shading to exclude the unfeasible areas excluded by those constraints.

The Peipel data had additional constraints, entered as linear constraints for the extreme vertices design. 
Each constraint is a line, drawn by the line graphics tool on the ternary plot. There are six active con-
straints, six vertices, and six centroid points shown on the plot, as well as two inactive (redundant) con-
straints. The feasible area is the inner white polygon delimited by the design points and constraint lines.

X1

X2
X3

(1/2, 1/2, 0)

X1 (1, 0, 0)

X2 (0, 1, 0) X3 (0, 0, 1)

(1/3, 1/3, 1/3)

(0.1, 0.1, 0.8)
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Figure 7.14 Diagram of Ternary Plot Showing Peipel Example Constraints

Fitting Mixture Designs
When fitting a model for mixture designs, you must take into account that all the factors add up to a 
constant, and thus a traditional full linear model will not be fully estimable. 

The recommended response surface model, called the Scheffé polynomial (Scheffé 1958), does the fol-
lowing:

• suppresses the intercept

• includes all the linear main-effect terms

• excludes all the square terms (such as X1*X1)

• includes all the cross terms (such as X1*X2)

To fit a model:

1 Choose DOE > Mixture Design and make the design data table. Remember that to fit a model, the 
Y column in the data table must contain values, so either assign responses or click the red triangle 
menu and select Simulate Responses before you click Make Table.

2 The design data table stores the model in the data table as a table property. This table property is a 
JSL script called Model, located in the left panel of the table.

3 Right-click the model and select Run Script to launch the Fit Model dialog, which is automatically 
filled with the saved model.

4 Click Run Model on the Fit Model dialog.
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In this model, the parameters are easy to interpret (Cornell 1990). The coefficients on the linear terms 
are the fitted response at the extreme points where the mixture consists of a single factor. The coeffi-
cients on the cross terms indicate the curvature across each edge of the factor space. Your values may be 
different from those shown below.

Figure 7.15  Fitting a Mixture Design

The model report usually has several sections of interest, including the whole model tests, Analysis of 
Variance reports, and response surface reports, which are described below.

Whole Model Tests and Analysis of Variance Reports

In a whole-model Analysis of Variance table, JMP traditionally tests that all the parameters are zero 
except for the intercept. In a mixture model without an intercept, JMP looks for a hidden intercept, in 
the sense that a linear combination of effects is a constant. If it finds a hidden intercept, it does the 
whole model test with respect to the intercept model rather than a zero-intercept model. This test is 
equivalent to testing that all the parameters are zero except the linear parameters, and testing that they 
are equal.

The hidden-intercept property also causes the R2 to be reported with respect to the intercept model 
rather than reported as missing.
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Understanding Response Surface Reports

When there are effects marked as response surface effects “&RS,” JMP creates additional reports that 
analyze the fitted response surface. These reports were originally designed for full response surfaces, not 
mixture models. However, if JMP encounters a no-intercept model and finds a hidden intercept with 
linear response surface terms, but no square terms, then it folds its calculations, collapsing on the last 
response surface term to calculate critical values for the optimum. This can be done for any combina-
tion that yields a constant and involves the last response surface term.

The contour plot feature of these reports does not fold to handle mixtures. If you want a contour plot 
of the surface, you can do any of the following:

• Save the model prediction formula and then create a ternary plot with Graph > Ternary Plot.

• Refit the model using a full response surface that omits the last factor. 

• Create a separate contour plot with Graph > Contour Plot, and add points to make the plot less 
granular.

A Chemical Mixture Example
Three plasticizers (p1, p2, and p3) comprise 79.5% of the vinyl used for automobile seat covers (Cor-
nell, 1990). Within this 79.5%, the individual plasticizers are restricted by the following constraints: 
0.409 ≤ x1 ≤ 0.849, 0 ≤ x2 ≤ 0.252, and 0.151 ≤ x3 ≤ 0.274. 

Create the Design

To create Cornell’s mixture design in JMP:

1 Select DOE > Mixture Design.

2 In the Factors panel, use the three default factors but name them p1, p2, and p3, and enter the high 
and low constraints as shown in Figure 7.16. Or, load the factors with the Load Factors command 
in the red triangle on the Mixture Design title bar. To import the factors, open Plastifactors.jmp, 
found in the Design Experiment Sample Data folder that was installed with JMP.

Figure 7.16 Factors and Factor Constraints for the Plasticizer Experiment

3 Click Continue.

4 Enter 3 in the Degree text box.

5 Click Exreme Vertices.
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6 Click Make Table. JMP uses the 9 factor settings to generate a JMP table (Figure 7.17). 

Figure 7.17 Extreme Vertices Mixture Design

7 Add an extra five design runs by duplicating the vertex points and center point, to give a total of 14 
rows in the table. 

Note: To identify the vertex points and the center (or interior) point, use the sample data script called 
LabelMixturePoints.jsl in the Sample Scripts folder installed with JMP.

8 Run the LabelMixturePoints.jsl to see the results inFigure 7.18, and highlight the vertex points and 
the interior point as shown.

Figure 7.18 Identify Vertices and Center Point with Sample Data Script

9 Select Edit > Copy, to copy the selected rows to the clipboard.

10 Select Rows > Add Rows and enter 5 as the number of rows to add

11 Click the At End radio button on the dialog, then click OK. 

12 Highlight the new rows and select Edit > Paste to add the duplicate rows to the table.

The Plasticizer data with the results (Y values) that Cornell obtained are available in the Sample data. 
Open Plasticizer.jmp in the Sample Data folder installed with JMP to see this table (Figure 7.19). 
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Figure 7.19 Plasticizer.jmp Data Table from the Sample Data Library

Analyze the Mixture Model

Use the Cornell plasticizer data from the Sample Data library (Figure 7.19) to run the mixture model:

1 Right-click the table property named Model on the upper-left of the data table and select Run 
Script, which runs a script that displays a completed Fit Model dialog. Click Run Model to see the 
response surface analysis.

2 Plasticizer.jmp contains a column called Pred Formula Y. This column was added after the analysis 
by selecting Save Columns > Prediction Formula from the red triangle menu in the Response Y 
title bar of the analysis report. To see the prediction formula, right-click (Ctrl+click on the Mac) the 
column name and select Formula: 
0–50.1465*p1 – 282.1982*p2 – 911.6484*p3 + p2*p1*317.363 + 

p3*p1*1464.3298 + p3*p2*1846.2177

Your values may be different from those shown here.

Note: These results correct the coefficients reported in Cornell (1990).

The Response Surface Solution report (Figure 7.20) shows that a maximum predicted value of 
19.570299 occurs at point (0.63505, 0.15568, 0.20927).
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Figure 7.20 Mixture Response Surface Analysis

The Prediction Profiler

The report contains a prediction profiler. 

3 If the profiler is not visible, click the red triangle in the Response Y title bar and select Factor 
Profiling > Profiler. You should see the initial profiler shown in Figure 7.21.

The crossed effects show as curvature in the prediction traces. Drag one of the vertical reference lines, 
and the other two move in the opposite direction maintaining their ratio.

Note: The axes of prediction profiler traces range from the 
upper and lower bounds of the factors, p1, p2, and p3, 
entered to create the design and the design table. When you 
experiment moving a variable trace, you see the other traces 
move such that their ratio is preserved. As a result, when the 
limit of a variable is reached, it cannot move further and only 
the third variable changes. 

4 To limit the visible profile curves to bounds that use all three variables, use the Stop at Boundaries 
command from the menu on the Prediction Profiler title bar. 

5 If needed, select the Desirability Functions command to display the desirability function showing 
to the right of the prediction profile plots in Figure 7.22.

6 Then select Maximize Desirabilty from the Prediction Profiler menu to see the best factor settings.
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The profiler in Figure 7.22, displays optimal settings (rounded) of 0.6350 for p1, 0.1557 for p2, and 
0.2093 for p3, which give an estimated response of 19.5703. 

Figure 7.21 Initial Prediction Profiler

Figure 7.22 Maximum Desirability in Profiler for Mixture Analysis Example
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The Mixture Profiler

The Fit Model report also has a Mixture Profiler that is use-
ful for visualizing and optimizing response surfaces from 
mixture experiments. 

Many of the features are the same as those of the Contour 
Profiler however some are unique to the Mixture Profiler:

• A ternary plot is used instead of a Cartesian plot, which 
enables you to view three mixture factors at a time.

• If you have more than three factors, radio buttons let you 
choose which factors to plot. 

• If the factors have constraints, you can enter their low and high limits in the Lo Limit and Hi Limit 
columns. This shades non-feasible regions in the profiler. 

7 Select Factor Profiling > Mixture Profiler from the menu on the Response Y title bar to see the mix-
ture profiler for the plasticizer data, shown in Figure 7.23. 

Figure 7.23 Mixture Profiler for Plasticizer Example

A Ternary Plot of the Mixture Response Surface

You can also plot the response surface of the plasticizer data as a ternary plot using the Ternary graph 
platform and contour the plot with information from an additional variable:
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1 Choose Graph > Ternary Plot.

2 Specify plot variables (p1, p2, and p3) and click X, Plottting, as shown in Figure 7.24. To identify 
the contour variable (the prediction equation), select Pred Formula Y and click the Contour 
Formula button. The contour variable must have a prediction formula to form the contour lines, as 
shown by the ternary plots at the bottom in Figure 7.25. If there is no prediction formula, the ter-
nary plot only shows points. 

Figure 7.24 Launch Dialog for the Ternary Plot Platform

3 Click OK and view the results, as shown in Figure 7.25. By default, the ternary plot displays contour 
lines only, but you can request a fill, as shown, with the Contour Fill command found in the red tri-
angle menu on the Ternary Plot title bar.

Figure 7.25 Ternary Plot of a Mixture Response Surface





Chapter 8
Discrete Choice Designs

The Discrete Choice designer creates experiments with factors that are product attributes. A collection 
of attributes is called a product profile. Respondents choose one in each set of product profiles. 

Industrial experimentation deals with the question of how to improve processes to deliver better prod-
ucts. Choice experiments help a company prioritize product features for their market. The purpose of a 
choice experiment is to define a product that people want to buy.

Choice experiments always involve people comparing prospective products and picking the one they 
prefer. For example, suppose a computer company wants to update its high-end laptop. Laptops have 
many features that are important to customers such as processor speed, hard disk size, screen size, bat-
tery life, and price. To build a laptop that customers want, the computer company needs to know the 
relative importance of each feature. Most people prefer a faster computer with more storage, longer bat-
tery life, and a low price. What the company does not know is how much more an extra hour of battery 
life is worth to a customer or whether doubling the hard disk size is as important as doubling the pro-
cessor speed. A choice experiment can answer these questions and indicate the optimal set of trade-offs 
among product features.
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Introduction
Most choice experiments involve conducting a market research survey. The survey consists of a series of 
questions about attributes of interest about a potential new product or product modification. For 
example, a computer manufacturer might be interested in manufacturing a new laptop and wants 
information about customer preference before beginning an expensive development process. Computer 
characteristics change so rapidly that it is crucial to quickly identify the attributes that help the manu-
facturers to design and build a new machine most likely to capture enough market share to be profit-
able. 

Often, the attributes are obvious. For example, the consumer wants a laptop that has a large screen, 
weighs almost nothing, costs almost nothing, and lasts forever on a single battery charge. The question, 
then, is how much is the customer willing to compromise these desires? How important is each of these 
attributes, and which kinds of trade off is the customer most likely to accept and still purchase a new 
machine?

Assume a simple situation where a computer manufacturer wants to examine preferences for four possi-
ble laptop configurations. Notice that there are no ‘right’ or ‘wrong’ selections. Instead there are just 
preferences. A well designed questionnaire and proper analysis of results can tell a manufacturer how to 
proceed. The manufacturer wants information about the following four laptop attributes. 

• size of hard drive disk (40 GB or 80 GB)

• speed of processor (1.5 GHz or 2.0 GHz)

• battery life (4 Hrs or 6 Hrs)

• cost of computer ($1000, $1200 or $1500)

If a survey were constructed that offered the possibility of choosing any combination of these attributes, 
a respondent would be forced to evaluate 24 possible combinations and make a single response. Instead 
each respondent usually evaluates several choice sets and for each choice set, chooses the preferred pro-
file. In the simplest situation, each respondent chooses between sets of two profiles.

Then, you analyze the choices of multiple respondents. A well designed choice experiment, correctly 
analyzed is a efficient way to give the researcher the most information for the least time and expense.

Table 1 shows hypothetical results from a single survey designed to collect information about consumer 
preferences about laptop computers. 

• Each column in the survey identifies a laptop attribute.

• Each line in the survey defines a laptop profile, which is a collection of attribute values.

• Each choice set consists of two attribute profiles.

• All of the attribute values are allowed to change across the two profiles in a choice set.
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The DOE Choice designer can create a survey like that shown in Table 8.1. However, to create an 
effective design, the Choice designer needs information about the attributes. For example, most laptop 
attributes have values that are intrinsic preferences. That is, a bigger disk size is better, longer battery 
life is better, and so forth. The purpose of conducting a choice survey is to find out how the potential 
laptop purchasers feels about the advantages of a collection of tractates. 

One way to gain prior information about attributes in a survey is to conduct a single example survey, 
analyze the results, and use those results as prior information to create the final survey instrument.

This chapter shows how to create a sample survey and use its results as prior information for a final sur-
vey design

Create an Example Choice Experiment
The Choice design can create a survey like the one in Table 1. As an example, 

1 Choose Doe > Choice Design, and complete the initial dialog as shown in Figure 8.1. 

Table 8.1 Hypothetical Choice Survey Results from a single Respondent, Subject ID 2

For each pair, please check the combination of attributes you find most appealing.
Disk Size Speed Battery Life Price Preference

1 1 40 GB 1.5 GHz 6 hours $1,000 _X_

2 80 GB 1.5 GHz 4 hours $1,200 ___

2 1 40 GB 1.5 GHz 4 hours $1,500 ___

2 80 GB 2.0 GHz 4 hours $1,200 _X_

3 1 40 GB 2.0 GHz 4 hours $1,200 _X_

2 80 GB 2.0 GHz 6 hours $1,500 ___

4 1 40 GB 2.0 GHz 4 hours $1,000 _X_

2 80 GB 1.5 GHz 6 hours $1,200 ___

5 1 40 GB 1.5 GHz 6 hours $1,000 _X_

2 40 GB 2.0 GHz 4 hours $1,500 ___

6 1 40 GB 2.0 GHz 6 hours $1,200 _X_

2 80 GB 1.5 GHz 4 hours $1,500 ___

7 1 40 GB 2.0 GHz 6 hours $1,500 ___

2 80 GB 1.5 GHz 4 hours $1,000 _X_

8 1 40 GB 1.5 GHz 4 hours $1,200 ___

2 80 GB 2.0 GHz 4 hours $1,000 _X_
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Figure 8.1 Choice Design Dialog with Attributes Defined

2 Click Continue. For this example, use the default values in the Model Control panel and in the 
Design Generation panel, as shown in Figure 8.2.

Optionally, you can use the DOE Model Controls panel to add interactions to the choice model in sit-
uations where you expect there are interactions and want to generate profile sets that will help detect 
them.

Figure 8.2 Design Generation Panel for the Laptop Experiment

The values in the Design Generation panel describe the laptop survey.

Number of attributes that can change within a choice set There are four laptop attributes. 
Entering 4 as the number of attributes that can change within a choice set means that the Choice 
designer can change 4 or fewer attribute values within a single choice set. You can enter fewer 
than the total number of attributes to constrain the total number that can be changed within a 
choice set. This might be a reasonable thing to do if you had a large number of attributes and you 
want to make it easier for the respondents to make a choice. For example, a survey might be 



168 Discrete Choice Designs Chapter 8
Create an Example Choice Experiment

interested in 20 or more attributes of a cell phone, but show and change only 5 or fewer 
attributes in a choice set. 

Number of profiles per choice set This example has two profiles per choice set. You can design 
choice experiments with more than two profiles in a choice set.

Number of choice sets per survey There are eight choice sets in the example survey but often 
there are many more.

Number of surveys The example only shows a single survey. Normally you expect multiple 
respondents and would request more than one survey.

Expected number of respondents per survey You might want to give surveys to 10 people, but 
use two different surveys. So you enter 2 as the Number of surveys and 5 as the Expected 
number of respondents per survey.

Note: Recall that this first example is used to generate prior information, then used to create a more 
realistic survey. This example is a single survey given to a single respondent.

3 Click Make Design to see the example survey results in Figure 8.3.

Figure 8.3 Survey Results based on a Simple Model and Default Prior Information

The Radio buttons beneath the design settings let you choose between having the survey settings in one 
JMP table and gathering survey results in a second table, or generating a single table that shows the set-
tings and has an additional column for the choice response.

You can see that there are eight choice sets, each consisting of two laptop profiles. At this point you can 
press Back and modify the design, or click Make Table and generate the JMP table shown in 
Figure 8.4. 

This default design was created with no given prior information. Without prior information, the 
Choice designer has no way of knowing which attribute levels are better. That is, the Choice designer 
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cannot know that a lower price might be more desirable than a higher price, a faster machine is better 
than a slower machine, and so forth. As a result, you can see that some choice sets might not convey 
useful information. The analysis results are used as prior information in a new Choice design dialog.

Figure 8.4 JMP Data Table for Preliminary Laptop Choice Survey

Analyze the Example Choice Experiment
Once a survey deign is complete, a respondent chooses one profile from each set, entering ‘1’ for the 
chosen profile and ‘0’ for the rejected profile. Suppose a respondent completed the example survey as 
shown in Figure 8.5. You can now analyze these results using the Choice platform in the Analyze menu 
(Analyze > Modeling > Choice). 

Note: When you create a survey data table, the default name of the table is Choice Profiles. A Choice 
analysis is saved with the table as a script that references the default data table name. This example table 
is saved as Laptop Design.jmp in the Design of Experiment folder of the Sample data. Note in 
Figure 8.5 that the script was modified to reference the table named Laptop Design.
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Figure 8.5 JMP Table with Survey Choice Sets and Responses

4 Click the Choice script in the Laptop Design data table and select Run to analyze that data with the 
Choice modelling platform from the Analyze menu.

When you run the Choice model script, the Choice launch dialog shown in Figure 8.6 appears, The 
Choice dialog is designed to cover a variety of choice survey results, which can include data saved in 
multiple data tables. This example has all data contained in a single table. For details about using the 
Choice analysis dialog, see Chapter 30, “Choice Modeling,” in the JMP Statistics and Graphics User 
Guide. 

Figure 8.6 Choice Model Fitting Dialog

Use the Choice 
script to analyze 
the data.
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5 Click Run Model on the Choice model fitting dialog.

6 An additional dialog then appears asking if this is a one-table analysis with all the data in the Profile 
Table, which is the case in this sample survey. Click Yes in this dialog to continue.

The analysis shows as in Figure 8.7.

To design the final choice survey using prior information, you will need to enter estimates of the mean 
and variance of the attribute parameter estimates. The analysis on the left in Figure 8.7 has estimates of 
the attribute means, called Estimate, and estimates of the standard deviation of the attributes, called 
Std Error. An easy way to see the variance of the attributes is to capture the analysis in a JMP table and 
compute the variance:

7 Right click on the Parameter Estimates report and choose Make into Data Table from the menu, as 
shown. 

8 In the new Untitled data table, create a new column and call it Var.

9 Select Formula from the Cols menu (Cols > Formula), or right-click at the top of the Var column 
and select Formula for the menu that shows.

10 In the Formula Editor, click the Std Error column in the column list and click the exponent button 
( ) on the formula editor panel to compute the variance shown on the right in Figure 8.7.

Figure 8.7 Analysis of the sample Laptop Survey

This preliminary survey with its analysis gives you the information needed to design a final survey 
appropriate for gathering information from multiple respondents. Keep in mind that in a real situation, 
you might have prior information about factor attributes and not need to do a sample design.

Note: Leave the Untitled data table with the mean and variance information open to be used in the 
next example.

Design a Choice Experiment Using Prior Information
In some situations, you will know from previous surveys or experience how to give prior information to 
the Choice designer about product attributes. This example continues by designing the laptop experi-
ment again, using the analysis information gained from the sample design. 

1 Choose DOE > Choice Design and enter the attributes and values as before.
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2 Click Continue to see the Choice design panels in Figure 8.8.

3 Now enter the values from the JMP table created by the previous analysis into the Prior Mean and 
Prior Variance Matrix panels of the Choice Design dialog, as shown in Figure 8.8. You can 
copy-and-paste to transfer the values from the data table to the Choice dialog panels.

Figure 8.8 Enter Prior Mean and Variance Information from Preliminary Survey

4 Enter the values into the Design Generation panel, as shown in Figure 8.9. 

• Four or fewer attribute levels can change within a choice set.

• There are two profiles per choice set.

• Each survey has eight choice sets.

• The design generates two separate surveys.

• Five respondents are expected to complete each survey (for a total of 10 respondents).

Enter mean 
estimates

copy and paste to 
enter information

Enter variance 
estimates
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Figure 8.9 Design Specifications for final Laptop Survey

5 Click Make Design to see a design similar to the one shown in Figure 8.10.

Figure 8.10 Design Runs for Two Choice Surveys

6 Click Make Table. The final data table will have runs for ten survey respondents, giving a total of 
160 observations (2 profiles * 8 choice sets * 2 surveys * 5 respondents = 160 observations).

Administer the Survey and Analyze Results
The survey data table with is results is stored in the Sample Data Design Experiment folder installed 
with JMP. Figure 8.11 is a partial listing of the survey data table with results. The Choice script created 
by the Choice designer and saved with the survey data table can be used to analyze the data. As shown 
previously, the default script accesses the default data table created by the Choice designer named 
Choice Profiles. If necessary, change the data table name in the script to the name you used for the 
final design table. Note in Figure 8.11, the data table name is changed to Laptop Results.

1 To continue with this example, open the table called Laptop Results, saved in the Design Experi-
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ment folder of the Sample Data.

Figure 8.11 Partial Listing of Final Survey with Results

Initial Choice Platform Analysis

2 To analyze the data, click the Choice script saved with the data and select Run Script from the 
menu to see the completed dialog shown in Figure 8.12.

Note that this dialog has three grouping variables (Respondent, Survey, and Choice Set, whereas the 
dialog shown Figure 8.6 had only the Choice Set grouping variable because there was a single survey 
and a single respondent. This example included multiple surveys and respondents, which must be 
included in the analysis.

Figure 8.12 Choice Model Fitting Dialog to Analyze the Laptop Survey

3 Click Run Model on the Fit Model dialog. The query again appears asking if the analysis is a 
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one-table analysis with all the data in the profile table. Click Yes to see the initial analysis result 
shown in Figure 8.13.

The results are clear. The most significant attribute is Speed (Prob < .0001). Disk Size and Price are 
also significant, but Battery Life is not.

Figure 8.13 Initial Analysis of the Final Laptop Survey

Find Unit Cost and Trade Off Costs with the Profiler

You would like to know how changing the price, or other characteristics, of a laptop affects the desir-
ability as perceived by potential buyers. This desirability is called the utility value of the laptop 
attributes. The profiler shows the utility value and how it changes as the laptop attributes change.

4 Select Profiler from the menu on the Choice Model title bar to see the Prediction Profiler in 
Figure 8.14. 

Figure 8.14 Default Prediction Profiler for Laptop Choice Analysis

When each attribute value is set to its lowest value, the Utility value is –0.3406. The first thing you 
want to know is the unit utility cost. 

5 To find the unit utility cost, move the trace for price to and note how the Utility value changes.
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Compare the Utility values in Figure 8.14 and Figure 8.15. The value of Utility changes from –0.3406 
to –2.3303 when cost is raised from $1,000 to $1,500. That is, raising the price of a laptop $500.00 
lowers the utility (or desirability) approximately 2 units. Thus, you can say that the unit utility cost is 
roughly $250.00.

Figure 8.15 Compare Change in Utility Over Price

With this unit utility cost estimate you can now vary the other attributes, note the change in utility, and 
find an approximate dollar value associated with that attribute change. For example, the most signifi-
cant attribute is speed (see Figure 8.13).

6 In the Prediction Profiler, set Price to its lowest value and change Speed to its higher value.

You can see in Figure 8.16 that the Utility value changes from the original value shown in Figure 8.14 
of –0.3406 to 0.9886, for a total change of 1.3292 units. If the unit utility cost is estimated to be 
$250.00, as shown above, then the increase in price for a 2.0 GHz laptop over a 1.5 GHz laptop can be 
computed to be 1.3292*$250.00 = $332.30. This is the dollar value the Choice survey provides the 
manufacturer as a basis for pricing different laptop products. You can make similar calculations for the 
other attributes.

Figure 8.16 Change Speed in Profiler and Note Utility Value

This simple Choice survey and its analysis shows how this kind if information can be used to help man-
ufacturers and retailers identify important product attributes and assign values to them. 
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The Choice designer allows more complex designs, such as designs with interactions and other terms. 
The Choice analysis platform can be used to analyze complex designs, and it can be used to incorporate 
data from multiple data sets that include demographic information about the respondents.





Chapter 9
Space-Filling Designs

Space-filling designs are useful in situations where run-to-run variability is of far less concern than the 
form of the model. Sensitivity studies of computer simulations is one such situation. For this case, and 
any mechanistic or deterministic modeling problem, any variability is small enough to be ignored.

For systems with no variability, randomization and blocking are irrelevant. Replication is undesirable 
because repeating the same run yields the same result. In space-filling designs, there are two objectives: 

• The first objective is to prevent replicate points by spreading the design points out to the maximum 
distance possible between any two points. 

• The second objective is to space the points uniformly.

The following methods are implemented for these types of designs:

• The Sphere-Packing method emphasizes spread of points.

• The Latin Hypercube method is a compromise between spread of points and uniform spacing.

• The Uniform method mimics the uniform probability distribution.

• The Minimum Potential method minimizes energy designs in a hypersphere.

• The Maximum Entropy method measures the amount of information contained in the distribution 
of a set of data.

• The Gaussian Process IMSE Optimal method creates a design that minimizes the integrated mean 
squared error of the gaussian process over the experimental region.



Contents
Introduction to Space-Filling Designs  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 181

Sphere-Packing Designs . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 181

Creating a Sphere-Packing Design . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 181

Visualizing the Sphere-Packing Design  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 183

Latin Hypercube Designs . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 184

Creating a Latin Hypercube Design. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 184

Visualizing the Latin Hypercube Design . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 185

Uniform Designs . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 186

Comparing Sphere-Packing, Latin Hypercube, and Uniform Methods. . . . . . . . . . . . . . . . . . . . . . . 187

Minimum Potential Designs. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 189

Maximum Entropy Designs . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .190

Gaussian Process IMSE Optimal Designs. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 192

Borehole Model: A Sphere-Packing Example  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 192

Create the Sphere-Packing Design for the Borehole Data  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 193

Guidelines for the Analysis of Deterministic Data . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 194

Results of the Borehole Experiment . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 195



9
S

p
a
c
e
-F

illin
g

 D
e
s
ig

n
s

Chapter 9 Space-Filling Designs 181
Introduction to Space-Filling Designs

Introduction to Space-Filling Designs
Space-filling designs are useful for modeling systems that are deterministic or near-deterministic. One 
example of a deterministic system is a computer simulation. Such simulations can be very complex 
involving many variables with complicated interrelationships. A goal of designed experiments on these 
systems is to find a simpler empirical model that adequately predicts the behavior of the system over 
limited ranges of the factors.

In experiments on systems where there is substantial random noise, the goal is to minimize the variance 
of prediction. In experiments on deterministic systems, there is no variance but there is bias. Bias is the 
difference between the approximation model and the true mathematical function. The goal of 
space-filling designs is to bound the bias.

There are two schools of thought on how to bound the bias. One approach is to spread the design 
points out as far from each other as possible consistent with staying inside the experimental boundaries. 
The other approach is to space the points out evenly over the region of interest. 

The Space Filling designer supports the following design methods: 

Sphere Packing maximizes the minimum distance between pairs of design points.

Latin Hypercube maximizes the minimum distance between design points but requires even 
spacing of the levels of each factor. This method produces designs that mimic the uniform distri-
bution. The Latin Hypercube method is a compromise between the Sphere-Packing method and 
the Uniform design method.

Uniform minimizes the discrepancy between the design points (which have an empirical uniform 
distribution) and a theoretical uniform distribution. 

Minimum Potential spreads points out inside a sphere around the center.

Maximum Entropy measures the amount of information contained in the distribution of a set of 
data.

Gaussian Process IMSE Optimal creates a design that minimizes the integrated mean squared 
error of the Gaussian process over the experimental region.

Sphere-Packing Designs
The Sphere-Packing design method maximizes the minimum distance between pairs of design points. 
The effect of this maximization is to spread the points out as much as possible inside the design region.

Creating a Sphere-Packing Design

To use the Sphere-Packing method:

1 Select DOE > Space Filling Design. 

2 Enter responses and factors. (See “Enter Responses and Factors into the Custom Designer,” p. 59.)

3 Alter the factor level values, if necessary. For example, Figure 9.1 shows the two existing factors, X1 
and X2, with values that range from 0 to 1 (instead of the default –1 to 1). 



182 Space-Filling Designs Chapter 9
Sphere-Packing Designs

4 Click Continue in the dialog.

Figure 9.1 Space-Filling Dialog for Two Factors

5 In the design specification dialog, specify a sample size (Number of Runs). Figure 9.2 shows a sam-
ple size of eight. 

Figure 9.2 Space-Filling Design Dialog

6 Click Sphere Packing. 

JMP creates the design and displays the design runs and the design diagnostics. Figure 9.3 shows the 
Design Diagnostics panel open with 0.518 as the Minimum Distance. Your results might differ 
slightly from the ones below, but the minimum distance will be the same.

Figure 9.3 Sphere-Packing Design Settings and Design Diagnostics 

Change Values to 0 and 1
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7 Click Make Table. Use this table to complete the visualization example, described next.

Visualizing the Sphere-Packing Design

To visualize the nature of the Sphere-Packing technique, create an overlay plot, adjust the plot’s frame 
size, and add circles using the minimum distance from the diagnostic report shown in Figure 9.3 as the 
radius for the circles. Using the table you just created:

1 Select Graph > Overlay Plot. 

2 Specify X1 as X and X2 as Y, then click OK. 

3 Adjust the frame size so that the frame is square by right-clicking the plot and selecting 
Size/Scale > Size to Isometric. 

4 Right-click the plot and select Customize. When the Customize panel appears, click the plus sign 
to see a text edit area and enter the following script: 
For Each Row(Circle({:X1, :X2}, 0.518/2)) 
where 0.518 is the minimum distance number you noted in the Design Diagnostics panel. This 
script draws a circle centered at each design point with radius 0.259 (half the diameter, 0.518), as 
shown on the left in Figure 9.4. This plot shows the efficient way JMP packs the design points.

5 Now repeat the procedure exactly as described in the previous section, but with a sample size of 10 
instead of eight.

Remember to change 0.518 in the graphics script to the minimum distance produced by 10 runs. 
When the plot appears, again set the frame size and create a graphics script using the minimum dis-
tance from the diagnostic report as the diameter for the circle. You should see a graph similar to the 
one on the right in Figure 9.4. Note the irregular nature of the sphere packing. In fact, you can 
repeat the process a third time to get a slightly different picture because the arrangement is depen-
dent on the random starting point. 

Figure 9.4 Sphere-Packing Example with Eight Runs (left) and 10 Runs (right)
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Latin Hypercube Designs
In a Latin Hypercube, each factor has as many levels as there are runs in the design. The levels are 
spaced evenly from the lower bound to the upper bound of the factor. Like the sphere-packing method, 
the Latin Hypercube method chooses points to maximize the minimum distance between design 
points, but with a constraint. The constraint maintains the even spacing between factor levels.

Creating a Latin Hypercube Design

To use the Latin Hypercube method:

1 Select DOE > Space Filling Design. 

2 Enter responses, if necessary, and factors. (See “Enter Responses and Factors into the Custom 
Designer,” p. 59.)

3 Alter the factor level values, if necessary. For example, Figure 9.5 shows adding two factors to the 
two existing factors and changing their values to 1 and 8 instead of the default –1 and 1. 

Figure 9.5 Space-Filling Dialog for Four Factors

4 Click Continue. 

5 In the design specification dialog, specify a sample size (Number of Runs). This example uses a 
sample size of eight.

6 Click Latin Hypercube (see Figure 9.2). Factor settings and design diagnostics results appear similar 
to those in Figure 9.6, which shows the Latin Hypercube design with four factors and eight runs. 

Note: The purpose of this example is to show that each column (factor) is assigned each level only 
once, and each column is a different permutation of the levels.
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Figure 9.6 Latin Hypercube Design for Four Factors and Eight Runs with Eight Levels

Visualizing the Latin Hypercube Design

To visualize the nature of the Latin Hypercube technique, create an overlay plot, adjust the plot’s frame 
size, and add circles using the minimum distance from the diagnostic report as the radius for the circle.

1 First, create another Latin Hypercube design using the default X1 and X2 factors. 

2 Be sure to change the factor values so they are 0 and 1 instead of the default –1 and 1.

3 Click Continue.

4 Specify a sample size of eight (Number of Runs).

5 Click Latin Hypercube. Factor settings and design diagnostics are shown in Figure 9.7.

Figure 9.7 Latin Hypercube Design with two Factors and Eight Runs

6 Click Make Table. 

7 Select Graph > Overlay Plot. 

8 Specify X1 as X and X2 as Y, then click OK. 

9 Right-click the plot and select Size/Scale > Size to Isometric to adjust the frame size so that the 
frame is square.

The minimum 
distance
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10 Right-click the plot, select Customize from the menu. In the Customize panel, click the large plus 
sign to see a text edit area, and enter the following script: 
For Each Row(Circle({:X1, :X2}, 0.404/2)),
where 0.404 is the minimum distance number you noted in the Design Diagnostics panel 
(Figure 9.7). This script draws a circle centered at each design point with radius 0.202 (half the 
diameter, 0.404), as shown on the left in Figure 9.8. This plot shows the efficient way JMP packs 
the design points.

11 Repeat the above procedure exactly, but with 10 runs instead of eight (step 5). Remember to change 
0.404 in the graphics script to the minimum distance produced by 10 runs. 

You should see a graph similar to the one on the right in Figure 9.8. Note the irregular nature of the 
sphere packing. In fact, you can repeat the process to get a slightly different picture because the arrange-
ment is dependent on the random starting point. 

Figure 9.8 Comparison of Latin Hypercube Designs with Eight Runs (left) and 10 Runs (right)

Note that the minimum distance between each pair of points in the Latin Hypercube design is smaller 
than that for the Sphere-Packing design. This is because the Latin Hypercube design constrains the lev-
els of each factor to be evenly spaced. The Sphere-Packing design maximizes the minimum distance 
without any constraints. 

Uniform Designs
The Uniform design minimizes the discrepancy between the design points (empirical uniform distribu-
tion) and a theoretical uniform distribution. 

Note: These designs are most useful for getting a simple and precise estimate of the integral of an 
unknown function. The estimate is the average of the observed responses from the experiment.

1 Select DOE > Space Filling Design. 

2 Enter responses, if necessary, and factors. (See “Enter Responses and Factors into the Custom 
Designer,” p. 59.)

3 Alter the factor level values to 0 and 1. 
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4 Click Continue. 

5 In the design specification dialog, specify a sample size. This example uses a sample size of eight 
(Number of Runs).

6 Click the Uniform button. JMP creates this design and displays the design runs and the design diag-
nostics as shown in Figure 9.9. 

Note: The emphasis of the Uniform design method is not to spread out the points. The minimum 
distances in Figure 9.9 vary substantially. 

Figure 9.9 Factor Settings and Diagnostics for Uniform Space-Filling Designs with Eight Runs

7 Click Make Table. 

A Uniform design does not guarantee even spacing of the factor levels. However, increasing the number 
of runs and running a distribution on each factor (use Analyze > Distribution) shows flat histograms. 

Figure 9.10 Histograms are Flat for each Factor when Number of Runs is Increased to 20

Comparing Sphere-Packing, Latin Hypercube, and Uniform 
Methods

To compare space-filling design methods, create the Sphere Packing, Latin Hypercube, and Uniform 
designs, as shown in the previous examples. The Design Diagnostics tables show the values for the fac-
tors scaled from zero to one. The minimum distance is based on these scaled values and is the mini-
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mum distance from each point to its closest neighbor. The discrepancy value is the integrated difference 
between the design points and the uniform distribution.

Figure 9.11 shows a comparison of the design diagnostics for three eight-run space-filling designs. Note 
that the discrepancy for the Uniform design is the smallest (best). The discrepancy for the Sphere-Pack-
ing design is the largest (worst). The discrepancy for the Latin Hypercube takes an intermediate value 
that is closer to the optimal value. 

Also note that the minimum distance between pairs of points is largest (best) for the Sphere-Packing 
method. The Uniform design has pairs of points that are only about half as far apart. The Latin Hyper-
cube design behaves more like the Sphere-Packing design in spreading the points out.

For both spread and discrepancy, the Latin Hypercube design represents a healthy compromise solu-
tion.

Figure 9.11 Comparison of Diagnostics for Three Eight-Run Space-Filling Methods

Another point of comparison is the time it takes to compute a design. The Uniform design method 
requires the most time to compute. Also, the time to compute the design increases rapidly with the 
number of runs. For comparable problems, all the space-filling design methods take longer to compute 
than the D-optimal designs in the Custom Designer.

Sphere- 
Packing

Latin 
Hypercube

Uniform
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Minimum Potential Designs
The Minimum Potential design spreads points out inside a sphere. To understand how this design is 
created, imagine the points as electrons with springs attached to every other point, as illustrated to the 
right. The coulomb force pushes the points apart, but the springs pull them together. The design is the 
spacing of points that minimizes the potential energy of the system.

Minimum Potential designs:

• have spherical symmetry 

• are nearly orthogonal

• have uniform spacing

To see a Minimum Potential example:

1 Select DOE > Space Filling Design. 

2 Enter responses and factors. (See “Enter Responses and Factors into the Custom Designer,” p. 59.)

3 Alter the factor level values to 0 and 1, if necessary.

4 Click Continue. 

5 In the design specification dialog (shown on the left in Figure 9.12), enter a sample size (Number of 
Runs). This example uses a sample size of 12.

6 Click the Minimum Potential button. JMP creates this design and displays the design runs (shown 
on the right in Figure 9.12) and the design diagnostics.

Figure 9.12 Space-Filling Methods and Design Diagnostics for Minimum Potential Design

7 Click Make Table.

You can see the spherical symmetry of the Minimum Potential design using the Scatterplot 3D graphics 
platform.

1 After you make the JMP design table, choose the Graph > Scatterplot 3D command.
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2 In the Scatterplot 3D launch dialog, select X1, X2, and X3 as Y, Columns and click OK to see the 
initial three dimensional scatterplot of the design points.

3 To see the results similar to those in Figure 9.13, double-click on the axes to scale them, and use the 
Normal Contour Ellipsoids option from the menu in the Scatterplot 3D title bar.

Now it is easy to see the points spread evenly on the surface of the ellipsoid.

Figure 9.13 Minimum Potential Design Points on Sphere

Maximum Entropy Designs
The Latin Hypercube design is currently the most popular design assuming you are going to analyze 
the data using a Gaussian-Process model. Computer simulation experts like to use the Latin Hypercube 
design because all its projections onto the coordinate axes are uniform.

However, as the example at the top in Figure 9.14 shows, the Latin Hypercube design does not neces-
sarily do a great job of space filling. This is a two-factor Latin Hypercube with 16 runs. Note that this 
design appears to leave a hole in the bottom right of the overlay plot.
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Figure 9.14 Two-factor Latin Hypercube Design

The Maximum Entropy design is a competitor to the Latin Hypercube design for computer experi-
ments because it optimizes a measure of the amount of information contained in an experiment. See 
the technical note below. The two-factor Maximum Entropy design shown in Figure 9.15 covers the 
region better than the Latin hypercube design in Figure 9.14. The space-filling property improves as 
the number of runs increases without bound.

Figure 9.15 Two-Factor Maximum Entropy Design

Technical Note: Maximum Entropy designs maximize the Shannon information (Shewry and 
Wynn (1987)) of an experiment, assuming that the data come from a normal (m, s2 R) distribution, 
where

is the correlation of response values at two different design points, xi and xj. Computationally, these 
designs maximize |R|, the determinant of the correlation matrix of the sample. When xi and xj are far 
apart, then Rij approaches zero. When xi and xj are close together, then Rij is near one.

Note empty area in
Latin Hypercube design

Rij θk xik xjk–( )2

k
∑–

⎝ ⎠
⎜ ⎟
⎛ ⎞

exp=
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Gaussian Process IMSE Optimal Designs
The Gaussian process IMSE optimal design is also a competitor to the Latin Hypercube design because 
it minimizes the integrated mean squared error of the Gaussian process model over the experimental 
region.

You can compare the IMSE optimal design to the Latin Hypercube (shown previously in Figure 9.14). 
The table and overlay plot in Figure 9.16 show a Gaussian IMSE optimal design. You can see that the 
design provides uniform coverage of the factor region.

Figure 9.16 Comparison of Two-factor Latin Hypercube and Gaussian IMSE Optimal Designs

Note: Both the Maximum Entropy design and the Gaussian Process IMSE Optimal design were cre-
ated using 100 random starts. 

Borehole Model: A Sphere-Packing Example
Worley (1987) presented a model of the flow of water through a borehole that is drilled from the 
ground surface through two aquifers. The response variable y is the flow rate through the borehole in 
m3/year and is determined by the equation

There are eight inputs to this model.

rw = radius of borehole, 0.05 to 0.15 m

r = radius of influence, 100 to 50,000 m

Tu = transmissivity of upper aquifier, 63,070 to 115,600 m2/year

y
2πTu Hu Hl–( )

r rw⁄( )ln 1
2LTu

r rw⁄( )ln rw
2

Kw

---------------------------------------
Tu
Tl
------+ +

------------------------------------------------------------------------------------------=
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Hu = potentiometric head of upper aquifier, 990 to 1100 m

Tl = transmissivity of lower aquifier, 63.1 to 116 m2/year

Hl = potentiometric head of lower aquifier, 700 to 820 m

L = length of borehole, 1120 to 1680 m

Kw = hydraulic conductivity of borehole, 9855 to 12,045 m/year

This example is atypical of most computer experiments because the response can be expressed as a sim-
ple, explicit function of the input variables. However, this simplicity is useful for explaining the design 
methods.

Create the Sphere-Packing Design for the Borehole Data

To create a Sphere-Packing design for the borehole problem: 

1 Select DOE > Space Filling Design.

2 Click the red triangle icon on the Space Filling Design title bar and select Load Factors.

3 Open the Sample Data folder installed with JMP. In the DOE folder, open Borehole Factors.jmp 
from the Design Experiment folder to load the factors (Figure 9.17).

Figure 9.17 Factors Panel with Factor Values Loaded for Borehole Example

Note: The logarithm of r and rw are used in the following discussion.

4 Click Continue.

5 Specify a sample size of 32 runs, as shown in Figure 9.18.
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Figure 9.18 Space-Filling Design Method Panel Showing 32 Runs

6 Click the Sphere Packing button to produce the design. 

7 Click Make Table to make a table showing the design settings for the experiment. The factor set-
tings in the example table might not have the same ones you see when generating the design because 
the designs are generated from a random seed.

8 To see a completed data table for this example, open Borehole Sphere Packing.jmp (Figure 9.19) 
from the Design Experiment Sample Data folder installed with JMP. This table also has a table vari-
able that contains a script to analyze the data. The results of the analysis are saved as columns in the 
table. 

Figure 9.19 Borehole Sample Data

Guidelines for the Analysis of Deterministic Data

It is important to remember that deterministic data has no random component. As a result, p-values 
from fitted statistical models do not have their usual meanings. A large F statistic (low p-value) is an 
indication of an effect due to a model term. However, you cannot make valid confidence intervals 
about the size of the effects or about predictions made using the model.
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Residuals from any model fit to deterministic data are not a measure of noise. Instead, a residual shows 
the model bias for the current model at the current point. Distinct patterns in the residuals indicate 
new terms to add to the model to reduce model bias.

Results of the Borehole Experiment

The example described in the previous sections produced the following results:

• A stepwise regression of the response, log y, versus the full quadratic model in the eight factors, led 
to the prediction formula column. 

• The prediction bias column is the difference between the true model column and the prediction 
formula column. 

• The prediction bias is relatively small for each of the experimental points. This indicates that the 
model fits the data well. 

In real world examples, the true model is generally not available in a simple analytical form. As a result, 
it is impossible to know the prediction bias at points other than the observed data without doing addi-
tional runs.

In this case, the true model column contains a formula that allows profiling the prediction bias to find 
its value anywhere in the region of the data. To understand the prediction bias in this example:

1 Select Graph > Profiler. 

2 Highlight the prediction bias column and click the Y, Prediction Formula button.

3 Check the Expand Intermediate Formulas box, as shown at the bottom on the Profiler dialog in 
Figure 9.20, because the prediction bias formula is a function of columns that are also created by 
formulas.

4 Click OK.

The profile plots at the bottom in Figure 9.20 show the prediction bias at the center of the design 
region. If there were no bias, the profile traces would be constant between the value ranges of each fac-
tor. In this example, the variables Hu and Hl show nonlinear effects.
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Figure 9.20 Profiler Dialog and Profile of the Prediction Bias in the Borehole Sphere-Packing Data

The range of the prediction bias on the data is smaller than the range of the prediction bias over the 
entire domain of interest. To see this, look at the distribution analysis (Analyze > Distribution) of the 
prediction bias in Figure 9.21. Note that the maximum bias is 1.826 and the minimum is –0.684 (the 
range is 2.51). 

Figure 9.21 Distribution of the Prediction Bias

The top plot in Figure 9.22 shows the maximum bias (2.91) over the entire domain of the factors. The 
plot at the bottom shows the comparable minimum bias (–4.84). This gives a range of 7.75. This is 
more than three times the size of the range over the observed data.
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Figure 9.22 Prediction Plots showing Maximum and Minimum Bias Over Factor Domains

Keep in mind that, in this example, the true model is known. In any meaningful application, the 
response at any factor setting is unknown. The prediction bias over the experimental data underesti-
mates the bias throughout the design domain.

There are two ways to assess the extent of this underestimation:

• Cross-validation refits the data to the model while holding back a subset of the points and looks at 
the error in estimating those points.

• Verification runs (new runs performed) at different settings to assess the lack of fit of the empirical 
model.





Chapter 10
Nonlinear Designs

Design of experiments with models that are nonlinear in their parameters is available using either the 
DOE menu or the JMP Starter DOE category, as shown below.

Nonlinear designs offer both advantages and disadvantages compared to designs for linear models. 

On the positive side, predictions using a well chosen model are likely to be good over a wider range of 
factor settings. It is also possible to model response surfaces with more curvature and with asymptotic 
behavior.

On the negative side, the researcher needs a greater understanding of both the system and of the non-
linear design tool.

DOE Menu JMP Starter
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Examples of Nonlinear Designs
The Nonlinear Designer allows scientists to generate optimal designs and optimally augment data for 
fitting models that are nonlinear in their parameters. Such models, when they are descriptive of the 
underlying process, can yield more accurate prediction of process behavior than is possible with the 
standard polynomial models.

To use the Nonlinear Designer, you first need a data table that has 

• one column for each factor 

• one column for the response

• a column that contains a formula showing the functional relationship between the factor(s) and the 
response. 

This is the same format for a table you would supply to the nonlinear platform for modeling.

The first example in this section describes how to approach creating a nonlinear design when there is 
prior data. The second example describes how to approach creating the design without data, but with 
reasonable starting values for the parameter estimates.

Using Nonlinear Fit to Find Prior Parameter Estimates

Suppose you have already collected experimental data and placed it in a JMP data table. That table can 
be used to create a nonlinear design for improving the estimates of the model’s parameters. 

To follow along with this example, open Chemical Kinetics.jmp from the Nonlinear Examples folder 
found in the sample data installed with JMP.

Chemical Kinetics.jmp (Figure 10.1) contains a column (Model (x))whose values are formed by a for-
mula with a poor guess of the parameter values. 

Figure 10.1 Chemical Kinetics.jmp

First, fit the data to the model using nonlinear least squares to get better parameter values.

1 Select Analyze > Modeling > Nonlinear.

2 Select Velocity (y) and click Y, Response on the nonlinear launch dialog.

3 Select Model (x) and click X, Predictor Formula (see Figure 10.2). Note that the formula given by 
Model (X) shows in the launch dialog.
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Figure 10.2 Initial Nonlinear Analysis Launch Dialog

4 Click OK on the launch dialog to see the Nonlinear control panel.

5 Click the Go button on the Nonlinear control panel to see the results (Figure 10.3).

Figure 10.3 Nonlinear Fit Results

6 Click the Confidence Limits button to produce confidence intervals.

7 Click Save Estimates to add the new fitted parameter values in the Model (x) column in the 
Chemical Kinetics.jmp data table, which contains the formula:

These ranges are the intervals for Vmax 
and k. They are asymptotically normal. 
Use these limits to create a nonlinear 
design in JMP.

The Save Estimates button adds the new fitted 
parameter values in the Model (x) column in the 
Chemical Kinetics.jmp data table.

The Confidence Limits button computes confi-
dence intervals used to create a nonlinear design.



1
0

N
o

n
lin

e
a
r D

e
s
ig

n
s

Chapter 10 Nonlinear Designs 203
Examples of Nonlinear Designs

Note: Leave the nonlinear analysis report open because these results are needed in the DOE nonlinear 
design dialog described next. 

Now create a design for fitting the model’s nonlinear parameters.

1 With the Chemical Kinetics.jmp data table open, select DOE > Nonlinear Design.

2 Complete the launch dialog the same way as the Nonlinear Analysis launch dialog shown previously. 
That is, Select Velocity (y) and click Y, Response. Select Model (x) and click the X, Predictor 
Formula. Figure 10.4 shows the completed dialog.

Figure 10.4 Initial Nonlinear Design Launch Dialog

3 Click OK to see the completed Design panels for factors and parameters, as shown in Figure 10.5.

Figure 10.5 Nonlinear Design Panels for Factors and Parameters

Note that in Chemical Kinetics.jmp (Figure 10.1), the range of data for Concentration goes from 
0.417 to 6.25. Therefore, these values initially appear as the high and low values in the Factors control 
panel as follows:

4 Change the factor range for Concentration to a broader interval—from 0.1 to 7 (Figure 10.6).

Note that the a priori distribution of the parameters Vmax and k is Normal, which is correct for this 
example. Change the current level of uncertainty in the two parameters using the analysis results.

5 Look back at the analysis report inFigure 10.3 and locate the upper and lower confidence limits for 
Vmax and k in the Solution table. Change the values for Vmax and k to correspond to those limits, 
as shown in Figure 10.6.
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Now you have described the current level of uncertainty of the two parameters. 

Figure 10.6 Change Values for Factor and Parameters

6 If necessary, type the desired number of runs (15) into the text box.

Use commands from the menu on the Nonlinear Design title bar to get the best possible design:

7 Select Number of Starts from the menu on the title bar and enter 100 in the text box.

8 Select Advanced Options > Number of Monte Carlo Samples and enter 2 in the text box.

9 Click Make Design to preview the design (Figure 10.7). Your results may differ slightly than those 
shown for the additional runs.

Figure 10.7 Selecting the Number of Runs

10 Click Make Table. 

This creates a new JMP design table (Figure 10.8) whose rows are the runs defined by the nonlinear 
design. 

Note: This example creates a new table to avoid altering the sample data table Chemical Kinetics.jmp. 
In most cases, however, you can augment the original table using the Augment Table option in the 
Nonlinear Designer instead of making a new table. This option adds the new runs shown in the Design 
to the existing data table.
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Figure 10.8 Making a Table with the Nonlinear Designer

The new runs use the wider interval of allowed concentration, which leads to more precise estimates of 
k and Vmax.

Creating a Nonlinear Design with No Prior Data

This next example describes how to create a design when you have not yet collected data, but have a 
guess for the unknown parameters.

To follow along with this example, open Reaction Kinetics Start.jmp, found in the Design Experiment 
folder in the sample data installed with JMP. Notice that the table is a template. That is, the table has 
columns with properties and formulas, but there are no observations in the table. The design has not 
yet been created and data has not been collected. 

This table is used to supply the formula in the yield model column to the Nonlinear DOE platform. 
The formula is used to create a nonlinear design for fitting the model’s nonlinear parameters. The for-
mula looks like this:

This model is from Box and Draper (1987). The formula arises from the fractional yield of the inter-
mediate product in a consecutive chemical reaction. It is written as a function of time and temperature.

1 With the Reaction Kinetics Start.jmp data table open, select DOE > Nonlinear Design to see the 
initial launch dialog.

2 Select observed yield and click Y, Response.

3 Select yield model (the column with the formula) and click X, Predictor Formula.

The completed dialog should look like the one in Figure 10.9.
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Figure 10.9 Nonlinear Design launch Dialog 

4 Click OK to see the nonlinear design Factors and Parameters panels in Figure 10.10.

5 Change the two factors’ values to be a reasonable range of values. (In your experiment, these values 
might have to be an educated guess.) For this example, use the values 510 and 540 for Reaction 
Temperature. Use the values 0.1 and 0.3 for Reaction Time.

6 Change the values of the parameter t1 to 25 and 50, and t3 to 30 and 35.

7 Click on the Distribution of each parameter and select Uniform from the menu to change the distri-
bution from the default Normal (see Figure 10.10).

8 Change the number of runs to 12 in the Design Generation panel.

Figure 10.10 Change Factor Values, Parameter Distributions, and Number of Runs

9 Click Make Design, then Make Table. Your results should look similar to those in Figure 10.11.

Figure 10.11 Design Table

10 To analyze data that contains values for the response, observed yield, open Reaction Kinetics.jmp 
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from the Design Experiment folder in the sample data installed with JMP (Figure 10.12).

11 To analyze data that contains values for the response, observed yield, open Reaction Kinetics.jmp 
from the Design Experiment folder in the sample data installed with JMP (Figure 10.12).

Figure 10.12 Reaction Kinetics.jmp

First, examine the design region with an overlay plot.

12 Selecting Graph > Overlay Plot.

13 Select Reaction Temperature and click Y 

14 Select Reaction Time and click X as shown in the Overlay Plot launch dialog in Figure 10.13.

15 Click OK to see the overlay plot in Figure 10.13.

Figure 10.13 Create an Overlay Plot

Notice that the points are not at the corners of the design region. In particular, there are no points at 
low temperature and high time—the lower right corner of the graph.

16 Select Analyze > Modeling > Nonlinear.

17 Select observed yield and click Y, Response.

18 Select yield model and click the X, Predictor Formula, then click OK.

19 Click Go on the Nonlinear control panel.
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20 Now, choose Profilers > Profiler from the red triangle menu on the Nonlinear Fit title bar.

21 To maximize the yield, choose Maximize Desirability from the red triangle menu on the Prediction 
Profiler title bar. 

The maximum yield is approximately 63.5% at a reaction temperature of 540 degrees Kelvin and a 
reaction time of 0.1945 minutes.

Figure 10.14 Time and Temperature Settings for Maximum Yield

Creating a Nonlinear Design
To begin, open a data table that has a column whose values are formed by a formula (for details about 
formulas, see the JMP User Guide). This formula must have parameters. 

Select DOE >Nonlinear Design, or click the Nonlinear Design button on the JMP Starter DOE page. 
Then, follow the steps below:

• “Identify the Response and Factor Column with Formula,” p. 208

• “Set Up Factors and Parameters in the Nonlinear Design Dialog,” p. 209

• “Enter the Number of Runs and Preview the Design,” p. 210

• “Make Table or Augment the Table,” p. 211

Identify the Response and Factor Column with Formula

1 Open a data table that contains a column whose values are formed by a formula that has parameters. 
This example uses Corn.jmp from the Nonlinear Examples folder in the sample data installed with 
JMP.

2 Select DOE > Nonlinear Design to see the initial launch dialog.

3 Select yield and click Y, Response. The response column cannot have missing values.

4 Select quad and click X, Predictor Formula. The quad variable has a formula that includes nitrate 
and three parameters (Figure 10.15).
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5 Click OK on the launch dialog to see the Nonlinear Design DOE panels.

Figure 10.15 Identify Response (Y) and the Column with the Nonlinear Formula (X)

Set Up Factors and Parameters in the Nonlinear Design Dialog

First, look at the formula for quad, shown in Figure 10.16, and notice there are three parameters. 
These parameters show in the Parameters panel of the Nonlinear design dialog, with initial parameter 
values.

Figure 10.16 Formula for quad has Parameters a, b, and c

Use Figure 10.17 to understand how to set up factor and parameter names and values. 

• The initial values for the factor and the parameters are reasonable and do not need to be changed. 

• If necessary, change the Distribution of the parameters to Uniform, as shown in Figure 10.17.



210 Nonlinear Designs Chapter 10
Creating a Nonlinear Design

Figure 10.17 Example of Setting Up Factors and Parameters

Enter the Number of Runs and Preview the Design

1 The Design Generation panel shows a default number of runs needed to perform the experiment. 
This example needs one run for each observation (144) plus three additional runs for the three 
parameters giving 147 as a total minimum number of runs. Enter 147 in the Number of Runs edit 
box.

2 Click Make Design before creating the data table to preview the design. Figure 10.18 shows a par-
tial listing of the design.

Double-click to edit the factor 
or parameter name. Click to enter or change factor values.

Click to edit the distribution: Uniform, 
Normal, Lognormal, or Exponential.
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Figure 10.18 Example Preview Design

Make Table or Augment the Table

3 The last step is to click either Make Table or Augment Table. The Make Table command creates a 
new table (Figure 10.19) with all runs included. The Augment Table command adds the new runs 
to the existing table. 

Figure 10.19 Partial Listing of an Example Nonlinear Design Table

Advanced Options for the Nonlinear Designer
For advanced users, the Nonlinear Designer has the two additional options, as shown in Figure 10.20. 
These advanced options are included because finding nonlinear DOE solutions involves minimizing 
the integral of the log of the determinant of the Fisher information matrix with respect to the prior dis-
tribution of the parameters. These integrals are complicated and have to be calculated numerically. 

The way the integration is done for Normal distribution priors uses a numerical integration technique 
where the integral is reparameterized into a radial direction, and the number of parameters minus one 
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angular directions. The radial part of the integral is handled using Radau-Gauss-Laguerre quadrature 
with an evaluation at radius=0. A randomized Mysovskikh quadrature is used to calculate the integral 
over the spherical part, which is equivalent to integrating over the surface of a hypersphere.

Note: If some of the prior distributions are not Normal, then the integral is reparameterized so that 
the new parameters have normal distribution, and then the radial-spherical integration method is 
applied. However, if the prior distribution set for the parameters does not lend itself to a solution, 
sometimes the process fails and gives the message that the Fisher information is singular in a region of 
the parameter space, and advises changing the prior distribution or the ranges of the parameters.

Figure 10.20 Advanced Options for the Nonlinear Designer

The following is a technical description for these two advanced options:

Number of Monte Carlo Samples sets the number of octahedra per sphere. Because each octa-
hedron is a fixed unit, this option can be thought of as setting the number of octahedra per 
sphere. 

N Monte Carlo Spheres are the number of nonzero radius values used. The default is two 
spheres and one center point. Each radial value requires integration over the angular dimensions. 
This is done by constructing a certain number of hyperoctahedra (the generalization of an octa-
gon in arbitrary dimensions), and randomly rotating each of them.

Technical Note: The reason for the approach given by these advanced options is to get good inte-
gral approximations much faster than using standard methods. For instance, with six parameters, using 
two radii and one sample per sphere, these methods give a generalized five- point rule that needs only 
113 observations to get a good approximation. Using the most common approach (Simpson’s rule) 
would need 56 = 15,625 evaluations. The straight Monte Carlo approach also requires thousands of 
function evaluations to get the same level of quality in the answer.

Keep in mind that if the number of radii is set to zero, then just the center point is used, which gives a 
local design that is optimal for a particular value of the parameters. For some people this is good 
enough for their purposes. These designs are created much faster than if the integration is performed.
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Quality was the watchword of 1980s, and Genichi Taguchi was a leader in the growth of quality con-
sciousness. One of Taguchi’s technical contributions to the field of quality control was a new approach 
to industrial experimentation. The purpose of the Taguchi method was to develop products that worked 
well in spite of natural variation in materials, operators, suppliers, and environmental change. This is 
robust engineering.

Much of the Taguchi method is traditional. His orthogonal arrays are two-level, three-level, and 
mixed-level fractional factorial designs. The unique aspects of his approach are the use of signal and 
noise factors, inner and outer arrays, and signal-to-noise ratios.

The goal of the Taguchi method is to find control factor settings that generate acceptable responses 
despite natural environmental and process variability. In each experiment, Taguchi’s design approach 
employs two designs called the inner and outer array. The Taguchi experiment is the cross product of 
these two arrays. The control factors, used to tweak the process, form the inner array. The noise factors, 
associated with process or environmental variability, form the outer array. Taguchi’s signal-to-noise ratios 
are functions of the observed responses over an outer array. The Taguchi designer supports all these fea-
tures of the Taguchi method. You choose from inner and outer array designs, which use the traditional 
Taguchi orthogonal arrays, such as L4, L8, and L16.

Dividing system variables according to their signal and noise factors is a key ingredient in robust engi-
neering. Signal factors are system control inputs. Noise factors are variables that are typically difficult or 
expensive to control.

The inner array is a design in the signal factors and the outer array is a design in the noise factors. A sig-
nal-to-noise ratio is a statistic calculated over an entire outer array. Its formula depends on whether the 
experimental goal is to maximize, minimize or match a target value of the quality characteristic of inter-
est.

A Taguchi experiment repeats the outer array design for each run of the inner array. The response vari-
able in the data analysis is not the raw response or quality characteristic; it is the signal-to-noise ratio. 

The Taguchi designer in JMP supports signal and noise factors, inner and outer arrays, and sig-
nal-to-noise ratios as Taguchi specifies. 
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The Taguchi Design Approach
The Taguchi method defines two types of factors: control factors and noise factors. An inner design 
constructed over the control factors finds optimum settings. An outer design over the noise factors looks 
at how the response behaves for a wide range of noise conditions. The experiment is performed on all 
combinations of the inner and outer design runs. A performance statistic is calculated across the outer 
runs for each inner run. This becomes the response for a fit across the inner design runs. The table 
below lists the recommended performance statistics.

Taguchi Design Example
The following example is an experiment done at Baylock Manufacturing Corporation and described by 
Byrne and Taguchi (1986). The objective of the experiment is to find settings of predetermined control 
factors that simultaneously maximize the adhesiveness (pull-off force) and minimize the assembly costs 
of nylon tubing.

To follow along with this example, open the Byrne Taguchi Data.jmp table found in the Design Exper-
iment folder of the Sample Data installed with JMP. Or, generate the original design table on your own 
using DOE > Taguchi Arrays.

The signal and noise factors in the Byrne Taguchi Data for this example appear in the table below.

Table 11.1
Goal S/N Ratio Formula

nominal is best

larger-is-better (maximize)

smaller-is-better (minimize)
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Table 11.2
Factor Name Type Levels Comment

Interfer control 3 tubing and connector interference

Wall control 3 the wall thickness of the connector

Depth control 3 insertion depth of the tubing into the connector

Adhesive control 3 percent adhesive

Time noise 2 the conditioning time

Temperature noise 2 temperature

Humidity noise 2 the relative humidity
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To start this example:

1 Select DOE > Taguchi.

2 Click the red triangle icon on the Taguchi Design title bar and select Load Factors.

3 When the Open File dialog appears, open the factors table, Byrne Taguchi Factors.jmp found in 
the Design Experiment Sample Data folder installed with JMP.

The factors panel then shows the four three-level control (signal) factors and three noise factors, as 
shown in Figure 11.1.

Figure 11.1 Response, and Signal and Noise Factors for the Byrne-Taguchi Example

4 Highlight L9-Taguchi to give the L9 orthogonal array for the inner design.

5 Highlight L8 to give an eight-run outer array design.

6 Click Continue.

The outer design has three two-level factors. A full factorial in eight runs is generated. However, it is 
only used as a guide to identify a new set of eight columns in the final JMP data table—one for each 
combination of levels in the outer design.

7 Click Make Table to create the design table shown in Figure 11.2.
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Figure 11.2 Taguchi Design Before Data Entry

Now suppose the pull-off adhesive force measures are collected and entered into the columns contain-
ing missing data, as shown in Figure 11.3. The missing data column names are appended with the let-
ter Y before the levels (+ or –) of the noise factors for that run. For example, Y--- is the column of 
measurements taken with the three noise factors set at their low levels.

8 To see the completed experiment, open the data table, Byrne Taguchi Data.jmp found in the Design 
Experiment Sample Data folder installed with JMP. Figure 11.3 shows the completed design. 

Figure 11.3 Complete Taguchi Design Table (Byrne Taguchi Data.jmp)

The column named SN Ratio Y is the performance statistic computed with the formula shown below. 
In this case, it is the “larger-the-better” (LTB) formula, which is –10 times the common logarithm of 
the average squared reciprocal:

This expression is large when all of the individual y values are small. 

Analyze the Data

The data in Byrne Taguchi Data.jmp are now ready to analyze. The goal of the analysis is to find factor 
settings that maximize both the mean and the signal-to-noise ratio.

1 Click the red triangle icon next to Model on the upper left of the data table and select Run Script. 

–10Log10 [Mean[(Y– – –)2
1

(Y– – +)2
1
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1
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The Model script produces the Fit Model dialog shown in Figure 11.4.

The Fit Model dialog that appears automatically has the appropriate effects. It includes the main effects 
of the four signal factors. The two responses are the mean (Mean Y) and signal-to-noise ratio (SN Ratio 
Y) over the outer array. 

Figure 11.4 Fit Model Dialog for Taguchi Data

2 Click Run Model on the Fit Model dialog.

The prediction profiler is a quick way to find settings that give the highest signal-to-noise ratio for this 
experiment. 

3 To open the Prediction Profiler, click the red triangle on the Response Mean Y title bar and select 
Factor Profiling > Profiler.

The profile traces (Figure 11.5) indicate that different settings of the first three factors would increase 
SN Ratio Y. 

Figure 11.5 The Prediction Profiler

4 To find optimal settings, click the red triangle on the Prediction Profiler title bar and select 
Desirability Functions. This adds the row of traces and a column of function settings to the pro-
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filer, as shown in Figure 11.6. The default desirability functions are set to larger-is-better, which is 
what you want in this experiment. See the chapter “Standard Least Squares: Perspectives on the Esti-
mates” of JMP Statistics and Graphics Guide for more details about the prediction profiler.

5 Again click the red triangle on the Prediction Profiler title bar and select Maximize Desirability to 
automatically set the prediction traces that give the best results according to the desirability func-
tions.

In this example, the settings for Interfer and Wall changed from L1 to L2 (see Figure 11.5 and 
Figure 11.6). The Depth setting changed from L1 to L3. The settings for Adhesive did not change. 
These new settings increased the signal-to-noise ratio from 24.0253 to 26.9075.

Figure 11.6 Best Factor Settings for Byrne Taguchi Data

Creating a Taguchi Design
To start a Taguchi design, select DOE >Taguchi Arrays, or click the Taguchi Arrays button on the 
JMP Starter DOE page. Then, follow the steps below:

• “Detail the Response and Add Factors,” p. 219

• “Choose Inner and Outer Array Designs,” p. 220

• “Display Coded Design,” p. 221

• “Make the Design Table,” p. 221

Detail the Response and Add Factors

The Responses panel has a single default response. The steps for setting up the details of this response 
are outlined in Figure 11.7. For information on importance weights and lower and upper limits, see 
“Understanding Response Importance Weights,” p. 60.
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Figure 11.7 Setting Up the Response

The steps for setting up the factors are outlined in Figure 11.8. 

Figure 11.8 Entering Factors

When you finish adding factors, click Continue.

Choose Inner and Outer Array Designs

Your choice for inner and outer arrays depends on the number and type of factors you have. 
Figure 11.9 shows the available inner array choices when you have eight signal factors. If you also have 
noise factors, choices include designs for the outer array. To follow along, enter eight two-level Signal 
factors and click Continue. Then highlight the design you want and again click Continue. This exam-
ple uses the L12 design.

Click to change the response goal: 
Larger Is Better, Nominal is Best, 
Smaller is Better, or None.

Double-click to edit 
the response name.

Click to enter lower and upper 
limits and importance weights.

1 2

3

Double-click to edit 
the factor name.

To change the value of a signal or noise, 
click and then type the new value.

2

3

1

Click to add a signal, then select a 
signal type: 2 Level, or 3 Level. 

or

Click to add a noise.
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Figure 11.9 Selecting a Design for Eight Signal Factors

After you click Continue, a dialog appears that asks to you specify how many times you want to per-
form each inner array run. Specify one (1) for this example.

Display Coded Design

After you select a design type, click the disclosure buttons (  on Windows/Linux and  on the 
Macintosh) to display the Coded Design (Figure 11.10). 

Figure 11.10 Coding for Eight Factor L12 Design

The Coded Design shows the pattern of high and low values for the factors in each run. For more 
details on the coded design, see “Understanding Design Codes,” p. 104.

Make the Design Table 

When you click Make Table, a table similar to that shown in Figure 11.11 appears. In the data table, 
each row represents a run. In the values for the Pattern variable, plus signs designate high levels and 
minus signs represent low levels.
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Figure 11.11 Taguchi Design Table for Eight Factor L12 Design



Chapter 12
Augmented Designs

If you treat experimentation as an iterative process, you can master the temptation to assume that one 
successful screening experiment has optimized your process. You can also avoid disappointment if a 
screening experiment leaves behind some ambiguities. The augment designer helps facilitate experi-
mentation as an iterative process.

The augment designer modifies an existing design data table, supporting your iterative process. It gives 
the following five choices:

• replicate the design a specified number of times

• add center points

• create a foldover design

• add axial points together with center points to transform a screening design to a response surface 
design

• add runs to the design using a model that can have more terms than the original model

This chapter provides an overview of the augment designer. It also presents a case study of design aug-
mentation.
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A D-Optimal Augmentation of the Reactor Example
This example, adapted from Meyer, et al. (1996), demonstrates how to use the augment designer in 
JMP to resolve ambiguities left by a screening design. In this study, a chemical engineer investigates the 
effects of five factors on the percent reaction of a chemical process.

To begin, open Reactor 8 Runs.jmp found in the Design Experiment Sample Data folder installed 
with JMP. Then select Augment Design from the DOE menu. When the initial launch dialog appears:

1 Select Percent Reacted and click Y, Response.

2 Select all other variables except Pattern and click X, Factor.

3 Click OK on the launch dialog to see the Augment Design dialog in Figure 12.1.

Note: You can check Group New Runs into Separate Blocks to add a blocking factor to any design. 
However, the purpose of this example is to estimate all two-factor interactions in 16 runs, which can’t 
be done when there is the additional blocking factor in the model. 

Figure 12.1 Augment Design Dialog for the Reactor Example

4 Now click Augment on the Augment Design dialog to see the display in Figure 12.2. 

This model shown in Figure 12.2 is the result of the model stored with the data table when it was cre-
ated by the Custom designer. However, the augmented design is to have 16 runs in order to estimate all 
two-factor interactions. 
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Figure 12.2 Initial Augmented Model

 

To continue with the augmented reactor design: 

5 Choose 2nd from the Interactions menu as shown in Figure 12.3. This adds all the two-factor inter-
actions to the model. The Minimum number of runs given for the specified model is 16, as shown 
in the Design Generation text edit box.

Figure 12.3 Augmented Model with All Two-Factor Interactions

6 Click Make Design. 
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JMP now computes D-optimally augmented factor settings, similar to the design shown in Figure 12.4.

Figure 12.4 D-Optimally Augmented Factor Settings

Note: The resulting design is a function of an initial random number seed. To reproduce the exact fac-
tor settings table in Figure 12.4, (or the most recent design you generated), choose Set Random Seed 
from the popup menu on the Augment Design title bar. A dialog shows the most recently used random 
number. Click OK to use that number again, or Cancel to generate a design based on a new random 
number. The dialog in Figure 12.5 shows the random number (12834729) used to generate the runs in 
Figure 12.4.

Figure 12.5 Specifying a Random Number

7 Click Make Table to generate the JMP table with D-Optimally augmented runs.

Analyze the Augmented Design

Suppose you have already run the experiment on the augmented data and recorded results in the 
Percent Reacted column of the data table. 

1 To see these results, open Reactor Augment Data.jmp found in the Design Experiment Sample 
Data folder installed with JMP. 
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It is desirable to maximize Percent Reacted, however its column in this sample data table has a 
response limits column property set to Minimize.

2 Click the asterisk next to the Percent Reacted column name in the Columns panel of the data table 
and select Response Limits, as shown on the left in Figure 12.6.

3 In the Column Info dialog that appears, change the response limit to Maximize, as shown on the 
right in Figure 12.6.

Figure 12.6 Change the Response Limits Column Property for the Percent Reacted Column

You are now ready to run the analysis.

4 To start the analysis, click the red triangle for Model in the upper left of the data table and select 
Run Script from the menu, as shown in Figure 12.7. 

Figure 12.7 Completed Augmented Experiment (Reactor Augment Data.jmp)

The Model script, stored as a table property with the data, contains the JSL commands that display the 
Fit Model dialog with all main effects and two-factor interactions as effects. 

5 Change the fitting personality on the Fit Model dialog from Standard Least Squares to Stepwise, 
as shown in Figure 12.8.
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Figure 12.8 Fit Model Dialog for Stepwise Regression on Generated Model

6 When you click Run Model, the stepwise regression control panel appears. Click the check boxes for 
all the main effect terms. 

Important: Choose Mixed from the Direction menu and make sure Prob to Enter is 0.050 and Prob 
to Leave is 0.100. These are not the default values. You should see the dialog shown in Figure 12.9.

Figure 12.9 Initial Stepwise Model
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7 Click Go to start the stepwise regression and watch it continue until all terms are entered into the 
model that meet the Prob to Enter and Prob to Leave criteria in the Stepwise Regression Control 
panel. 

Figure 12.10, shows the result of this example analysis. Note that Feed Rate is out of the model while 
the Catalyst*Temperature, Stir Rate*Temperature, and the Temperature*Concentration interactions 
have entered the model.

Figure 12.10 Completed Stepwise Model

8 After Stepwise is finished, click Make Model on the Stepwise control panel to generate this reduced 
model, as shown in Figure 12.11. 

9 Click Run Model and fit the reduced model to do additional diagnostic work, make predictions, 
and find the optimal factor settings.
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Figure 12.11 New Prediction Model Dialog

The Analysis of Variance and Lack of Fit Tests in Figure 12.12, indicate a highly significant regression 
model with no evidence of Lack of Fit.

Figure 12.12 Prediction Model Analysis of Variance and Lack of Fit Tests

The Sorted Parameter Estimates table in Figure 12.13, shows that Catalyst has the largest main effect. 
However, the significance of the two-factor interactions are of the same order of magnitude as the main 
effects. This is the reason that the initial screening experiment, shown in the chapter “Screening 
Designs,” p. 89, had ambiguous results.
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Figure 12.13 Prediction Model Estimates Plot

10 Chose Maximimize Desirability from the menu on the Prediction Profiler title bar.

The prediction profile plot at the bottom in Figure 12.14, shows that maximum occurs at the high lev-
els of Catalyst, Stir Rate, and Temperature and the low level of Concentration. At these extreme set-
tings, the estimate of Percent Reacted increases from 65.17 to 98.38.

Figure 12.14 Maximum Percent Reacted

To summarize, compare the analysis of 16 runs with the analyses of reactor data from previous chapters: 

• “Screening Designs,” p. 89, the analysis of a screening design with only 8 runs produced a model 
with the five main effects and two interaction effects with confounding. None of the factors effects 
were significant, although the Catalyst factor was large enough to encourage collecting data for fur-
ther runs.

• “Full Factorial Designs,” p. 129, a full factorial of the five two-level reactor factors, 32 runs, was first 
subjected to a stepwise regression. This approach identified three main effects (Catalyst, 
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Temperature, and Concentration) and two interactions (Temperature*Catalyst, 
Contentration*Temperature) as significant effects.

• By using a D-optimal augmentation of 8 runs to produce 8 additional runs, a stepwise analysis 
returned the same results as the analysis of 32 runs. The bottom line is that only half as many runs 
yielded the same information. Thus, using an iterative approach to DOE can save time and money.

Creating an Augmented Design
The augment designer modifies an existing design data table. It gives the following five choices:

Replicate replicates the design a specified number of times. See “Replicate a Design,” p. 233.

Add Centerpoints adds center points. See “Add Center Points,” p. 235. 

Fold Over creates a foldover design. See “Creating a Foldover Design,” p. 236.

Add Axial adds axial points together with center points to transform a screening design to a 
response surface design. See “Adding Axial Points,” p. 237.

Augment adds runs to the design (augment) using a model, which can have more terms than the 
original model. See “Adding New Runs and Terms,” p. 238.

Replicate a Design

Replication provides a direct check on the assumption that the error variance is constant. It also reduces 
the variability of the regression coefficients in the presence of large process or measurement variability. 

To replicate the design a specified number of times:

1 Open a data table that contains a design you want to augment. This example uses Reactor 8 
Runs.jmp from the Design Experiment Sample Data folder installed with JMP.

2 Select DOE > Augment Design to see the initial dialog for specifying factors and responses.

3 Select Percent Reacted and click Y, Response.

4 Select all other variables (except Pattern) and click X, Factor to identify the factors you want to use 
for the augmented design (Figure 12.15). 

Figure 12.15 Identify Response and Factors

5 Click OK to see the Augment Design panel shown in Figure 12.16.
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6 If you want the original runs and the resulting augmented runs to be identified by a blocking factor, 
check the box beside Group New Runs into Separate Block on the Augment Design panel.

Figure 12.16 Choose an Augmentation Type

7 Click the Replicate button to see the dialog shown on the left in Figure 12.17. Enter the number of 
times you want JMP to perform each run, then click OK. 

Note: Entering 2 specifies that you want each run to appear twice in the resulting design. This is the 
same as one replicate (Figure 12.17).

8 View the design, shown on the right in Figure 12.17.

Figure 12.17 Reactor Data Design Augmented With Two Replicates

9 Click the disclosure icons next to Prediction Variance Profile and Prediction Variance Surface to see 
the profile and surface plots shown in Figure 12.18.
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Figure 12.18 Prediction Profiler and Surface Plot

10 Click Make Table to produce the design table shown in Figure 12.19. 

Figure 12.19 The Replicated Design

Add Center Points

Adding center points is useful to check for curvature and reduce the prediction error in the center of 
the factor region. Center points are usually replicated points that allow for an independent estimate of 
pure error, which can be used in a lack-of-fit test. 
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To add center points:

1 Open a data table that contains a design you want to augment. This example uses Reactor 8 
Runs.jmp found in the Design Experiment Sample Data folder installed with JMP.

2 Select DOE > Augment Design.

3 In the initial Augment Design dialog, identify the response and factors you want to use for the aug-
mented design (see Figure 12.15) and click OK. 

4 If you want the original runs and the resulting augmented runs to be identified by a blocking factor, 
check the box beside Group New Runs into Separate Block (Figure 12.16).

5 Click the Add Centerpoints button and type the number of center points you want to add. For this 
example, add two center points, and click OK.

6 Click Make Table to see the data table in Figure 12.20.

The table shows two center points appended to the end of the design.

Figure 12.20 Design with Two Center Points Added

Creating a Foldover Design

A foldover design removes the confounding of two-factor interactions and main effects. This is espe-
cially useful as a follow-up to saturated or near-saturated fractional factorial or Plackett-Burman 
designs.

To create a foldover design:

1 Open a data table that contains a design you want to augment. This example uses Reactor 8 
Runs.jmp, found in the Design Experiment Sample Data folder installed with JMP.

2 Select DOE > Augment Design.

3 In the initial Augment Design dialog, identify the response and factors you want to use for the aug-
mented design (see Figure 12.15) and click OK. 

4 Check the box to the left of Group New Runs into Separate Block (Figure 12.16). This identifies 
the original runs and the resulting augmented runs with a blocking factor.

5 Click the Fold Over button. A dialog appears that lists all the design factors.

6 Choose (select) which factors to fold. The default, if you choose no factors, is to fold on all design 
factors. If you choose a subset of factors to fold over, the remaining factors are replicates of the orig-
inal runs. The example in Figure 12.21 folds on all five factors and includes a blocking factor.

7 Click Make Table. The design data table that results lists the original set of runs as block 1 and the 
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new (foldover) runs are block 2.

Figure 12.21 Listing of a Foldover Design On All Factors 

Adding Axial Points

You can add axial points together with center points, which transforms a screening design to a response 
surface design. To do this:

1 Open a data table that contains a design you want to augment. This example uses Reactor 8 
Runs.jmp, from the Design Experiment Sample Data folder installed with JMP.

2 Select DOE > Augment Design.

3 In the initial Augment Design dialog, identify the response and factors you want to use for the aug-
mented design (see Figure 12.15) and click OK. 

4 If you want the original runs and the resulting augmented runs to be identified by a blocking factor, 
check the box beside Group New Runs into Separate Block (Figure 12.16).

5 Click Add Axial.

6 Enter the axial values in units of the factors scaled from –1 to +1, then enter the number of center 
points you want. When you click OK, the augmented design includes the number of center points 
specified and constructs two axial points for each variable in the original design.

Figure 12.22 Entering Axial Values

7 Click Make Table. The design table appears. Figure 12.23 shows a table augmented with two center 
points and two axial points for five variables.
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Figure 12.23 Design Augmented With Two Center and Ten Axial Points

Adding New Runs and Terms

A powerful use of the augment designer is to add runs using a model that can have more terms than the 
original model. For example, you can achieve the objectives of response surface methodology by chang-
ing a linear model to a full quadratic model and adding the necessary number of runs. Suppose you 
start with a two-factor, two-level, four-run design. If you add quadratic terms to the model and five 
new points, JMP generates the 3 by 3 full factorial as the optimal augmented design.

D-optimal augmentation is a powerful tool for sequential design. Using this feature you can add terms 
to the original model and find optimal new test runs with respect to this expanded model. You can also 
group the two sets of experimental runs into separate blocks, which optimally blocks the second set 
with respect to the first.

To add new runs and terms to the original model:

1 Open a data table that contains a design you want to augment. This example uses Reactor Augment 
Data.jmp, from the Design Experiment Sample Data folder installed with JMP.

2 Select DOE > Augment Design.

3 In the initial Augment Design dialog, identify the response and factors you want to use for the aug-
mented design (see Figure 12.15) and click OK. 

4 If you want the original runs and the resulting augmented runs to be identified by a blocking factor, 
check the box beside Group New Runs into Separate Block (not used in this example).

5 Click the Augment button. The original number of runs (Figure 12.24) appear in the Factor Design 
panel.

center points

axial points
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Figure 12.24 Viewing the Existing Design

6 In the Design Generation panel, enter the number of total runs you want this design to contain. 
The number you enter is the original number of runs plus the number of additional runs you want.

7 Click the Make Design button. The new number of runs (Figure 12.25) appear in the Design 
panel.
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Figure 12.25 24 Total Runs

8 If desired, view the prediction variance profile and the prediction variance surface.

9 Click Make Table to create the augmented design JMP table (Figure 12.26) with the additional 
runs.
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Figure 12.26 The Augmented Design Table with New Runs

Technical Note: The Augment designer does not support designs that have terms whose estimability 
has been set to If Possible instead of Necessary, as is done in some screening designs that have fewer 
runs than terms.

Special Augment Design Commands
After you select DOE > Augment Design and identify factors and responses, the window in 
Figure 12.27 appears. Click the red triangle icon on the Augment Design title bar to see a list of com-
mands. Most of these commands are for saving and loading information about variables; they are avail-
able in all designs and more information is in “Special Custom Design Commands,” p. 74. The 
following sections describe commands found in this menu that are specific to augment designs.

additional 
runs
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Figure 12.27 Click the Red Triangle Icon to Reveal Commands

Save the Design (X) Matrix

To create a script and save it as a table property in the JMP design data table, click the red triangle icon 
in the Augment Design title bar (Figure 12.27) and select Save X Matrix. The script is saved as a table 
property called Design Matrix. When you run this script, JMP creates a global matrix called X and dis-
plays its number of rows in the log. If you do not have the log visible, select View > Log or Window > 
Log on the Macintosh.

Modify the Design Criterion (D- or I- Optimality)

To modify the design optimality criterion, click the red triangle icon in the Augment Design title bar 
(Figure 12.28) and select Optimality Criterion, then choose Make D-Optimal Design or Make 
I-Optimal Design. The default criterion for Recommended is D-optimal for all design types unless 
you have used the RSM button in the Model panel to add effects that make the model quadratic.

Figure 12.28 Change the Optimality Criterion
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Select the Number of Random Starts

To override the default number of random starts, click the red triangle icon in the Augment Design title 
bar (Figure 12.28) and select Number of Starts. The window in Figure 12.29 appears with an edit box 
for you to enter the number of random starts for the design you want to build. The number you enter 
overrides the default number of starts, which varies depending on the design. 

Figure 12.29 Changing the Number of Starts

For additional information on the number of starts, see “Why Change the Number of Starts?,” p. 79.

Specify the Sphere Radius Value

Augment designs can be constrained to a hypersphere. To edit the sphere radius for the design in units 
of the coded factors (–1, 1), click the red triangle icon in the Augment Design title bar (Figure 12.27) 
and select Sphere Radius. Enter the appropriate value and click OK. 

Or, use JSL and submit the following command before you build a custom design:

DOE Sphere Radius = 1.0;

In this statement you can replace 1.0 with any positive number.

Disallow Factor Combinations

In addition to linear inequality constraints on continuous factors and constraining a design to a hyper-
sphere, you can define general factor constraints on the factors. You can disallow any combination of 
levels of categorical factors if you have not already defined linear inequality constraints. 

For information on how to do this, see “Disallowed Combinations: Accounting for Factor Level 
Restrictions,” p. 80.





Chapter 13
Prospective Power and Sample Size

Use the DOE > Sample Size and Power command to answer the question “How many runs do I 
need?” The important quantities are sample size, power, and the magnitude of the effect. These depend 
on the significance level—alpha—of the hypothesis test for the effect and the standard deviation of the 
noise in the response. You can supply either one or two of the three values. If you supply only one of 
these values, the result is a plot of the other two. If you supply two values, JMP computes the third.

Using the Sample Size and Power command when doing a prospective analysis helps answer the 
question, “Will I detect the group differences I am looking for, given my proposed sample size, estimate 
of within-group variance, and alpha level?” In this type of analysis, you must give JMP an estimate of 
the group means and sample sizes in a data table as well as an estimate of the within-group standard 
deviation (σ).

The sample size and power computations determine how large a sample is needed to be reasonably 
likely that an experiment or sample will yield a significant result, given that the true effect size is at least 
a certain size. It requires that you enter any two of three quantities, difference to detect, sample size, 
and power, and computes the third for the following cases:

• difference between one sample's mean and a hypothesized value

• difference between two samples means

• differences in the means among k samples

• difference between a standard deviation and a hypothesized value

• difference between one sample proportion and a hypothesized value

• difference between two sample proportions

• difference between counts per unit in a Poisson-distributed sample and a hypothesized value.

The calculations assume that there are equal numbers of units in each group. You can apply this plat-
form to more general experimental designs, if they are balanced, and a number-of-parameters adjust-
ment is specified. 
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Prospective Power Analysis

Prospective Power Analysis
The following five values have an important relationship in a statistical test on means:

Alpha Alpha is the significance level that prevents declaring a zero effect significant more than 
alpha portion of the time.

Error Standard Deviation Error Standard Deviation is the unexplained random variation around 
the means. An estimate of the Error Standard Deviation could be the root mean square error 
(RMSE) from a previous model fit.

Sample Size Sample size is how many experimental units (runs, or samples) are involved in the 
experiment.

Power Power is the probability of declaring a significant result.

Effect Size Effect size is how different the means are from each other or from the hypothesized 
value.

The Sample Size and Power command in JMP helps estimate in advance either the sample size 
needed, power expected, or the effect size expected in the experimental situation where there is a single 
mean or proportion comparison, a two sample or proportion comparison, when comparing k sample 
means, or when comparing counts per unit.

When you select DOE > Sample Size and Power, the panel shown in Figure 13.1 appears with button 
selections for experimental situations. The following sections describe each of these selections and 
explains how to enter estimated parameter values and the desired computation.

Figure 13.1 Sample Size and Power Choices
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One-Sample and Two-Sample Means
After you click either One Sample Mean, or Two Sample Means in the initial Sample Size selection 
list (Figure 13.1), the Power and Sample Size dialog in Figure 13.2 appears and asks for the anticipated 
experimental values. As an example, consider the two-sample situation.

Figure 13.2 Initial Power and Sample Size Dialogs for Single Mean (left) and Two Means (right)

 

The dialogs are the same except the One Mean dialog has a button at the bottom that accesses an ani-
mation script. 

The choice in the initial Power and Sample Size dialog always requires values for Alpha and the error 
standard deviation (Std Dev), and one or two of the other three values: Difference to detect, Sample 
Size, and Power. The power and sample size platform then calculates the missing item. If there are two 
unspecified fields, the power and sample size platform constructs a plot that shows the relationship 
between those two values:

• power as a function of sample size, given specific effect size

• power as a function of effect size, given a sample size

• effect size as a function of sample size, for a given power.

The Power and Sample Size dialog asks for these values:

Alpha Alpha is the significance level, usually 0.05. This implies willingness to accept (if the true 
difference between groups is zero) that 5% (alpha) of the time a significant difference will be 
incorrectly declared.

Std Dev Std Dev (error standard deviation) is the true residual error. Even though the true error is 
not known, the power calculations are an exercise in probability that calculates what might hap-
pen if the true value is the one you specify. An estimate of the Error Standard Deviation could be 
the root mean square error (RMSE) from a previous model fit.

Extra Parameters Extra Parameters is only for multi-factor designs. Leave this field zero in sim-
ple cases. In a multi-factor balanced design, in addition to fitting the means described in the situ-
ation, there are other factors with the extra parameters that can be specified here. For example, in 
a three-factor two-level design with all three two-factor interactions, the number of extra param-
eters is five—two parameters for the extra main effects, and three parameters for the interactions. 
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One-Sample and Two-Sample Means

In practice, it isn’t very important what values you enter here unless the experiment is in a range 
where there is very few degrees of freedom for error.

Difference to Detect Difference to detect is the smallest detectable difference (how small a dif-
ference you want to be able to declare statistically significant). For single sample problems this is 
the difference between the hypothesized value and the true value.

Sample Size Sample size is the total number of observations (runs, experimental units, or sam-
ples). Sample size is not the number per group, but the total over all groups. Computed sample 
size numbers can have fractional values, which you need to adjust to real units. This is usually 
done by increasing the estimated sample size to the smallest number evenly divisible by the num-
ber of groups.

Power Power is the probability of getting a statistic that will be declared statistically significant. 
Bigger power is better, but the cost is higher in sample size. Power is equal to alpha when the 
specified effect size is zero. You should go for powers of at least 0.90 or 0.95 if you can afford it. 
If an experiment requires considerable effort, plan so that the experimental design has the power 
to detect a sizable effect, when there is one.

Continue Evaluates at the entered values.

Back Goes back to the previous dialog.

Animation Script The Animation Script button runs a JSL script that displays an interactive plot 
showing power or sample size. See the section, “Power and Sample Size Animation for a Single 
Sample,” p. 250, for an illustration of this animation script.

Single-Sample Mean

Suppose there is a single sample and the goal is to detect a difference of 1.5 where the error standard 
deviation is 2, as shown in the left-hand dialog in Figure 13.3. To calculate the power when the sample 
size is 20, leave Power missing in the dialog and click Continue. The dialog on the right in 
Figure 13.3, shows the power is calculated to be 0.0.8888478174 (round to 0.89). 

Figure 13.3 A One-Sample Example
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To see a plot of the relationship of power and sample size, leave both Sample Size and Power empty in 
the dialog and click Continue.

The plots in Figure 13.4, show a range of sample sizes for which the power varies from about 0.1 to 
about 0.95. The plot on the right in Figure 13.4 shows using the crosshair tool to illustrate the example 
in Figure 13.3.

Figure 13.4 A One-Sample Example Plot

 

When only Sample Size is specified (Figure 13.5) and Difference to Detect and Power are empty, a 
plot of power by difference appears.

Figure 13.5 Plot of Power by Difference to Detect for a Given Sample Size

 

Power and Sample Size Animation for a Single Sample

The Animation Script button on the Power and Sample Size dialog for the single mean displays an 
interactive plot that illustrates the effect that changing the sample size has on power. The example in 
Figure 13.6 shows a Sample Size of 20, Alpha is 0.05, and the Difference to Detect is set to 1.5. The 
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One-Sample and Two-Sample Means

initial animation shows a normal curve positioned with mean at zero (representing the estimated mean 
and the true mean), and another with mean at 1.5 (the difference to be detected). The probability of 
committing a Type II error (not detecting a difference when there is a difference), often represented as 
β in literature, is shaded in blue on this plot. 

Select and drag the square handles to see the changes in statistics based on the positions of the curves. 
To change the values of Sample Size and Alpha, click on their values beneath the plot.

Figure 13.6 Example of Animation Script to Illustrate Power

Two-Sample Means

Choose Two Sample Means from the Power and Sample Size options (see Figure 13.1).The dialogs 
work similarly for one and two samples; the Difference to Detect is the difference between two means. 
Suppose the standard deviation is 2 (as before), the desired detectable difference is 1.5, and the sample 
size is 30 (15 per group). 

Leave Power blank and click Continue to see the power calculation, 0.509347, as shown in the dialog 
on the left in Figure 13.7. This result is considerably lower than in the single sample (0.89) because 
each mean has only half the sample size. The comparison is between two random samples instead of 
one sample and an hypothesized mean. 

To have a greater power requires a larger sample. To find out how large, leave both Sample Size and 
Power blank and examine the resulting plot, shown on the right in Figure 13.7. The crosshair tool esti-
mates that a sample size of about 78 is needed to obtain a power of 0.9.
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Figure 13.7 Plot of Power by Sample Size to Detect for a Given Difference 

 

k-Sample Means
The k-Sample Means situation can compare up to 10 means. The next example considers a situation 
where 4 levels of means are expected to be about 10 to 13, and the standard deviation is 0.9. When a 
sample size of 16 is entered the power calculation is 0.95, as shown in the dialog on the left in 
Figure 13.8.

If both Sample Size and Power are left blank, the power and sample size calculations produce the 
power curve shown on the right in Figure 13.8. This confirms that a sample size of 16 looks acceptable.

Notice that the difference in means is 2.236, calculated as square root of the sum of squared deviations 
from the grand mean. In this case it is the square root of (–1.5)2+ (–0.5)2+(0.5)2+(1.5)2, which is the 
square root of 5.
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One Sample Standard Deviation

Figure 13.8 Prospective Power for k-Means and Plot of Power by Sample Size

 

One Sample Standard Deviation
The One-Sample Standard Deviation choice on the Power and Sample Size dialog (Figure 13.1) 
determines sample size for detection of a change in standard deviation. The usual purpose of this 
option is to compute a large enough sample size to guarantee that the risk of accepting a false hypothe-
sis (β) is small. 

In the dialog, specify 

Alpha Alpha is the significance level, usually 0.05. This implies willingness to accept (if the true 
difference between standard deviation and the hypothesized standard deviation is zero) that 5% 
(alpha) of the time a significant difference will be incorrectly declared.

Hypothesized Standard Deviation Hypothesized or baseline standard deviation to which the sam-
ple standard deviation is compared.

Alternative Standard Deviation Select Larger or Smaller from the menu to indicate the direction 
of the change you want to detect.

In the lower part of the dialog you enter two of the items and the Power and Sample Size calculations 
determines the third.

The examples throughout the rest of this chapter use engineering examples from the online manual of 
The National Institute of Standards and Technology (NIST). You can access the NIST manual exam-
ples at http://www.itl.nist.gov/div898/handbook.

One example from the NIST manual states a problem in terms of the variance and difference to detect. 
The variance for resistivity measurements on a lot of silicon wafers is claimed to be 100 ohm-cm and 

http://www.itl.nist.gov/div898/handbook
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the buyer is unwilling to accept a shipment if the variance is greater than 155 ohm-cm for a particular 
lot (55 ohm-cm above the baseline of 100 ohm-cm).

The hypothesis to be tested is:

Ho: v1 = v2, where v1 is the hypothesized variance, and v2 = v1 plus the difference to detect.

In JMP, the computations use the standard deviation. The hypothesis is stated:

Ho: s1 = s2, where s1 is the hypothesized standard deviation, and s2 = s1 plus the difference to detect.

In this example the hypothesized standard deviation, s1, is 10 (the square root 100) and s2 is 12.4499 
(the square root of 100 + 55 = 155). The difference to detect is 12.4499 – 10 = 2.4499.

You want to detect an increase in the standard deviation of 2.4499 for a known hypothesized standard 
deviation of 10, with an alpha of 0.05 and power of 0.99. 

Enter these items as shown in Figure 13.9. When you click Continue, the computed result shows that 
you need a sample size of 171 (sample size rounded up the next whole number).

If you select Smaller from the Alternative Standard Deviation menu (you want to detect a change to a 
smaller standard deviation), enter a negative amount in the Difference to Detect box.

Figure 13.9 Dialog To Compare Single-Direction One-Sample Standard Deviation

 

One-Sample and Two-Sample Proportions
The dialogs and computations to test power and sample sizes for proportions are similar to those for 
testing sample means. You enter a baseline Proportion (known or hypothesized proportion) and choose 
an Alpha level. Then, for the one-sample proportion case, enter the Sample Size to obtain the esti-
mated Power or enter the Power to obtain the estimated Sample Size. You can also see a plot of 
Sample Size versus Power by leaving the two fields blank and clicking Continue. For the two-sample 
proportion case, either the two sample sizes or the desired Power must be entered. (See Figure 13.10 
and Figure 13.11). The sampling distribution for proportions is actually binomial, but the computa-
tions to determine sample size and test proportions use exact methods described in Agresti and Coull 
(1998).



1
3

P
o

w
e
r a

n
d

 S
a
m

p
le

 S
iz

e
Chapter 13 Prospective Power and Sample Size 255

One-Sample and Two-Sample Proportions

One Sample Proportion

The One Sample Proportion choice on the Power and Sample Size dialog (Figure 13.10) determines 
either a difference in proportion, the power, or the sample size, for detection of a change in proportion 
in a single sample from a known or hypothesized proportion. If you supply two of these quantities, the 
third is computed, or if you enter any one of the quantities, you see a plot of the other two. 

Often, there is a known proportion of defects (or other proportion of interest) and you want a large 
enough sample size to guarantee that the risk of accepting a false hypothesis (β) is small. That is, you 
want to detect, with reasonable certainty, a given increase in the proportion of defects.

For the one sample proportion, the hypothesis supported is 

and the two-sided alternative is 

where p is the true proportion and p0 is the null proportion to test against. 

In the top portion of the dialog, specify Alpha and the following quantity:

Proportion True proportion, which could be known or hypothesized.

In the bottom portion of the dialog, enter two of the following quantities to see the third, or a single 
quantity to see a plot of the other two.

Null Proportion Proportion to test against.

Sample Size Desired sample size, or blank for computation.

Power Desired power, or blank for computation.

For example, suppose an assembly line has a known proportion of defects of 0.3 and you want to know 
the power to detect when the proportion is different from 0.5 in a sample of 25. That is, you want to be 
able to detect a change of 0.2 in the proportion of defects, for an alpha level of 0.05 in a sample size of 
25. 

Click Continue to see the Power computation of approximately 0.7. 

H0: p p0=

Ha: p p0≠
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Figure 13.10 Power and Sample Dialog for One-Sample Proportions

 

Two Sample Proportions

The Two Sample Proportions choice computes the power or sample size needed to detect the differ-
ence between two proportions, p1 and p2. 

For the two sample proportion, the hypothesis supported is 

and the two-sided alternative is 

where p1 and p2 are the true proportions from two populations, and D0 is the hypothesized difference 
in proportions. 

If you enter any two of the three quantities (Null Difference in Proportion, Sample Size 1 and Sample 
Size 2, or Power), the third is computed. 

As an example, suppose Proportion 1 is 0.2, Proportion 2 is 0.4. You want to know the power for a 
sample size of 50 (25 in each group) to detect a difference of 0.175. 

In the Two Proportions dialog, enter:

1 0.2 as Proportion 1.

2 0.4 as Proportion 2. 

3 Enter 0.175 as the Null difference in Proportion. 

4 Enter 25 as Sample Size 1 and 25 as Sample Size 2 (for a total sample size of 50).

5 Leave Power blank.

The completed dialog should look like the one on the left in Figure 13.11.

6 Click Continue to see the right dialog in Figure 13.11, which shows the power calculation of 
approximately 0.83. 

H0: p1 p2– D0=

Ha: p1 p2– D0≠
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One-Sample and Two-Sample Proportions

Suppose you want to know the sample size needed to obtain a power of 0.9, that detects the same dif-
ference (0.175) and given the same observed proportions (0.2 and 0.4). 

7 Enter the power you want (0.9) and leave the two sample size edit boxes blank. 

8 Click Continue to see the results on the lower right in Figure 13.11. 

Equal sample sizes are computed (rounded to the next whole number). In this example, you need 30 in 
each group to obtain a power of 0.9 when detecting a difference in proportions of 0.175. 

Note: The computations for finding two sample sizes may take a little time so be patient.

Figure 13.11 Difference Between Two Proportions
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Counts per Unit 
The Counts per Unit selection from the Power and Sample size selection list calculates sample size for 
the Poisson-distributed counts typical when you can measure more than one defect per unit. A unit can 
be an area and the counts can be fractions or large numbers.

Although the number of defects observed in an area of a given size is often assumed to have a Poisson 
distribution, the area and count are assumed to be large enough to support a normal approximation.

Questions of interest are:

• Is the defect density within prescribed limits?

• Is the defect density greater than or less than a prescribed limit?

In the Counts per Unit dialog, enter Alpha and the Baseline Count per Unit. Then enter two of the 
remaining fields to see the calculation of the third. The test is for one-sided (one-tailed) change. Enter 
the Difference to Detect in terms of the Baseline Count per Unit (defects per unit). The computed 
sample size is expressed in those units, rounded to the next whole number. 

As an example, consider a wafer manufacturing process with a target of 4 defects per wafer and you 
want to verify that a new process meets that target within a difference of 2 defects per wafer. In the 
Counts per Unit dialog:

9 Enter an Alpha of 0.1 to be the chance of failing the test if the new process is as good as the target.

10 Enter 4 as the Baseline Counts per Unit, indicating the target of 4 defects per wafer.

11 Enter 2 as the Difference to detect. 

12 Enter a power of 0.9, which is the chance of detecting a change larger than 2 (6 defects per wafer). 
In this kind of situation, alpha is sometimes called the producer’s risk and beta is called the consumer’s 
risk.

13 Click Continue to see the results in Figure 13.12, showing a computed sample size of 9 (rounded to 
the next whole number). 

The process meets the target if there are less than 54 defects (6 defects per wafer in a sample of 9 
wafers).

Figure 13.12 Dialog For Counts Per Unit Example
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Sigma Quality Level

Sigma Quality Level
The Sigma Quality Level feature is a simple statistic that puts a given defect rate on a six sigma scale. 
For example, on a scale of one million opportunities, 3.397 defects results in a ‘6-sigma process. The 
computation that gives the Sigma Quality Level statistic is

Sigma Quality Level = NormalQuantile(1 – defects/opportunities) + 1.5

Select DOE > Sample Size and Power and then click the Sigma Quality Level button to see the Sam-
ple Size dialog:

Enter any two of the three quantities on the dialog:

• number of defects

• number of opportunities

• Sigma quality level

When you click Continue, the sigma quality calculator computes the missing quantity.

As an example, use the Sample Size and Power feature to compute the Sigma quality level for 50 defects 
in 1,000,000 opportunities:

1 Select DOE > Sample Size and Power.

2 Then, click the Sigma Quality Level button.

3 Enter 50 for the Number of Defects and 1,000,000 as the Number of Opportunities, as shown in 
the window to the left in Figure 13.13. 

4 Click Continue. The results, as shown in the window on the right in Figure 13.13, are a Sigma qual-
ity level for 5.39 defects in 1,000,000 opportunities.

Figure 13.13 Sigma Quality Level Example 1
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If you want to know how many defects reduce the Sigma Quality Level to ‘six-sigma’ for 1,000,000 
opportunities, enter 6 as the Sigma Quality Level and leave the Number of Defects blank (dialog on 
the left in Figure 13.14). The computation (dialog on the right in Figure 13.14) shows that the 
Number of Defects cannot be more than approximately 3.4.

Figure 13.14 Sigma Quality Level Example 2
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